Microsoft Excel

Herbers Excel/VBA-Archiv

Indirekt richtige Grundlage?


Betrifft: Indirekt richtige Grundlage? von: Jan
Geschrieben am: 13.08.2016 13:06:13

Hallo!

Ich baue gerade an einer Datei herum und komme nicht weiter. Zum besseren Verständnis habe ich die Datei beigefügt: https://www.herber.de/bbs/user/107594.xlsx

Im Tabellenblatt1 sind für diverse Monate verschiedene Werte hinterlegt.
Im Tabellenblatt2 sollen bestimmte Kennzahlen aus den in Blatt1 hinterlegten Werten berechnet werden.

Um Werte für bestimmte Monate zu berechnen, ist in Feld A1 eine Liste hinterlegt, über die erfassten Monate ausgewählt werden sollen.

Ich komme aber bei folgenden Versuchen leider nicht weiter:

(A) Die Monatsliste in Blatt1 wird kontinuierlich erweitert. Wie kann ich es erreichen, dass - sobald in Blatt2 über A1 z.B. Dezember ausgewählt wird und sich die Bezeichnungen in Zeile 1 anpassen - automatisch die richtigen Werte (aus Blatt1) für die Berechnung herangezogen werden? Ich habe mit dem Befehlt INDIREKT experimentiert. Das hat aber irgendwie nicht funktioniert.

Ich bin der Logik gefolgt, wenn in A1 = Dezember, dann wähle aus Tabelle1 die Spalte aus, die in Tabelle2 neben Dezember genannt wird. Damit wäre es ja einfacher, neue Monate zu ergänzen und in die Berechnungen einzubeziehen, ohne alle Formeln in Blatt2 manuell anpassen zu müssen. Ich will die Formeln so wenig statisch wie möglich halten.

(B) Wie kann ich die benachbarte Zelle rechts oder links vom jeweiligen Monat in meine Formel einbeziehen (z.B. den Mittelwert von März und dem Folgemonat berechnen), ohne die Formel statisch die das Tabellenblatt1 zu beziehen.

Habt ihr eventuell ein paar Tipps für mich?

Viele liebe Grüße und danke im Voraus
Jan

  

Betrifft: AW: Indirekt richtige Grundlage? von: Jan
Geschrieben am: 13.08.2016 13:10:58

Besteht denn auch die Möglichkeit, über Formeln zu definieren, dass ohne zu viele verschachtelte Wenn-Dann-Beziehungen in Tabelle2 den Spaltenwert heraussucht, der zum entsprechenden Monat gehört, sobald man in A1 eine Auswahl trifft?


  

Betrifft: AW: Indirekt richtige Grundlage? von: Jan
Geschrieben am: 13.08.2016 13:28:10

Ich habe es nun noch einmal mit folgender (vereinfachter) Vorgehensweise versucht:

=MITTELWERT((ADRESSE(2;SVERWEIS($A$1;A12:B23;2;FALSCH);4;1;Tabelle1));B12)

Aber der Ansatz funktioniert auch nicht wirklich...


  

Betrifft: Mittelwert Monat + Vormonat von: WF
Geschrieben am: 13.08.2016 14:59:36

Hi,

in B2:
=(INDEX(Tabelle1!$A$1:$Z$16;ZEILE($X2);VERGLEICH($A$1;Tabelle1!$A$1:$Z$1;0)) +INDEX(Tabelle1!$A$1:$Z$16;ZEILE($X2);VERGLEICH($A$1;Tabelle1!$A$1:$Z$1;0)-1)) /2
runterkopieren

B2 nach C2 kopieren und hinten die -1 in +1 ändern für den Mittelwert Monat + Folgemonat

Salut WF


  

Betrifft: AW: Mittelwert Monat + Vormonat von: Jan
Geschrieben am: 13.08.2016 16:11:41

Funktioniert einwandfrei. Vielen Dank!

Viele Grüße
Jan


Beiträge aus den Excel-Beispielen zum Thema "Indirekt richtige Grundlage?"