Microsoft Excel

Herbers Excel/VBA-Archiv

Kgrößte mit Text?


Betrifft: Kgrößte mit Text? von: Glanck
Geschrieben am: 02.05.2017 09:21:58

Hallo zusammen,

Ziel meiner kleinen Spielerei ist es eine Zeile einer Tabelle in einer zweiten Tabelle ausgeben zulassen wenn die Bedingung "Name" erfüllt ist.

https://www.herber.de/bbs/user/113232.xlsx

Das bedeutet in Tabelle 2 sollen alle Werte aus Tabelle 1 angezeigt werden welche den Namen Susanne zu zuordnen sind.

Das Ganze wollte ich ohne VBA oder einer Zwischenrechnung lösen.

{=KGRÖSSTE(($E$2:$E$7="Susanne")*A$2:A$7;1)}

setze ich in G2 ein und kopiere dementsprechend die Formel. Vorher ist die Formel in eine Matrixfkt. übergeben worden, weswegen die {}.

Ausgabe ist dann der Fehler Wert.

Habt Ihr einen Ansatz?

  

Betrifft: AW: Kgrößte mit Text? von: SF
Geschrieben am: 02.05.2017 09:28:36

Hola,

=WENNFEHLER(INDEX($A$2:$A$7;AGGREGAT(15;6;ZEILE($A$2:$A$7)-1/($E$2:$E$7="susanne");ZEILE(A1)));" _
")

Gruß,
steve1da


  

Betrifft: AW: Kgrößte mit Text? von: Glanck
Geschrieben am: 02.05.2017 09:36:28

Dankeschön! Funktioniert!

Über KGrösste kann es nicht ausgegeben werden weil? Mich würde mein Denkfehler interessieren.


  

Betrifft: AW: Kgrößte mit Text? von: SF
Geschrieben am: 02.05.2017 09:42:28

Hola,

deine Variante funktioniert nur, wenn in A2:A7 Zahlen stehen.

Gruß,
steve1da


  

Betrifft: es ist egal, ob in A2:A7 Text oder Zahl steht von: WF
Geschrieben am: 02.05.2017 13:27:16

Hi,

{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(E$1:E$99="Susanne";ZEILE($X1:$X99));ZEILE(X1)));"")}

Salut WF


  

Betrifft: falsche Dollarsetzung bei ZEILE von: WF
Geschrieben am: 02.05.2017 13:35:38

{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(E$1:E$99="Susanne";ZEILE(X$1:X$99));ZEILE(X1)));"")}

WF