Microsoft Excel

Herbers Excel/VBA-Archiv

Spalte addieren trotz ...


Betrifft: Spalte addieren trotz ... von: philipp b
Geschrieben am: 02.08.2017 10:05:33

Hallo,
guten Morgen.
Ich möchte gern die Spalte addieren obwohl die Zahlen als
Text hinterlegt sind.
Geht das ?

gruß
philipp b

  

Betrifft: mit SUMMENPRODUKT von: WF
Geschrieben am: 02.08.2017 10:25:20

Hi,

statt:
=SUMME(A1:A99)

schreibst Du:
=SUMMENPRODUKT(A1:A99*1)

WF


  

Betrifft: Ja aber mit Formel... von: philipp b
Geschrieben am: 02.08.2017 10:57:01

Hallo WF,
einwandfrei.
In der Spalte:
=WENN(i1="";"";RUNDEN(+i1/h1;2))
steht diese Formel.
Da wird #Wert angezeigt.

gruß
philipp b


  

Betrifft: bei auch echtem Text musst Du WENNen von: WF
Geschrieben am: 02.08.2017 11:51:37

Hi,

steht in der Spalte echter Text (Buchstaben etc. oder auch "")
folgende Arrayformel:
{=SUMME(WENN(ISTZAHL(A1:A99*1);A1:A99*1))}

WF

Eingabe Arrayformel:
Du kopierst Dir die Formel.
Dann gehst Du in die Bearbeitungszeile, löschst die {geschweiften Klammern} am Anfang und Ende und schließt ab mit GLEICHZEITIG: Strg Shift Enter (statt Enter allein). Dadurch werden diese Klammern erzeugt.


  

Betrifft: Danke WF und gut erklärt ! -) von: philipp b
Geschrieben am: 02.08.2017 12:20:52




Beiträge aus den Excel-Beispielen zum Thema "Spalte addieren trotz ..."