Microsoft Excel

Herbers Excel/VBA-Archiv

merkwürdiges Formelverhalten


Betrifft: merkwürdiges Formelverhalten von: Dietmar Schell
Geschrieben am: 11.10.2017 16:05:07

Hallo,
ich habe ein merkwürdiges Formelverhalten festgestellt, von dem ich nicht weiß wie ich es abstellen kann.
In einem Tabellenblatt steht in A5 die Formel
=Summe(A1:A3)

Gebe ich jetzt in A1, A2, A3 Werte ein, so bekomme ich die richtige Summe.
Gebe ich jetzt in A4 ebenfalls einen Wert ein, so ändert sich der Eintrag in A5 von selber auf
=Summe(A1:A4), was ich aber auf keinen Fall möchte.
Dieses Verhalten tritt auch mit anderen Formeln auf: Mittewert, Mittelwerta.
Selbst wenn die Formel sperrt und das Blatt geschützt ist ändert sich die Formel.
Weiß jemand Bescheid wie man das abstellt? Zelle A4 entfernen (also die Formel eine Zeile hochrücken) wäre nur Kosmetik, würde das Problem nicht beheben.

Wäre schöne, wenn ihr mir hier weiter helfen könnt.
Viele Grüße,
Dietmar

  

Betrifft: AW: merkwürdiges Formelverhalten von: yummi
Geschrieben am: 11.10.2017 16:07:49

Hallo Dietmar,

=SUMME($D$1:$D$3)

dann sind die Grenzen fix.

Gruß
yummi


  

Betrifft: AW: merkwürdiges Formelverhalten von: Dietmar Schell
Geschrieben am: 11.10.2017 16:18:17

Hallo,
tatsächlich ist das Problem mit fixen Grenzen gelöst ($). Vielen Dank!

Trotzdem bleibt es sehr merkwürdig, dass so etwas passiert.
Es geht sogar noch weiter (bei der "alten" Notation A1:A3):
Gebe ich in A4 einen Wert ein, ändert sich die Formel, nach Drücken von Steuerung + z (Rückgängig) verschwindet die letzte Eingabe (erwartungsgemäß) und sogar die Formel wird wieder auf A1:A3 zurück gesetzt. Können die Excel-Entwickler das gewollt haben?

Grüße, Dietmar


  

Betrifft: AW: merkwürdiges Formelverhalten von: Rainer
Geschrieben am: 11.10.2017 16:08:59

Hallo Dietmar,

Ich kann den Fehler leider nicht reproduzieren.

Tritt es auch auf bei =Summe($A$1:$A$3) ?

Gruß,

Rainer


  

Betrifft: versuchs mal mit absoluter Zelladressierung ;-) oT von: Matthias L
Geschrieben am: 11.10.2017 16:09:57




  

Betrifft: Das ist schlicht eine Einstellung... von: {Boris}
Geschrieben am: 11.10.2017 19:06:30

Hi Dietmar,

...in den Optionen - und zwar unter "Exceloptionen - Erweitert - Datenbereichsformate und Formeln erweitern".
Entferne den Haken, und der Bereich wird nicht automatisch angepasst.

VG, Boris


  

Betrifft: hast Du das getestet? Das stimmt nicht ... owT von: Matthias L
Geschrieben am: 11.10.2017 19:31:58




  

Betrifft: Klar hab ich das getestet... von: {Boris}
Geschrieben am: 11.10.2017 19:33:55

Hi Matthias,

...weshalb sollte es nicht stimmen?

VG, Boris


  

Betrifft: ich habs in 2 XL-Versionen geprüft ... von: Matthias L
Geschrieben am: 11.10.2017 19:38:20

Hallo Boris

In XL-2007 und Office 365

In beiden Versionen in denen man nur relative Zelladressierung benutzt, passiert das Selbe
Egal ob in den Optionen umgestellt oder nicht.
Ich will nichts besser wissen, aber ich habs tatsächlich getestet.

Gruß Matthias


  

Betrifft: AW: ich habs in 2 XL-Versionen geprüft ... von: Dietmar Schell
Geschrieben am: 11.10.2017 19:45:53

Hallo Matthias,
in Excel 2010 geht es. Schon komisch...

VG, Dietmar


  

Betrifft: ok, ich hab meine Testversionen ja angegeben von: Matthias L
Geschrieben am: 11.10.2017 19:48:37

und nur in diesen konnte ich es ja Testen
Wenns bei Deiner Version funktioniert, um so Besser :-)

Gruß Matthias


  

Betrifft: AW: ich habs in 2 XL-Versionen geprüft ... von: {Boris}
Geschrieben am: 11.10.2017 19:46:54

Hi Matthias,

also ich habe gerade xl2010 zu Hand - zufälliger Weise diese selbe Version wie der Frager.
Und da funzt es wie gewünscht.
Wenn die Option in den anderen Exceloptionen auch vorhanden ist UND nichts bewirkt, dann scheint es aber dort ein Bug zu sein...?

VG, Boris


  

Betrifft: ja Boris, das scheint tatsächlich so ... von: Matthias L
Geschrieben am: 11.10.2017 19:51:08

Ich teste das aber jetzt nochmal unter den angegebenen Bedingungen des Fragenden
und melde mich gleich nochmal.

Gruß Matthias


  

Betrifft: Kommando zurück ! von: Matthias L
Geschrieben am: 11.10.2017 19:57:27

Hi,

Ich hatte unter Excel-Optionen-Formel
Autovervollständigen-Formeln deaktiviert

Sorry, mein Fehler - war nicht unter "Erweitert".

Alles gut, auch in meinen Versionen

Danke und Gruß Matthias


  

Betrifft: :-) oT von: {Boris}
Geschrieben am: 11.10.2017 20:56:47

VG, Boris


  

Betrifft: AW: Klar hab ich das getestet... von: Dietmar Schell
Geschrieben am: 11.10.2017 19:43:13

Hallo Boris, hallo Daniel,

vielen Dank für euren Hinweis. Das war's! Immer schön wenn man außer einer Möglichkeit etwas zu umgehen (fixierte Werte) auch die Ursache für das Verhalten kennt.
Da ich die Datei weiter geben muss, bleibt trotzdem nur die Option "$", da diese nicht aufgehoben werden kann.
Das Wichtigste für mich: es ist kein Excel-Bug sondern nur eine "gut versteckte" beabsichtigte Eigenschaft.
Euch allen vielen Dank und einen schönen Abend,
Dietmar


  

Betrifft: AW: merkwürdiges Formelverhalten von: Daniel
Geschrieben am: 11.10.2017 19:10:57

HI

dieses Verhalten kannst du steuern, und zwar über

DATEI - OPTIONEN - ERWEITERT - BEARBEITUNGSOPTIONEN - Datenbereichsformate und -formeln erweitern
ist dieses Häkchen gesetzt, dann geht Excel davon aus, dass wenn du direkt unter einer Liste einen weiteren Wert einträgst, dieser Wert zu dieser Liste dazugehört und übernimmt die Formatierung aus den darüberliegenden Zellen und erweitert die Formeln, die sich auf diese Liste beziehen.
In den meisten Fällen dürfte dieses Verhalten sinnvoll sein und dem Anwender die Arbeit erleichtern.
Für alle anderen wie dich ist die Option abschaltbar.

Gruß Daniel





  

Betrifft: hast Du es getestet? Das stimmt nicht ... owT von: Matthias L
Geschrieben am: 11.10.2017 19:32:20




  

Betrifft: AW: hast Du es getestet? Das stimmt nicht ... owT von: Daniel
Geschrieben am: 11.10.2017 19:57:35

Hi Matthias
klar habe ich das getestet, mit Excel 2010 wie vom Fragesteller angegeben.
Funktioniert wie beschrieben.

mit Excel 2013 funktioniert es auch, dh die Formel wird nicht erweitert.
Allerdings erscheint an der Formel ein Hinweis, dass an den Bereich, auf den sich die Formel bezieht, noch Zahlen angrenzen und man hat mehrere Optionen zur Auswahl, was jetzt passieren soll.

also alles in allem kein Bug, sondern eine Frage der Einstellungen in den Optionen, mit denen man sich mal intensiver auseinander setzen sollte wenn Excel sich nicht wie gewünscht verhält.

Gruß Daniel


  

Betrifft: siehe meine Antwort an Boris ... von: Matthias L
Geschrieben am: 11.10.2017 20:02:56

also alles in allem kein Bug, sondern eine Frage der Einstellungen in den Optionen, mit denen man sich mal intensiver auseinander setzen sollte wenn Excel sich nicht wie gewünscht verhält.

Du solltest mich nicht schon wieder provozieren! Merk Dir das endlich mal.


  

Betrifft: AW: Ich provoziere dich dich nicht Matthias L von: Daniel
Geschrieben am: 11.10.2017 20:31:42

das war jetzt nur ein ganz allgemeiner Hinweis an Dietmar und alle anderen Excelnutzer, die das Verhalten von Excel komisch finden.


Gruß Daniel


  

Betrifft: Irrtum meinerseits siehe Antw. an Boris owT von: Matthias L
Geschrieben am: 11.10.2017 19:58:09