Microsoft Excel

Herbers Excel/VBA-Archiv

Verschachtelte WENN-/SUMMEWENNS vereinfachen


Betrifft: Verschachtelte WENN-/SUMMEWENNS vereinfachen von: Roland
Geschrieben am: 05.11.2017 11:19:30

Guten Morgen an alle,

nach längerer Zeit der Abstinenz mal ein Frage zur Vereinfachung einer bestehenden und funktionierenden Formelverkettung:

=WENN(C7=$H$1;SUMMEWENNS(H$1:H$4;F$1:F$4;A7;G$1:G$4;B7);WENN(C7=$I$1;SUMMEWENNS(I$1:I$4;F$1:F$4;A7;G$1:G$4;B7);WENN(C7=$J$1;SUMMEWENNS(J$1:J$4;F$1:F$4;A7;G$1:G$4;B7);0)))

https://www.herber.de/bbs/user/117440.xlsx

Die Formel funktioniert also einwandfrei. Ich frage mich nur, ob ich sie nicht deutlich einfacher und vlt. auch dynamischer darstellen kann. Komme allerdings hier nicht wirklich weiter ...

Über konkrete Hinweise würde ich mich sehr freuen!

Danke und herzliche Grüße,
Roland

  

Betrifft: INDEX von: lupo1
Geschrieben am: 05.11.2017 11:25:51

D7: =INDEX(H$2:J$4;VERGLEICH(B7;G$2:G$4;);VERGLEICH(C7;H$1:J$1;))

lässt sich 3d erweitern, wenn insgesamt Städte sich wiederholen über verschiedene Teams.


  

Betrifft: 3D von: lupo1
Geschrieben am: 05.11.2017 12:02:59

D7: =INDEX(H$2:J$4;VERGLEICH(A7&B7;INDEX(F$2:F$4&G$2:G$4;););VERGLEICH(C7;H$1:J$1;))

Ungültige Einträge ergeben gewollt #NV


  

Betrifft: AW: Verschachtelte WENN-/SUMMEWENNS vereinfachen von: Roland
Geschrieben am: 05.11.2017 12:16:27

@lupo1 = herzlichen Dank! Mit INDEX hatte ich ein wenig rumgespielt, es aber nicht hinbekommmen. Den #NV fange ich pragmatisch mit Istfehler und 0 ab.

VG Roland


  

Betrifft: Noch pragmatischer mit WENNFEHLER von: lupo1
Geschrieben am: 05.11.2017 12:19:18




  

Betrifft: AW: es geht auch noch etwas einfacher und ... von: ... neopa C
Geschrieben am: 05.11.2017 13:54:45

Hallo Roland

... und zunächst auch kürzer mit folgender Formel in D7:

=WENNFEHLER(AGGREGAT(15;6;H$2:J$4/(F$2:F$4&G$2:G$4=A7&B7)/(H$1:J$1=C7);1);"")

Und "dynamischer" kannst Du die Auswertung gestalten, wenn Du zuerst die Liste in F1:J4 mit der Funktion "Als Tabelle formatieren" in eine intelligente Tabelle wandelst.

Die Tabelle und die für die folgende Formel passt sich dann automatisch auf Datenerweiterung in dieser Tabelle an. Und wenn Du die Tabelle A6:D24 ebenfalls als solche Tabelle formatierst ist auch die deren Auswertung bei Erweiterung dynamisiert.

In D7 dann meine oben vorgeschlagene Formel entsprechend angepasst, dann so:

=WENNFEHLER(AGGREGAT(15;6;Tabelle1[[Junior-Spez]:[Senior-Spez]]/(Tabelle1[Team]&Tabelle1[Ort]=A7&B7) /(Tabelle1[[#Kopfzeilen];[Junior-Spez]:[Senior-Spez]]=C7);1);"")


Gruß Werner
.. , - ...


Beiträge aus den Excel-Beispielen zum Thema "Verschachtelte WENN-/SUMMEWENNS vereinfachen"