Microsoft Excel

Herbers Excel/VBA-Archiv

Was kniffliges für Zwischendurch


Betrifft: Was kniffliges für Zwischendurch von: MM
Geschrieben am: 21.11.2017 20:20:55

Hallo Leute!

Ich bin neu hier hab aber gleich mal ein (für mich sehr kniffliges) Problem. Ich grübel seit Tagen darüber, finde aber keine Lösung.

https://www.herber.de/bbs/user/117818.xlsx

Das ganze soll eine Auswertung sein.

In Spalte B werden manuell "X" oder "x" eingetragen.
In Spalte C-L stehen Werte, welche mit der Matrix (Spalte N) verglichen werden sollen.

Steht nun also in Spalte B ein "x" oder "X" dann soll in Spalte O bei JEDEM Wert (C-L) eins dazu gezählt werden.

Und um das ganze noch komplizierter zu machen stehen die Werte in C-L in keiner Reihenfolge (dh ein Wert kann in Spalte C stehen und 3 Zeilen weiter steht derselbe Wert in Spalte H). - und gleich vorweg, das kann nicht geändert werden, denn die Tabelle ist sehr sehr sehr umfangreich.

Kann mir jemand helfen??

  

Betrifft: AW: Was kniffliges für Zwischendurch von: Daniel
Geschrieben am: 21.11.2017 20:43:17

=SUMMENPRODUKT(($B$1:$B$10="x")*($C$1:$L$10=N1))

btw ein von Hand ausgezähltes, für das gezeigte Beispiel passende Ergebnis wäre hilfreich, weil man dann gleich sehen würde, ob der Lösungsvorschlag passt oder nicht.

Gruß Daniel


  

Betrifft: AW: Was kniffliges für Zwischendurch von: mm
Geschrieben am: 22.11.2017 16:13:57

https://www.herber.de/bbs/user/117840.xlsx


  

Betrifft: AW: nachgefragt ... von: ... neopa C
Geschrieben am: 21.11.2017 20:45:10

Hallo,

... unklar ist mir was Du mit bei "...JEDEM Wert (C-L) eins..." genau meinst.

Ansonsten ist es, wie eich es momentan interpretiere nicht komplziert, In O1

=SUMME(INDEX((C$1:L$99=N1)*(B$1:B$99="x");)) und nach unten kopieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: Was kniffliges für Zwischendurch von: Uduuh
Geschrieben am: 21.11.2017 20:45:41

Hallo,
meinst du
=SUMMENPRODUKT(($B$1:$B$10="x")*($C$1:$L$10=N1))
???

Gruß aus’m Pott
Udo



  

Betrifft: AW: ein Versuch von: Fennek
Geschrieben am: 21.11.2017 20:48:44

Hallo,

teste diesen Code:

Sub Main
for i = 1 to 10
	if lcase(cells(i,2)) = "x" then
		for j = 3 to 12
			if not isempty(cells(i,j)) then
				o = asc(cells(i,j)) -65
				range("P1").offset(o) = range("P1").offset(o) + 1
				msgbox cells(i,j), o
			end if
		next j
	end if
next i
End Sub
mfg


  

Betrifft: AW: passt doch (owT) von: Fennek
Geschrieben am: 22.11.2017 16:19:07




  

Betrifft: AW: Was kniffliges für Zwischendurch von: mm
Geschrieben am: 22.11.2017 16:12:50

Hallo Leute,

danke für die Lösungsvorschläge ich werde sie mal ausprobieren.
Um eure Formeln selbst zu prüfen habe ich euch unter folgendem Link


https://www.herber.de/bbs/user/117840.xlsx

die Lösung für die og. Datei von Hand angegeben. So sollte es dann aussehen. Egal an welcher Position (Spalten C-L) der selbe wert wie in Spalte N steht; sobald in der Selben Zeile vorne (Spalte B) ein "X" oder "x" steht soll in Spalte O gezählt werden.


  

Betrifft: AW: alle Formellösungen ergeben das Ergebnis owT von: ... neopa C
Geschrieben am: 22.11.2017 17:17:55

Gruß Werner
.. , - ...