Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS sortieren


Betrifft: SVERWEIS sortieren von: Jörg Bleicher
Geschrieben am: 26.01.2018 17:04:54

Hallo liebe Excel Gemeinde,
ich habe ein kleines Problem, ich habe eine Mitgliedsliste die mit Altersklassen versehen ist. Diese Altersklassen erstelle ich über einen SVERWEIS (Beispiel:"=SVERWEIS(Tabelle1!F2;Tabelle2!$A$2:$C$9;3;WAHR)"). Jetzt habe ich folgendes Problem wenn ich die Daten sortieren will stimmt die Altersklassen Zuordnung nicht mehr. Als wenn beim sortieren die Werte nicht mitgenommen werden.
Weiß jemand Rat?
Vielen Dank im voraus
Jögg

  

Betrifft: AW: Daten sortieren ... von: ... neopa C
Geschrieben am: 26.01.2018 17:36:27

Hallo Jörg,

... und wenn Du sortierte Daten auswertest, dann erhältst Du auch ein sortierte Ergebnislisting. Anderenfalls muss die Sortierung in einem entsprechenden Formelkonstrukt eingebaut werden. das wird dann aber wesentlicher komplexer.

Gruß Werner
.. , - ...


  

Betrifft: AW: SVERWEIS sortieren von: Robert Werner
Geschrieben am: 26.01.2018 18:20:44

Hallo Jörg,

bei mir funktioniert es einwandfrei. Kannst Du vielleicht eine Beispieldatei einstellen, damit man den Fehler sehen kann. Es reichen ja 2-3 Datensätze in der Mitgliederliste, die Du schnell anonymisieren kannst.

Gruß
Robert


  

Betrifft: AW: SVERWEIS sortieren von: Stephan A.
Geschrieben am: 30.01.2018 10:19:08

Hallo zusammen,

ich habe das gleiche oder so ein ähnliches Problem. Ich habe eine Liste aus Sharepoint in Excel exportiert die in Tabelle 1 ist. Über die SVERWEIS-Funktion gibt er mir leider nicht das aus was ich dort als Wert eingegeben habe.

https://www.herber.de/bbs/user/119393.xlsm

Ich bin für eure Hilfe dankbar.
Gruß Stephan


  

Betrifft: AW: SVERWEIS sortieren von: Robert Werner
Geschrieben am: 30.01.2018 18:12:17

Hallo Stephan,

das liegt an dem Suchkriterium und dem Bereichs_Verweis (1. und letztes Argument der SVerweis-Funktion).
Wenn der Bereich_Verweis WAHR angegeben wird, muss die Suchmatrix in aufsteigender Reihenfolge sortiert sein. Das ist bei Dir nicht der Fall. Aber selbst wenn es der Fall wäre funktioniert es nicht. Als Suchkriterium gibst Du "D0570896" ein. In der Matrix (owssvr!$A2:owssvr!$A68) gibt es exakt diesen Wert aber nicht. In der 2. Zeile der Matrix steht zwar "D0570896-0_Rev00 ABEFDDDDDDDDD", dieser Wert beginnt zwar mit dem Suckriterium, er ist aber nicht mit diesem identisch. Durch den Bereich_Verweis "WAHR" liefert die SVerweis-Funktion den nächst kleineren Wert, wenn das Suchkriterium nicht gefunden wird. Hättest Du als Bereich_Verweis "FALSCH" angegeben, würde die Funktion #NV für "Nicht vorhanden" liefern. Schau Dir mal die Online-Hilfe zu der Funktion SVerweis an.
Lösen kannst Du das Problem, indem Du dem Suchkriterium noch ein Jokerzeichen (*) anfügst und den Bereich_Verweis FALSCH angibst (mit WAHR funktioniert es nicht mit dem Jokerzeichen).

Folgende Formel müsste das korrekte Ergebnis liefern:
=SVERWEIS("D0570896*";owssvr!$A2:$A68;1;FALSCH)

Gruß
Robert


  

Betrifft: AW: SVERWEIS sortieren von: Jörg Bleicher
Geschrieben am: 30.01.2018 18:48:14

Hallo Robert,
ich habe eine Beispieldatei beigefügt, vielleicht kannst du sie dir anschauen und findest etwas heraus.
https://www.herber.de/bbs/user/119419.xlsx
Vielen Dank
Jörg


  

Betrifft: AW: SVERWEIS sortieren von: Robert Werner
Geschrieben am: 30.01.2018 19:12:31

Hallo Jörg,

ändere die Formel von (Beispiel für Zelle G2)

=SVERWEIS(Tabelle1!E2;Tabelle2!$A$2:$C$9;3;WAHR)

in

=SVERWEIS(E2;Tabelle2!$A$2:$C$9;3;WAHR)

dann klappt es. Durch die Angabe der Tabelle beim Suchkriterium in Deiner Formel behandelt Excel die Formel beim Sortieren so, wie wenn das Suchkriterium in einer anderen Tabelle (z. B. Tabelle3) stehen würde. In dem Fall, hätte eine Sortierung in der Tabelle1 ja keinen Einfluss auf die Tabelle3. Dann müsste sich das Suchkriterium, z. B. in der Formel für "Fuzzi, Thomas", vor und nach der Sortierung immer auf die Zelle E2 der Tabelle3 beziehen.
Da dies bei Dir ja nicht der Fall ist, einfach nur den Zellbezug ohne Tabellennamen als Suchkriterium angeben.

Gruß
Robert


  

Betrifft: AW: SVERWEIS sortieren von: Jörg Bleicher
Geschrieben am: 30.01.2018 19:24:44

Hallo Robert,
herzlichen Dank und es war wieder so einfach, Wahnsinn!
Da wäre ich nie drauf gekommen, nochmals herzlichen Dank.
LG
Jörg


  

Betrifft: Gerne (owT) von: Robert Werner
Geschrieben am: 30.01.2018 19:27:16




Beiträge aus dem Excel-Forum zum Thema "SVERWEIS sortieren"