Microsoft Excel

Herbers Excel/VBA-Archiv

=Zelle + 25


Betrifft: =Zelle + 25 von: Sabrina
Geschrieben am: 02.02.2018 22:39:54

Hallo Leute

Ich habe in Zelle AA:1 =A1, in Zelle AA:2 =A2 bis AA:24 =A24 stehen.
Jetzt soll in AB2 =A26, in AC3 soll =A51 ... stehen.

Also immer 25 mehr.

Kann mir jemand Helfen wie das geht?

LG Sabbel

  

Betrifft: AW: =Zelle + 25 von: Sepp
Geschrieben am: 02.02.2018 22:50:06

Hallo Sabrina,

für AB2 und runterziehen.

=INDEX(A:A;ZEILE(A1)*25+1)

Gruß Sepp



  

Betrifft: Aus 1 Dim werden 2 DIM von: lupo1
Geschrieben am: 03.02.2018 10:45:25

... daher IMMER beides, nämlich ZEILE und SPALTE:

AA1: =INDEX($A:$A;ZEILE(A1)+(SPALTE(A1)-1)*25)


  

Betrifft: AW: Aus 1 Dim werden 2 DIM von: Sulprobil
Geschrieben am: 04.02.2018 09:14:54

Man könnte noch die Grenzen checken, damit die Formel außerhalb des gewünschten Bereiches keine Werte zeigt:
=WENN(UND(ZEILE()=MEDIAN(ZEILE();1;25);SPALTE()=MEDIAN(SPALTE();SPALTE($AA$1);SPALTE($AZ$1))); INDEX($A:$A;ZEILE()+25*(SPALTE()-SPALTE($AA$1)));"")

Viele Grüße,
Bernd P


  

Betrifft: Hm ... also Schutz eines unmündigen Anwenders? von: lupo1
Geschrieben am: 04.02.2018 10:03:44

Solche Fehlerbehandlungen kann man vom Hündchen bis zum Stöckchen betreiben. Excel ist nun mal ein verantwortungsheischendes Instrument.

Ärgerlich finde ich bspw. die abweichende Behandlung des ersten von n Datensätzen in folgendem Beispiel:

Das gewünschte B2: =B1+A2 wird zu =SUMME(B1;A2), wenn man bei einer Überschrift in B1 nicht B2: =A2 verwenden möchte.

Startet man hingegen erst in B3, kann man die erste Formel mit "no frills" so belassen.

Und für eine rollierende Summe über die letzten 12 Monate startet man halt erst in

B13: =SUMME(A2:A13) und lässt die ersten 11 Zellen B2:B12 (nach der Überschrift in Zeile 1) leer.


  

Betrifft: AW: Hm ... also Schutz eines unmündigen Anwenders? von: Sulprobil
Geschrieben am: 04.02.2018 20:22:36

Hallo Alexander,
Niemand hier ist unmündig.
Mir ist auch nicht klar warum so ein Bereich umformatiert werden muss.
Aber so ist es nun mal.
Wir arbeiten mit unvollständiger Information.
Viele Grüße,
Bernd P