Microsoft Excel

Herbers Excel/VBA-Archiv

Formel


Betrifft: Formel von: Markus
Geschrieben am: 14.01.2019 13:21:13

Hallo Forum,

ich hab eine Excel-Datei,
in Tabelle 1 in Spalte A stehen Datumsangaben (TT.MM.JJ) übers ganze Jahr verteilt
in Tabelle 1 in Spalte B stehen Abteilungskürzel H1 G7 KL usw.

nun möchte ich in Tabelle 2 eine Auswertung vornehmen
ich möchte wissen wie oft kam die Abteilung H1 im Januar vor, im Februar usw.
Ich habe es schon mit ZÄHLENWENN und SUMMENPRODUKT versucht aber irgendwie klappt das nicht.
Gruß Markus

  

Betrifft: AW: Formel von: SF
Geschrieben am: 14.01.2019 13:26:03

Hola,

=summenprodukt((monat(A2:A500)=1)*(A2:A500<>"")*(B2:B500="h1"))
Gruß,
steve1da


  

Betrifft: AW: Formel von: UweD
Geschrieben am: 14.01.2019 13:38:29

Hallo

so???


Tabelle1

 AB
1DatumAbteilung
201.01.2018H1
311.02.2018H1
401.03.2018G7
501.01.2018H1
601.01.2018G7
701.04.2018H1
801.01.2018H1
901.01.2018G7
1001.01.2018KL
1101.05.2018H1
1201.01.2018H1
1310.07.2018H1
1401.01.2018KL
1501.04.2018H1
1601.01.2018KL
1701.01.2018H1
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit




Tabelle2
 ABCDEFGHIJKLM
1AbteilungJan 2018Feb 2018Mrz 2018Apr 2018Mai 2018Jun 2018Jul 2018Aug 2018Sep 2018Okt 2018Nov 2018Dez 2018
2G7201000000000
3H1510210100000
4KL300000000000

verwendete Formeln
Zelle Formel Bereich N/A
B2:M4=SUMMENPRODUKT((MONAT(Tabelle1!$A$2:$A$100)=MONAT(Tabelle2!B$1))*(JAHR(Tabelle1!$A$2:$A$100)=JAHR(Tabelle2!B$1))*(Tabelle1!$B$2:$B$100=$A2))  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit




LG UweD


  

Betrifft: AW: Formel von: Markus
Geschrieben am: 14.01.2019 13:45:52

Super, Danke für die Blitzantwort


  

Betrifft: Prima! Danke für die Rückmeldung. owT von: UweD
Geschrieben am: 14.01.2019 15:33:19




Beiträge aus dem Excel-Forum zum Thema "Formel"