Microsoft Excel

Herbers Excel/VBA-Archiv

Daten vom Vorjahr übernehmen


Betrifft: Daten vom Vorjahr übernehmen von: mike49
Geschrieben am: 23.01.2019 23:07:08

Hallo Leute,

ich hätte gerne mit einem kleinen Makro die Werte aus Zellen in die danebenliegenden übertragen werden und die bestehenden Werte mit diesen überschrieben werden. Die Zellen sollen dann für eine Neueingabe wieder leer sein.D.h.:
Es sollen die Werte aus den Zellen C6,C7,C8,C10,C11 und C16,C17,C19 sowie C24,C25,C26,C31 in die danebenliegenden Zellen der Spalte B übertragen werden. Die Spalte C soll dann leer sein.
Wie müsste das Makro lauten?

Gruß mike49

  

Betrifft: Zeichne... von: Bernd
Geschrieben am: 24.01.2019 05:23:24

Hi,

es mit dem Macrorecorder auf, dann weißt Du wie der Code aussieht.

MfG Bernd


  

Betrifft: AW: Daten vom Vorjahr übernehmen von: Hans W. Herber
Geschrieben am: 24.01.2019 06:59:00

Hallo Mike,

wie folgt:

Sub WerteUebertragen()
   Dim rng As Range, rngAll As Range
   
   Set rngAll = Range("C6,C7,C8,C10,C11,C16,C17,C19,C24,C25,C26,C31")
   
   For Each rng In rngAll.Cells
      rng.Offset(0, -1).Value = rng.Value
      rng.ClearContents
   Next rng
End Sub
Gruss hans


  

Betrifft: AW: Daten vom Vorjahr übernehmen von: Hans W. Herber
Geschrieben am: 24.01.2019 07:02:04

... oder besser:

Sub WerteUebertragen()
   Dim rngAll As Range
   
   Set rngAll = Range("C6,C7,C8,C10,C11,C16,C17,C19,C24,C25,C26,C31")
   rngAll.Offset(0, -1).Value = rngAll.Value
   rngAll.ClearContents
End Sub



  

Betrifft: AW: Daten vom Vorjahr übernehmen von: mike49
Geschrieben am: 24.01.2019 10:24:39

Hallo Hans,

danke für die rasche Hilfe.
Aber irgendwie habe ich mich nicht richtig ausgedrückt.
Es soll der Wert aus C6 nach B6, der Wert aus C7 nach B7, der Wert aus C8 nach B8 usw. übernommen werden.

Gruß mike49


  

Betrifft: Genau das wird doch gemacht! Gruß owT von: Luc:-?
Geschrieben am: 24.01.2019 10:33:28

:-?


  

Betrifft: AW: Daten vom Vorjahr übernehmen von: Andrro
Geschrieben am: 24.01.2019 10:33:59

Hallo Mike,

dann ändere die Verschiebung wie folgt:

rngAll.Offset(-1, 0).Value = rngAll.Value

gruß Andrro


  

Betrifft: AW: Daten vom Vorjahr übernehmen von: mike49
Geschrieben am: 24.01.2019 11:32:57

Hallo Andrro,
bei mir funktioniert das nicht. Meine Datei sieht so aus:
Zählerstände

 ABC
1Zählerstände 2018 
2   
3Wasser31.12.201731.12.2018
4
5kalt  
6                 EG 1,000  
7                 DG 2,000  
8                 OG 3,000  
9warm  
10                 EG 4,000  
11                 OG 5,000  
12   
13   
14Wärmemengenzähler31.12.201731.12.2018
15MWhMWh
16                 EG FBH 6,000  
17                 EG HK 7,000  
18Summe 13,000  
19                 OG 8,000  
20   
21   
22Stromzwischenzähler31.12.201731.12.2018
23kWhMWh
24Zählerstand 9.996
25Arbeitspreis o. MWSt 24,49200 ct/kWh
26Grundgebühr o. MWSt 75,00 €
27   
28   
29Ölstand31.12.201731.12.2018
30LiterLiter
31Heizöl 3.400

Formeln der Tabelle
ZelleFormel
B3=DATUM(B1-1;12;31)
C3=DATUM(B1;12;31)
B14=B3
C14=C3
B18=WENN(B16="";"";SUMME(B16:B17))
C18=SUMME(C16:C17)
B22=B3
C22=C3
B29=B3
C29=C34


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Es sollen die Werte aus den Zellen in Spalte C (außer C18. Ist Summenformel)je einzeln in die Zellen der Spalte B. Also: Der Wert 1 in C6 soll nach B6 übertragen werden. C6 soll dann leer sein, Der Wert 2 in C7 soll nach B7 übertragen werden. C7 soll dann leer sein usw.
Gruß mike49


  

Betrifft: AW: Daten vom Vorjahr übernehmen von: Hans W. Herber
Geschrieben am: 24.01.2019 14:22:03

Hallo Mike,

ich wüsste wirklich nicht, was da nicht funktionieren sollte. Ich habe Deine Tabelle in Excel übernommen, meinen Code und eine Schaltfläche hinzugefügt. Sage mir bitte was da nicht funktioniert:
https://www.herber.de/bbs/user/127065.xlsb


  

Betrifft: AW: Daten vom Vorjahr übernehmen von: mike49
Geschrieben am: 24.01.2019 15:57:26

Hallo Hans,

ich kann mir das nicht erklären.
Ich habe deine Mappe heruntergeladen. Wenn ich jetzt das Makro über die Schaltfläche ausführe, steht bei mir in allen Zellen in der Spalte B jeweils der Wert 1,000 drin!In den Zeilen 33 bis 38 stehen Werte, die ich nicht weiß wo die herkommen!

Gruß mike49


  

Betrifft: AW: Daten vom Vorjahr übernehmen von: Hans W. Herber
Geschrieben am: 25.01.2019 09:17:16

Hallo Mike,

sorry, mein Fehler, die erste Code-Version war die richtige. Bitte folgende Datei runterladen:
https://www.herber.de/bbs/user/127091.xlsb

gruß hans


Beiträge aus dem Excel-Forum zum Thema "Daten vom Vorjahr übernehmen"