Microsoft Excel

Herbers Excel/VBA-Archiv

VBA und Excel-Tabellenblattbezüge


Betrifft: VBA und Excel-Tabellenblattbezüge von: Anja
Geschrieben am: 29.01.2019 17:16:57

Hallo zusammen,

hier eine weitere Frage:

ich habe in einem Tabellenblatt eine Zelle mit Zellbezügen:

= WENN(D11=D12; "-";WENN(D11>D12;VERKETTEN(B11; " ";C11);VERKETTEN(B12; " ";C12)))

Diese Prozedur schmeißt mir einen Namen raus.

Jetzt möchte ich per VBA Bezug auf diese Zelle nehmen (d.h.auf einen Namen).

Das funktioniert leider nicht indem ich die Zelle anspreche. Ist das generell nicht möglich, oder gibt es eine Möglichkeit sich nur den Wert der Zelle ausgeben zu lassen?

Vielen Dank
Anja

  

Betrifft: AW: VBA und Excel-Tabellenblattbezüge von: onur
Geschrieben am: 29.01.2019 18:05:56

"ich habe in einem Tabellenblatt eine Zelle mit Zellbezügen:
= WENN(D11=D12; "-";WENN(D11>D12;VERKETTEN(B11; " ";C11);VERKETTEN(B12; " ";C12))) "" - Das ist eine Zelle mit Formel und nicht eine Zelle mit Zellbezügen.
"Diese Prozedur schmeißt mir einen Namen raus" - kann man nicht beurteilen, denn nur DU hast ja das Blastt vor dir.
"Jetzt möchte ich per VBA Bezug auf diese Zelle nehmen (d.h.auf einen Namen)" - WAS genau meinst du denn bitte?
"Das funktioniert leider nicht indem ich die Zelle anspreche" - kommt drauf an, WIE du es gemacht hast.
"gibt es eine Möglichkeit sich nur den Wert der Zelle ausgeben zu lassen?" - Schon mal mit:

Cells(x,y).Value 

versucht?
Je präziser du das Problem beschreibst, desto weniger Zeit vergeudet man mit der Hin- und Her-Fragerei.