Microsoft Excel

Herbers Excel/VBA-Archiv

Auswertung_Uhrzeiten_Schichtplan


Betrifft: Auswertung_Uhrzeiten_Schichtplan von: Markus
Geschrieben am: 06.09.2019 09:26:11

Guten Morgen,

ich habe kaum Excelerfahrung und stehe vor einem, für mich, großem Problem.
Für eine wichtige Auswertung benötige ich eine Formel oder einen Code:

Ich habe folgende Datenbasis
Datum ; Stockwerk ; Belegungszeiten
01.06.2019 ; 1 ; 10:00-12:00
01.06.2019 ; 2 ; 09:00-14:00

01.06. - 31.07.2019 mit den verschiedensten Uhrzeiten und auch doppelten Zeiten pro Stockwerk. Wenn die Zeit einmal vorkommt soll eine 1 in der Tabelle stehen, wenn das Zeitfenster durch eine andere Zeit betroffen ist eine 2 etc...

Diese Daten sollen in eine Tabelle Eingetragen werden.

Beispiel:
https://www.herber.de/bbs/user/131878.xls

Ich hoffe es kann mir jemand von euch helfen.

Vielen Dank im Voraus.

Viele Grüße
Markus

  

Betrifft: AW: Auswertung_Uhrzeiten_Schichtplan von: SF
Geschrieben am: 06.09.2019 09:41:08

Hola,

trenne die Uhrzeiten in Spalte D und E auf. Dann:

=SUMMENPRODUKT(($A$1:$A$14=$G3)*($B$1:$B$14=$H3)*(J$1>=STUNDE($D$1:$D$14)*(J$1<=STUNDE($E$1:$E$14)))) 
Gruß,
steve1da


  

Betrifft: Sorry, fehlerhaft von: SF
Geschrieben am: 06.09.2019 09:50:09

=SUMMENPRODUKT(($A$1:$A$14=$G3)*($B$1:$B$14=$H3)*(J$1>=STUNDE($D$1:$D$14))*(J$1<=STUNDE($E$1:$E$14))) 



  

Betrifft: AW: Sorry, fehlerhaft_Danke steve1da von: Markus
Geschrieben am: 06.09.2019 10:29:38

Super Vielen Dank
Grüße
Markus


  

Betrifft: AW: Auswertung_Uhrzeiten_Schichtplan von: Markus
Geschrieben am: 06.09.2019 09:58:14

Super vielen Dank, funktioniert super :-)

VG Markus


  

Betrifft: Bitte nochmal schauen AW: Auswertung_Uhrzeiten von: Markus
Geschrieben am: 06.09.2019 10:15:10

Hallo steve1da,

die Formel hat mir teilweise einen Fehlergebnis ausgeworfen. Könntest Du bitte nochmal schauen.

https://www.herber.de/bbs/user/131879.xls


Viele Dank

Viele GRüße
Markus


  

Betrifft: Bitte nochmal schauen AW: Auswertung_Uhrzeiten von: SF
Geschrieben am: 06.09.2019 10:18:43

Hola,

ich hatte meine Formel nochmal korrigiert....siehe "Fehlerhaft".

Gruß,
steve1da