Microsoft Excel

Herbers Excel/VBA-Archiv

Formel gesucht


Betrifft: Formel gesucht von: ilka maria
Geschrieben am: 27.09.2019 12:57:44

Guten Tag,

die Beispieldatei enthält eine Formel.
Wie sähe denn die Lösung aus mit den Funktionen Sverweis/Wverweis?
Dank im Voraus.
Gruß
ilka maria

https://www.herber.de/bbs/user/132242.xlsx

  

Betrifft: AW: Formel gesucht von: SF
Geschrieben am: 27.09.2019 12:59:33

Hola,

=INDEX(A1:D5;VERGLEICH(B7;A1:A5;0);VERGLEICH(B8;A1:D1;0))
Gruß,
steve1da


  

Betrifft: AW: Formel gesucht von: ilka maria
Geschrieben am: 27.09.2019 13:03:10

steve1da,

Danke, so ähnlich habe ich es auch gelöst.
Ich suchte aber nach einer Lösung mit SVERWEIS und WVERWEIS, komme aber nicht auf die Lösung.
Gruß
ilka maria


  

Betrifft: AW: Formel gesucht von: Regina Resch-Jansen
Geschrieben am: 27.09.2019 13:13:08

Hi,
geht m.E. mit Sverweis/Wverweis nicht, da beide Funktionen als Spalten- bzw. Zeilenindex einen nummerischen Wert brauchen. Falls Du die Monatsnamen durch Zahlen ersetzt (1=Januar usw..) dann kannst Du die Angabe des gesuchten Monats als Spaltenindex für den Sverweis nutzen, muss dann +1 gesetzt werden.

Gruß
Regina


  

Betrifft: AW: Danke von: ilka maria
Geschrieben am: 29.09.2019 11:00:31

Guten Morgen Regina,

vielen Dank für Deinen Beitrag, der mir zeigt, dass mein Ansatz nicht optimal gewählt war.
Danke.

Gruß
ilka maria


  

Betrifft: AW: Formel gesucht von: Daniel
Geschrieben am: 27.09.2019 13:15:11

Hi

=SVERWEIS(B7;A2:D5;VERGLEICH(B8;A1:D1;0);0)

=WVERWEIS(B8;A1:D5;VERGLEICH(B7;A1:A5;0);0)

Gruß Daniel


  

Betrifft: AW: Danke schön von: ilka maria
Geschrieben am: 29.09.2019 11:02:16

Guten Morgen Daniel,

vielen Dank Daniel für Deine 2 Formeln, die perfekt funktionieren.
Danke

Gruß
ilka maria


  

Betrifft: AW: mit SVERWEIS() oder WVERWEIS() ... von: neopa C
Geschrieben am: 27.09.2019 13:17:47

Hallo ilka maria,

... so: =SVERWEIS(B7;A:D;VERGLEICH(B8;1:1;0);0) bzw. so: =WVERWEIS(B8;1:6;VERGLEICH(B7;A:A;0);0)

Gruß Werner
.. , - ...


  

Betrifft: AW: Danke schön.. von: ilka maria
Geschrieben am: 29.09.2019 11:18:26

Guten Morgen Werner,

vielen Dank für Deine 2 Formeln, die perfekt funktionieren. Danke.

Gruß
ilka maria


Beiträge aus dem Excel-Forum zum Thema "Formel gesucht"