Microsoft Excel

Herbers Excel/VBA-Archiv

geht das kürzer?


Betrifft: geht das kürzer? von: Christian
Geschrieben am: 01.10.2019 19:30:43

Hallo,

Wie gesagt, geht das kürzer? in meiner Version wären es 2799 Summanden, zuviel zum tippen.

=(C2*(D2+E2)+C3*(D3+E3)+C4*(D4+E4) + ... + C2799*(D2799+E2799))/SUMME(D2:E2799)

Danke
Christian

  

Betrifft: AW: geht das kürzer? von: Hajo_Zi
Geschrieben am: 01.10.2019 19:35:45

Halo Christian,


Tabelle3

 ABCDE
1 2111
2 8222
3 18333
42828   

verwendete Formeln
Zelle Formel Bereich N/A
B1:B3=C1*(D1+E1)  
A4{=SUMME(C1:C3*(D1: D3+E1:E3))}$A$4 
B4=SUMME(B1:B3)  
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.20 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: mit SUMMENPRODUKT() ... von: neopa C
Geschrieben am: 01.10.2019 19:45:24

Hallo Christian,

... so: =SUMMENPRODUKT(C2:C2799*(D2:D2799+E2:E2799))/SUMME(D2:E2799)

Gruß Werner
.. , - ...


  

Betrifft: AW: mit SUMMENPRODUKT() ... von: Christian
Geschrieben am: 01.10.2019 20:11:43

Hallo Werner,

vielen Dank
Christian