Microsoft Excel

Herbers Excel/VBA-Archiv

Werte nach oben ausfüllen!


Betrifft: Werte nach oben ausfüllen! von: marcus
Geschrieben am: 01.10.2019 19:19:36

Hallo,

ich habe eine Spalte die einen Text mit nein und Zahlen.
Die Zahlen sollen den Text überschreiben und mit den Zahlen nach oben ausgefüllt werden.
z.B.
nein--1200
nein--1200
nein--1200
1200--1200
nein--1250
nein--1250
1250--1250

die Zahlen können in jeder 1000 Zeile sein oder jeder 100 zeile, also ganz unterschiedlich

Währe dankbar für eine Lösung

  

Betrifft: AW: z.B. als Formellösung ... von: neopa C
Geschrieben am: 01.10.2019 19:39:08

Hallo Marcus,

... in einer Nachbarspalte ab B1:

=WENN(LINKS(A1;1)="n";INDEX(A:A;VERGLEICH(1;INDEX(ISTZAHL(LINKS(A2:A1111;1)+0)+0;);0)+ZEILE());A1&"")
und Formel nach unten kopieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: Danke von: marcus
Geschrieben am: 01.10.2019 20:00:56

Super,
vielen Dank!!


  

Betrifft: AW: bitteschön; doch ich hatte vermutet, ... von: neopa C
Geschrieben am: 01.10.2019 20:28:19

Hallo Marcus,

... dass die hinteren Zahlen verschieden sein könnten. Dann wird nämlich die Formel komplizierter. Da ich diese schon definiert habe, stell ich sie hier auch noch ein:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1nein--10001200--1000
2nein--11001200--1100
3nein--12001200--1200
4nein--22221200--2222
51200--12001200--1200
6nein--125150--125
7nein--175150--175
8150--1250150--1250
9  

ZelleFormel
B1=WENN(LINKS(A1;1)="n";WECHSELN(A1;"nein";AGGREGAT(14;6;0+TEIL(INDEX(A:A;VERGLEICH(1;INDEX(ISTZAHL(LINKS(A2:A1111;1)+0)+0;);0)+ZEILE());1;SPALTE(A1:O1));1));A1&"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Gruß Werner
.. , - ...


  

Betrifft: AW: Perfekt von: marcus
Geschrieben am: 01.10.2019 20:36:38

Super!!
Danke nochmal