Microsoft Excel

Herbers Excel/VBA-Archiv

Spalte füllen von bis, bezug zur Nachbarspalte

Betrifft: Spalte füllen von bis, bezug zur Nachbarspalte von: Andi K.
Geschrieben am: 17.11.2014 17:53:30

Hallo,

wie Kann ich Spalte B mit 1 füllen im Bereich von A3-A7, also von Nachbarspalte 1-0?



Danke

  

Betrifft: B7 richtig ? von: Matthias L
Geschrieben am: 17.11.2014 18:00:09

Hallo

Ich hätte jetzt eher gedacht in B7 müsste eine 0 stehen.

 AB
311
4 1
5 1
6 1
700

Formeln der Tabelle
ZelleFormel
B3=A3
B4=WENN(A4="";B3;A4)
B5=WENN(A5="";B4;A5)
B6=WENN(A6="";B5;A6)
B7=WENN(A7="";B6;A7)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: B7 richtig ? von: Andi K.
Geschrieben am: 17.11.2014 18:32:54

Ist schon mal 'n Ansatz, ich benötige aber in B7 auch die 1.

Die restlichen Felder können 0 oder leer sein.

Ein Ansatz wäre in Spalte C =WENN(UND(B6=1;B7=0);1;B7)

Aber die richtige Formel für den Von/Bis Bereich wüsste ich trotzdem gerne, hätte die die letzte Zeit schon mehrfach brauchen können.


Danke und Gruß


  

Betrifft: was hast Du denn vor? von: Matthias L
Geschrieben am: 17.11.2014 18:48:20

Hallo

Du schreibst:
ich benötige aber in B7 auch die 1

Erkläre es doch bitte mal genauer.
Man muss ja die Bedingungen kennen um helfen zu können.

Gruß Matthias


  

Betrifft: AW: was hast Du denn vor? von: Andi K.
Geschrieben am: 17.11.2014 19:27:37

Die Werte mit 1 benötige ich für eine Berechnung, B7 signalisiert den Ausstieg, ist aber auch ein Wert der dazu gehört.


  

Betrifft: letzter Versuch ... von: Matthias L
Geschrieben am: 17.11.2014 19:43:41

Hallo

Ok ...
keine Ahnung was Du vorhast.
Evtl hilft das:

 AB
311
4 1
5 1
6 1
701
8  
9  
10  
11  
12  
133 
14  
15  
16  
172 

Formeln der Tabelle
ZelleFormel
B4=WENN(ANZAHL($A$3:A3)<2;B3;"")
B5=WENN(ANZAHL($A$3:A4)<2;B4;"")
B6=WENN(ANZAHL($A$3:A5)<2;B5;"")
B7=WENN(ANZAHL($A$3:A6)<2;B6;"")
B8=WENN(ANZAHL($A$3:A7)<2;B7;"")
B9=WENN(ANZAHL($A$3:A8)<2;B8;"")
B10=WENN(ANZAHL($A$3:A9)<2;B9;"")
B11=WENN(ANZAHL($A$3:A10)<2;B10;"")
B12=WENN(ANZAHL($A$3:A11)<2;B11;"")
B13=WENN(ANZAHL($A$3:A12)<2;B12;"")
B14=WENN(ANZAHL($A$3:A13)<2;B13;"")
B15=WENN(ANZAHL($A$3:A14)<2;B14;"")
B16=WENN(ANZAHL($A$3:A15)<2;B15;"")
B17=WENN(ANZAHL($A$3:A16)<2;B16;"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Solltest Du weitere Hilfe benötigen dann erkläre es bitte besser.

Gruß Matthias


  

Betrifft: AW: letzter Versuch ... von: Andi K.
Geschrieben am: 17.11.2014 21:09:44

Ok,

die 1 und die 0 beziehen sich auf eine weitere Spalte und bewegen sich in einem Bereich den ich berechnen will.

Also zb. alle werte über 100, die 1 markiert den ersten wert über 100 und die 0 den ersten wert der unter 100 liegt.

Der erste Wert unter 100 ist aber noch relevant.

Ich dachte ich lass die weitern Verknüpfungen mal weg um es nicht zu verkomplizieren.

Gruß


  

Betrifft: Du willst keine Hilfe mehr, ist ok für mich .. oT von: Matthias L
Geschrieben am: 17.11.2014 21:20:10




  

Betrifft: AW: Du willst keine Hilfe mehr, ist ok für mich .. oT von: Andi K.
Geschrieben am: 17.11.2014 21:47:00

Das sind beides Themen die mich die letzten Tage beschäftigt haben. Was genau ich berechne ist nicht wichtig, daher habe ich es so gut wie möglich auf einer gesonderten Tabelle nachgebildet und ein Foto gepostet.

Was genau an Infos fehlt denn noch?
Manchmal muss erst mal an der Frage gefeilt werden um die richtige Antwort zu finden...

Gruß


 

Beiträge aus den Excel-Beispielen zum Thema "Spalte füllen von bis, bezug zur Nachbarspalte"