Live-Forum - Die aktuellen Beiträge
Datum
Titel
01.03.2024 22:49:01
01.03.2024 22:31:05
01.03.2024 19:13:27
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

anzahl bis 80 % vom total erreich sind

anzahl bis 80 % vom total erreich sind
Benjamin
hallo zusammen,
ich mal wieder.....
btw. tausend dank für alle die, die sich hier die zeit nehmen daus wie mir zu helfen!!!!
ich hobe schon wieder ein problem.
ich habe eine tabelle.
produkt--produktgruppe--qty---qty_sum_prduktgruppe
a12a--a--30--80
a13a--a--20--80
a14a--a--15--80
a15a--a--10--80
a16a--a--5--80
b10b--b--20--50
b12b--b--20--50
b13b--b--10--50
nun möchte ich errechnen, mit wievielen produkten eine produktgruppe ich x% erreiche.
Bei 60 % wäre das für produktgruppe a
80= 100%
x = 60%
x = 48
also erreiche ich mit den ersten beiden artikeln der produktgruppe =50 und 80 ist grösser als 48
Antwort wäre 2
für produktgruppe b
50=100%
x = 60%
x = 30
also erreiche ich mit den ersten beiden produkten der produktgruppe b 40 und 40 is grösser als 30
also antwort wäre zwei....
Kennt jemand dafür eine formel?
danke und gruss
benjamin

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: anzahl bis 80 % vom total erreich sind
10.11.2009 16:46:01
Matthias5
Hallo Benjamin,
ganz leicht ist dein Anliegen nicht zu verstehen, aber ich versuch es mal so (der Übersichtlichkeit wegen mit Hilfsspalte):
Tabelle1
 ABCDEFGHI
1produktproduktgruppeqtyHilfsspalte  P-Gruppe100%60%Positionen
2a12aa3030  a80482
3a13aa2050  b50302
4a14aa1565         
5a15aa1075         
6a16aa580         
7b10bb2020         
8b12bb2040         
9b13bb1050         

verwendete Formeln
Zelle Formel
D2 =SUMMEWENN($B$2:$B2;B2;C$2:C2)
G2 =SUMMEWENN(B:B;F2;C:C)
H2 =G2*H$1
I2 {=MIN(WENN((B$1:B$20=F2)*($D$1:$D$20>=H2);ZEILE($1:$20)))-VERGLEICH(F2;B:B;0)+1}
G3 =SUMMEWENN(B:B;F3;C:C)
H3 =G3*H$1
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 4.8

Gruß,
Matthias
Anzeige
Hmm, 'ne Rückmeldung wäre schon nett gewesen! :-(
13.11.2009 11:33:26
Matthias5

302 Forumthreads zu ähnlichen Themen


Hallo zusammen.
Gibt es über VBA eine Möglichkeit, die Hintergrundfarbe einer Zelle in eine Zahl umzuwandeln und das schneller als mit for- Schleifen?
Habe einen Bereich ("J16:AG39"), wo ich per Zellaktivierung mit der Maus Zellen oder auch Zellbereiche mit einer Hintergrundfarbe verseh...
Anzeige

Hi Formelspezialisten,
in Zelle B2 steht dise Formel (funktionert auc h):
=TEXT(I4-D4;"00.0")&" ("&TEXT(I4/D4-1;"0%")&")".
Mein Ziel, dass eine Minuszahl in ROT erscheint. Hab's mit bedingte Formatierung versucht und bekomme es nicht hin.
Gibt es eine Möglichkeit, a...

Hallo,
ein ähnliches Problem wurde hier im Forum schon einmal diskutiert. (https://www.herber.de/forum/archiv/632to636/t635773.htm)
Meine Problem:
Wie kann ich die Anzahl unterschiedlicher Einträge/Werte einer Spalte erhalten, ohne dass diese vorgegeben werden ( also ohne die Verwe...
Anzeige

Hall Leute!
ich will nach einem Begriff, in meinem Fall nach "SUMs" in der Spalte C suchen und wissen wie oft es in der Spalte vorkommt.
Bei Berechnungen funktioniert es mit ZÄHLENWENN ohne Probleme aber wie erhalte ich die "absolute" Zahl?
Vielen Dank für Eure Hilfe!
Grüße
...

Guten Morgen!
Ich habe in einem Arbeitsblatt mehrere Tabellen.
In einer UserForm habe habe ich 460 TextBoxen, wobei die Zählung immer pro Reihe senkrecht erfolgt.
Spalte 1 = TextBox1-23, Spalte2 = TextBox24- TextBox46 usw.
Ich möchte nun z.B. die erste Tabelle in die Textboxen e...
Hallo,
in einer Telefontabelle, welche sich ständig ändert, möchte ich die ersten 4 Ziffern der Rufnummer per Makro rot einfärben.
Hat jemand eine gute Idee?
https://www.herber.de/bbs/user/54765.xls
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige