Microsoft Excel

Herbers Excel/VBA-Archiv

Zellwert in Datentabelle zusammenzählen | Herbers Excel-Forum


Betrifft: Zellwert in Datentabelle zusammenzählen von: Tobias
Geschrieben am: 08.01.2010 23:52:07

Hallo
Kann mir jemand weiterhelfen?
Habe z.B. folgende Daten in einer Tabelle (siehe unterstehender Link) und möchte, dass es mir die Anzahl von jedem Produkt anzeigt.
(mit Summenprodukt wäre es möglich, ist nicht so benutzerfreundlich, bin mir sicher, dass es einfachere und clevere Lösungen gibt.
Danke und Gruss

https://www.herber.de/bbs/user/67094.xls

  

Betrifft: AW: Zellwert in Datentabelle zusammenzählen von: Josef Ehrensberger
Geschrieben am: 08.01.2010 23:57:19

Hallo Tobias,

du meinst aber nicht so. Beschreibung und Tabelle sind gelinde gesagt, eine Frechheit!

Tabelle1

 ABCDEFGHIJ
1          
2TMA 1164/112TMA 1164/112TMA 1264/212TMA 1164/112   TMA 1164/11211 
3 TMA 1264/212     TMA 1264/2122 
4TMA 1164/112TMA 1164/112TMA 1164/112TMA 1164/112   TME 1710/221 
5  TME 1710/22       
6TMA 1164/112TMA 1164/112TMA 1164/112TMA 1164/112      
7          

Formeln der Tabelle
ZelleFormel
I2=ZÄHLENWENN($A$2:$E$7;H2)
I3=ZÄHLENWENN($A$2:$E$7;H3)
I4=ZÄHLENWENN($A$2:$E$7;H4)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Zellwert in Datentabelle zusammenzählen von: Tobias
Geschrieben am: 09.01.2010 00:07:36

Hallo Sepp
Verstehe deine Aussage, sorry wenn ich mich nicht genau ausgedrückt habe.
Besteht die Möglichkeit H2, H3 und H4 "automatisch" zu generieren, d.h. nicht sep. herauszukopieren (da die Tabelle in der Tat eine grosse Datenmenge beinhaltet)?
Danke für deine Rückmeldung.
Gruss Tobias


  

Betrifft: AW: Zellwert in Datentabelle zusammenzählen von: Josef Ehrensberger
Geschrieben am: 09.01.2010 00:15:35

Hallo Tobias,

dazu fält mir im Moment nichts ein.


Gruß Sepp



  

Betrifft: =ZÄHLENWENN($A$2:$E$7;A10) _oT von: NoNet
Geschrieben am: 09.01.2010 00:14:55

_oT


  

Betrifft: AW: =ZÄHLENWENN($A$2:$E$7;A10) _oT von: Tobias
Geschrieben am: 09.01.2010 00:33:47

Hallo
Besteht die Möglichkeit A10 "automatisch" zu generieren, d.h. nicht sep. herauszukopieren (da die Tabelle in der Tat eine grosse Datenmenge beinhaltet)?
Danke für die Rückmeldung.
Gruss Tobias


  

Betrifft: Mehrspaltige Liste einspaltig ohne Redundanzen von: NoNet
Geschrieben am: 09.01.2010 01:20:58

Hallo Tobias,

das ist möglich, allerdings etwas komplex und aufwändig.
Ich habe Dir anbei ein Beispiel erstellt - schau es Dir an und versuche, es auf Deine Datei zu übertragen :

https://www.herber.de/bbs/user/67095.xls

Viel Erfolg, NoNet


  

Betrifft: Korrektur: Bereich.Verschieben(E$4;...) von: NoNet
Geschrieben am: 09.01.2010 02:07:50

Hallo Tobias,

in G4 muss es BEREICH.VERSCHIEBEN(E$4;...) anstelle BEREICH.VERSCHIEBEN(E$3;...) heißen
(mit Strg+Shift+ENTER bestätigen, dann nach unten kopieren !)

Wenn Du nun im Beispiel zwischen Spalte A:B (nicht VOR Spalte A !) 2 neue Spalten einfügst, kannst Du Deine gepostete Beispieltabelle in den gelben Bereich kopieren.
Es müssen keine weitere Formeln/Funktionen geändert werden !

Das Ergebnis sieht dann so aus (Gewünschtes Ergebnis in Spalte I:J) :



Bei grösseren Tabellen muss der entsprechende Bereich in den Funktionen angepasst werden (in den Spalten E und H z.B. $A$4:$C$9 durch den tatsächlichen Listenbereich und in Spalte G dann $E$4:$E$23 durch den tatsächlichen einspaltigen Listenbereich). Alternativ kann man diesen Bereich auch durch einen flexiblen Bereichsnamen in den Funktionen ersetzen, den man zuvor per Strg+F3 oder über das Namenfeld (oberhalb A1) definieren muss !

Gruß, NoNet


  

Betrifft: AW: Korrektur: Bereich.Verschieben(E$4;...) von: Tobias
Geschrieben am: 09.01.2010 10:37:57

Hallo NoNet

Herzlichen Dank!
Dies ist perfekt.
Werde dies nun in meine Matrix übertragen!

Wünsche ein schönes Wochenende.

Gruss Tobias


Beiträge aus den Excel-Beispielen zum Thema "Zellwert in Datentabelle zusammenzählen"