Umsortierung Werte einer Tabelle (nach Name)

Bild

Betrifft: Umsortierung Werte einer Tabelle (nach Name)
von: Joerschi
Geschrieben am: 17.07.2015 20:55:29

Hallo liebes Forum,
folgendes Szenario soll via Formel gelöst werden (Skizze + Musterdatei unten):
Es gibt eine Ausgangs-/Quelltabelle (C3:V4) mit Namen und zugehörigen Werten.
Viele Namen haben unterschiedliche Werte, bei einigen Namen gibt es auch gleiche Werte.
Aufgabe:
In einer Zieltabelle sollen nun (via Formel) für jeden der Namen untereinander die Werte aufgelistet werden (optimalerweise aus der Quelltabelle von links nach rechts ausgelesen - das ist aber nur nice-to-have...).
Mehrfache Werte je Name sollen auch mehrfach vorkommen in der "Umsortierung" (im Beipsiel unten wäre das der Wert 4 beim Name "F1")
Skizze (gelb ist der gesuchte Formelbereich - manuell sind die Lösungen des Beispieles eingetragen):
Userbild
Musterdatei: https://www.herber.de/bbs/user/98907.xlsx
Hätte jemand einen Tip?
Danke vorab und Liebe Grüße
Joerschi

Bild

Betrifft: AW: Umsortierung Werte einer Tabelle (nach Name)
von: Sepp
Geschrieben am: 17.07.2015 21:08:16
Hallo Joerschi,
Tabelle1

 BCDEFGHIJKLMNOPQRSTUV
2Ausgangstabelle/Quelldaten                    
3NameF1F2F1F1F2F2F2F3F3F3F3F4F1F5F5F5F5F5F4F10
4Wert4234567891011121314151617181920
5                     
6                     
7                     
8Zieltabelle - einsortiert                    
9NameF1F2F3F4F5F6F7F8F9F10          
10Wert 14281214    20          
11Wert 23591915               
12Wert 34610 16               
13Wert 413711 17               
14Wert 5    18               
15Wert 6                    

Formeln der Tabelle
ZelleFormel
C10=WENNFEHLER(INDEX($C$4:$V$4;1;AGGREGAT(15;6;SPALTE($A$1:$U$1)/($C$3:$V$3=C$9); ZEILE($A1))); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp


Bild

Betrifft: AW: Umsortierung Werte einer Tabelle (nach Name)
von: Joerschi
Geschrieben am: 17.07.2015 21:13:22
Funktioniert einwandfrei. Besten Dank, Sepp!
Beste Grüße
joerschi

Bild

Betrifft: alternativ für Zahlenwerte, sortiert und un- ...
von: der neopa C
Geschrieben am: 18.07.2015 11:42:49
Hallo Joerschi
... au Deiner Fragestellung geht hervor, dass es sich erstens ausschließlich um Zahlenwerte handelt und zweitens schriebst Du: "... von links nach rechts ausgelesen - das ist aber nur nice-to-have..."
Dies ermöglicht als Lösungsformel auch das Weglassen von INDEX() im Formelvorschlag von Sepp und damit gleichzeitig die Möglichkeit die Zahlenwerte nach Größe sortiert auszugeben.
In C10: =WENNFEHLER(AGGREGAT(14;6;$4:$4/($3:$3=C$9);ZEILE(A1));"") für Groß nach Klein oder umgekehrt von Klein nach Groß einfach in der Formel die 14 durch eine 15 ersetzen und Formel nach rechts und unten ziehend kopieren.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Umsortierung Werte einer Tabelle (nach Name)"