Microsoft Excel

Herbers Excel/VBA-Archiv

Auswertung einer Tabelle

Betrifft: Auswertung einer Tabelle von: Marcus
Geschrieben am: 24.09.2014 13:37:31

Hallo,

ich würde gerne angehängte Tabelle auswerten.

https://www.herber.de/bbs/user/92790.xlsx

Mit "zählenwenn" bekomme ich ja nur aufgeführt wie oft ein Produkt in der Liste aufgeführt ist. Aber nicht wie oft es tatsächlich verkauft wurde und was dann die Gesamtsumme für jeden Artikel ist.

Hoffe mir kann hier jemand helfen :(

Viele Grüße
Marcus

  

Betrifft: AW: Auswertung einer Tabelle von: hary
Geschrieben am: 24.09.2014 13:45:15

Moin Marcus



Tabelle1

 FGH
1 Anzahl verkaufter ProdukteSumme verkaufter Produkte
2Produkt 16480
3Produkt 2240
4Produkt 3360

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
G2:G4=SUMMEWENNS($B$2:$B$7;$A$2:$A$7;F2)  =SUMIFS(R2C2:R7C2,R2C1:R7C1,RC[-1])
H2:H4=SUMMEWENNS($D$2:$D$7;$A$2:$A$7;F2)  =SUMIFS(R2C4:R7C4,R2C1:R7C1,RC[-2])

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: Du hast natürlich völlig Recht von: neopa C (paneo)
Geschrieben am: 24.09.2014 13:50:23

Hallo hary,

... mein Vorschlag ZÄHLENWENNS() wäre hier quatsch :-(
Ich hätte allerdings swieso eine PIVOTauswertung bevorzugt.

Gruß Werner
.. , - ...


  

Betrifft: AW: Auswertung einer Tabelle von: Marcus
Geschrieben am: 24.09.2014 15:00:47

Hallo Harry,

vielen lieben Dank für die schnelle und sehr gute Hilfe.
Tabelle steht :)

Grüße
Marcus


  

Betrifft: am einfachsten wäre eine PIVOTauswertung ... von: neopa C (paneo)
Geschrieben am: 24.09.2014 13:48:13

Hallo Marcus,


... aber Du kannst für die Anzahl auch die Formel mit ZÄHLENWENNS() und für die Summen SUMMEWENNS() nutzen.


Gruß Werner
.. , - ...


  

Betrifft: AW: Auswertung einer Tabelle von: fcs
Geschrieben am: 24.09.2014 13:49:24

Hallo Marcus,

mit der Funktion SUMMEWENN kannst du je Produkt auch die Summe von Anzahl bzw. Summe berechnen.

Für solche Auswertungen sind jedoch Pivottabellenberichte die via Menü "Einfügen" erstellt werden oft (für mich fast immer) die geeignetere Lösung.

Gruß
Franz


  

Betrifft: AW: Auswertung einer Tabelle von: Ludicla
Geschrieben am: 24.09.2014 13:54:28

hey Markus,

nimm die Pivot-Tabelle

https://www.herber.de/bbs/user/92791.xlsx


Gruss Ludicla


  

Betrifft: AW: Auswertung einer Tabelle von: Marcus
Geschrieben am: 24.09.2014 15:04:19

Hallo Ludida,

auch Dir vielen Dank für die schnelle Hilfe :)

Nun hab ich zwei Möglichkeiten und werde dank Dir endlich mal beginnen mich mit Pivot-Tabellen auseinanderzusetzen :)

Grüße
Marcus


 

Beiträge aus den Excel-Beispielen zum Thema "Auswertung einer Tabelle"