Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Werte aus Übersicht in neue Tabelle

Werte aus Übersicht in neue Tabelle
11.02.2016 19:22:46
andreas
Hallo...,
ich versuche aus einer Übersicht die tatsächlichen Werte herauszukriegen und in einer neuen Tabelle zusammenzufassen. Leere Zellen sollen ignoriert werden.
Tabelle1
In Zeile 1 befinden sich die Raumbezeichnungen. In Spalte A ist Datum. In der Tabelle wird die Belegung mit einem Buchstaben (A, B, C oder...) dargestellt.
neue Tabelle2
Datum, Raum, Belegung
01.01.2016, R1, B
01.01.2016, R4, A
03.01.2016, R2, C
04.01.2016, R2, C
Erste Versuche hatte ich mit SVERWEIS gemacht, das bringt mich aber nicht weiter.
Bitte helft mir.
Gruß andreas

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Werte aus Übersicht in neue Tabelle
11.02.2016 19:30:36
SF
Hola,
eine Beispieltabelle wäre sinnvoll.
Gruß,
steve1da

AW: am einfachsten mit einer Hilfsspalte ...
12.02.2016 09:27:28
...
Hallo Andreas,
... in der Du folgende kleine Formel in der zweiten Zeile schreibst: =ANZAHL2(B2:E2) und diese nach unten ziehend kopierst und anschließend diese Spalte mittels des Autofilter nach 0 filterst. Die so gefilterten Zeilen markierst Du und löschst diese anschließend. Abschließend hebst Du den Autofilter wieder auf und löschst die Hilfsspalte.
Gruß Werner
.. , - ...

Anzeige
AW: am einfachsten mit einer Hilfsspalte ...
12.02.2016 17:55:53
andreas
Hallo neopa C,
damit bekomme ich aber nicht meine Tabelle2... jeder Eintrag eine Zeile (01.01.2016;R2;W)
Gruß andreas

AW: dann mit zwei AGGREGAT()-Formeln ...
13.02.2016 09:11:43
...
Hallo Andreas,
... die beiden Formeln einfach ziehend nach unten kopieren:
 ABCDEFGHIJ
1DatumR1R2R3R4   DatumBelegung
201.01.2016       02.01.2016I
302.01.2016I W    02.01.2016W
403.01.2016IR     03.01.2016I
504.01.2016IR     03.01.2016R
605.01.2016 R W   04.01.2016I
706.01.2016 R     04.01.2016R
807.01.2016 R     05.01.2016R
908.01.2016       05.01.2016W
1009.01.2016       06.01.2016R
1110.01.2016  W    07.01.2016R
1211.01.2016       10.01.2016W
1312.01.2016       14.01.2016W
1413.01.2016       17.01.2016W
1514.01.2016W      19.01.2016W
1615.01.2016       20.01.2016W
1716.01.2016         
1817.01.2016 W       
1918.01.2016         
2019.01.2016  W      
2120.01.2016W        
2221.01.2016         
23          

Formeln der Tabelle
ZelleFormel
I2=WENNFEHLER(AGGREGAT(15;6;A$2:A$99/(B$2:E$99>0); ZEILE(A1)); "")
J2=WENN(I2="";"";INDEX(A:E;VERGLEICH(I2;A:A;); AGGREGAT(15;6;SPALTE(A1:E1)/(A$1:A$99=I2)/(A$1:E$99>0); 1+ZÄHLENWENN(I$2:I2;I2))))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...
Anzeige

307 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige