Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung zählen | Herbers Excel-Forum


Betrifft: Bedingte Formatierung zählen von: Stef@n
Geschrieben am: 20.11.2009 20:43:50

Hallo ExcelFreunde

ich habe in einer Tabelle pro Zeile den/die jeweils höchsten Zahlen per bedingter Formatierung eingefärbt.
Jetzt möchte ich pro Spalte die Anzahl der "eingefärbten" Zellen zählen

Gibts dafür eine Formellösung ?

Freu mich auf eine Antwort
Gruß Stef@n

hier mal die Datei:
https://www.herber.de/bbs/user/66066.xls

  

Betrifft: Bed. Formatierung zählen - oder andere Lösung ? von: Stef@n
Geschrieben am: 20.11.2009 22:26:30

Hallo

kleine Ergänzung:
Gern auch eine andere Lösung ;) - ggfs mit Hilfsspalten ...
wenn das "einfacher" ist :O?
Bin auf der Suche nach der Summe der Zeilen-Maximal-Werte einer Spalte
"wie häufig ist diese Spalte ein Maximalwert?"
besten Gruss Stef@n


  

Betrifft: mit Hilfspalte von: Tino
Geschrieben am: 21.11.2009 05:42:28

Hallo,
geht es so?

https://www.herber.de/bbs/user/66070.xls

Gruß Tino


  

Betrifft: AW: mit Hilfspalte von: Stef@n
Geschrieben am: 21.11.2009 07:05:18

Hey Tino,
einen wunderschönen guten Morgen :)
Danke für die schnelle Antwort am frühen morgen !

Als Summe der Maximalwerte für die Zeilen --- perferkt !
Jetzt brauche ich nur noch Formeln in der Zeile 487 nach dem Motto

=ZÄHLENWENN(C2:C482;MAX(....))
= Anzahl der Grün markierten Zellen in der Spalte C ... D usw
Wie häufig ist in jeder Spalte ein Zeilenwert mal ein Maximalwert ?

Noch ne Idee ?
Gruss Stef@n


  

Betrifft: AW: mit Hilfspalte von: Tino
Geschrieben am: 21.11.2009 07:38:09

Hallo,
steht dies im Beispiel nicht schon in der Zelle P1?

=ZÄHLENWENN(P2:P482;">1")

Gruß Tino


  

Betrifft: AW: mit Hilfspalte von: Stef@n
Geschrieben am: 21.11.2009 07:54:57

Hey Tino
.. leider nein :|
Ich hab die Datei mal reduziert auf weniger Zeilen
und manuell gezählt - Ergebnisse stehen in der Zeile 42
Sorry, falls ich mich nicht klar genug ausgedrückt habe :O

https://www.herber.de/bbs/user/66072.xls
Gruss Stef@n


  

Betrifft: müsste so funktionieren. von: Tino
Geschrieben am: 21.11.2009 08:09:44

Hallo,

https://www.herber.de/bbs/user/66073.xls

Gruß Tino


  

Betrifft: perfekt :)) von: Stef@n
Geschrieben am: 21.11.2009 18:47:54

Hallo Tino
klasse Lösung ! Dank Dir sehr !
Genau das hab ich gesucht.
Interessant ist der Weg über die Hilfsspalte.

Schönes Wochenende noch :)
Gruss Stef@n


Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung zählen"