Microsoft Excel

Herbers Excel/VBA-Archiv

gerade oder ungerade

Betrifft: gerade oder ungerade von: Michael
Geschrieben am: 19.09.2020 11:43:12

Hallo Excel Profis,


ich habe kaum Erfahrungen mit Excel und für Euch ist es sicherlich ein Leichtes. Ich versuche gerade eine Tabelle zu erstellen die mir das Leben als Gerüstbauer ein wenig vereinfacht. Ich möchte eine Datei erstellen die es mir ermöglicht einfach eine Meterzahl einzugeben und dann errechnet wird wieviele Gerüstrahmen, Treppen, Geländer etc. man benötigt. Dazu benötige ich aber eine Formel die es mir erlaubt zwischen gerade oder ungerade zu unterscheiden.

Beispiel:

Wenn der Turm z.B. eine gerade Zahl an Höhe hat sagen wir mal 6 m dann benötigt man 6 Spindelfüße

Hat er aber eine ungerade Zahl benötigt man 8 Spindelfüße.


Die Formel bekomme ich einfach nicht hin.


wenn ich eingebe =WENN(D2=istgerade;6;8)

steht in der Ausgabezeile nur Name


jetzt dürft Ihr ruhig lachen ;-)


VG Michael

Betrifft: AW: gerade oder ungerade
von: SF
Geschrieben am: 19.09.2020 11:48:02

Hola,

=wenn(istgerade(D2);6;8)

Gruß,
steve1da

Betrifft: AW: gerade oder ungerade
von: Daniel
Geschrieben am: 19.09.2020 11:49:06

Hi

Es gibt die Excelfunktion Istgerade(), die du ganznormal verwenden kannst.
Tipp einfach mal die ersten Buchstaben ein, dann sollte sie dir in der Eingabehilfe angezeigt werden.

Gruß Daniel

Betrifft: AW: gerade oder ungerade
von: Nepumuk
Geschrieben am: 19.09.2020 11:52:08

Hallo Michael,

so:

=WENN(ISTGERADE(D2);6;8)

Gruß
Nepumuk

Betrifft: AW: gerade oder ungerade
von: Michael
Geschrieben am: 19.09.2020 11:52:19

Ihr seid der Hammer !!!!

1000 Dank !!!!

Betrifft: AW: gerade oder ungerade
von: Daniel
Geschrieben am: 19.09.2020 11:53:03

Hi

Wenn der Turm jetzt 8m hoch ist oder 10m oder 4m, benötigt er dann auch 6 Spindelfüße?

Gruß Daniel

Betrifft: AW: gerade oder ungerade
von: Michael
Geschrieben am: 19.09.2020 11:57:45

Ja genau nur bei einer ungerade Meterzahl verändert sich die Anzahl jedoch ändern sich dann einige andere Dinge. Diese kann ich aber mit dieser Formel errechnen.
z.B: Benötigt man für 10 Meter 5 Treppen a 2Meter
bei 9 Meter nur 4 Treppen a 2 Meter jedoch noch eine von einem Meter Höhe.
Mit Eurer Formel komme ich auf jeden Fall klar.

Vielen Dank !!!!

Betrifft: AW: gerade oder ungerade
von: Daniel
Geschrieben am: 19.09.2020 13:02:22

HI
für solche Berechnugen könntest du dann Quotient (Ganzahlergebnis einer Division) und Rest (ganzahlige Restmenge der Division)

dh wenn in A1 die Höhe steht, bekommst du mit Quotient(A1;2) die Anzahl der benötigten 2m-Treppen und mit Rest(A1;2) die Anzahl der benötigten 1m-Treppen.

Gruß Daniel

Betrifft: AW: gerade oder ungerade
von: Zwenn
Geschrieben am: 19.09.2020 11:53:11

Hallo,

trage in A1 eine beliebige Zahl ein. Es wird abhängig von der Zahl die Zahl selbst ausgegeben, wenn sie gerade ist, ansonesten die Zahl +1. Ich denke, Du brauchst das universell, also für beliebige Zahlen.
=WENN(ISTGERADE(A1);A1;A1+1)
Für Formeln gilt immer, dass die Parameter in Klammern geschrieben werden.

Viele Grüße,

Zwenn

Betrifft: Noch n Gedicht
von: RPP63
Geschrieben am: 19.09.2020 12:03:02

Moin!

=6+2*(REST(D2;2)=1)

Gruß Ralf

Betrifft: AW: Noch n Gedicht
von: Daniel
Geschrieben am: 19.09.2020 12:17:19

Oder noch einfacher:

=8-2*Istgerade(D2)
=6+2*Rest(D2;2)

Gruß Daniel

Betrifft: AW: Nimm die Kleingeldverteilung von Excel-Formeln
von: Sulprobil
Geschrieben am: 21.09.2020 07:13:39

Als Münzgrößen die Treppengrößen 2 und 1 nehmen und was Du sonst noch hast.
Dann bekommst Du gleich heraus, wie viele Treppen welcher Größe Du brauchst.
Bei nur 2 Treppengrößen kannst Du Daniels Ansatz verwenden.
Für die Spindelfüße nimm OBERGRENZE(A1;2).

Beiträge aus dem Excel-Forum zum Thema "gerade oder ungerade "