Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
904to908
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
904to908
904to908
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

zähle die Tage Montag bis Donnerstag im Monat

zähle die Tage Montag bis Donnerstag im Monat
10.09.2007 15:12:35
Edwin
Hallo,
ich möchte gerne in einem bestimmten Monat die Tage Montag bis Donnerstag zählen.
Als Bsp. wären dies im September 16 Tage.
Kann mir da jemand helfen?
Gruß
Edwin

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Montage bis Donnerstage im September
10.09.2007 15:46:47
WF
Hi Edwin,
=SUMMENPRODUKT((WOCHENTAG(DATUM(2007;9;ZEILE(1:30));2)<5)*1)
Salut
WF

AW: Montage bis Donnerstage im September
10.09.2007 15:59:21
Edwin
Hallo WF,
vielen Dank, super! Es geht.
Kappiert habe ich es allerings nicht.
ZEILE(1:30) habe ich noch in ZEILE(1:31) abgeändert, damit z.B. für 10.2007 als Ergebnis 19 Tage kommen.
Gruß
Edwin

AW: zähle die Tage Montag bis Donnerstag im Monat
10.09.2007 16:10:00
jockel
hi Edwin das geht so:
Tabelle1
 ABCDE
101.09.2007Sa2007916
202.09.2007So   
303.09.2007Mo   
404.09.2007Di   
505.09.2007Mi   
606.09.2007Do   
707.09.2007Fr   
808.09.2007Sa   
909.09.2007So   
1010.09.2007Mo   
1111.09.2007Di   
1212.09.2007Mi   
1313.09.2007Do   
1414.09.2007Fr   
1515.09.2007Sa   
1616.09.2007So   
1717.09.2007Mo   
1818.09.2007Di   
1919.09.2007Mi   
2020.09.2007Do   
2121.09.2007Fr   
2222.09.2007Sa   
2323.09.2007So   
2424.09.2007Mo   
2525.09.2007Di   
2626.09.2007Mi   
2727.09.2007Do   
2828.09.2007Fr   
2929.09.2007Sa   
3030.09.2007So   
Formeln der Tabelle
A1 : =DATUM($C$1;$D$1;ZEILE())
B1 : =A1
E1 : {=SUMME((WOCHENTAG(ZEILE(INDIREKT(A1&":"&DATUM(JAHR(A1); MONAT(A1)+1;0))); 2)<=4)*1)}
A2 : =A1+1
B2 : =A2
A3 : =A2+1
B3 : =A3
A4 : =A3+1
B4 : =A4
A5 : =A4+1
B5 : =A5
A6 : =A5+1
B6 : =A6
A7 : =A6+1
B7 : =A7
A8 : =A7+1
B8 : =A8
A9 : =A8+1
B9 : =A9
A10 : =A9+1
B10 : =A10
A11 : =A10+1
B11 : =A11
A12 : =A11+1
B12 : =A12
A13 : =A12+1
B13 : =A13
A14 : =A13+1
B14 : =A14
A15 : =A14+1
B15 : =A15
A16 : =A15+1
B16 : =A16
A17 : =A16+1
B17 : =A17
A18 : =A17+1
B18 : =A18
A19 : =A18+1
B19 : =A19
A20 : =A19+1
B20 : =A20
A21 : =A20+1
B21 : =A21
A22 : =A21+1
B22 : =A22
A23 : =A22+1
B23 : =A23
A24 : =A23+1
B24 : =A24
A25 : =A24+1
B25 : =A25
A26 : =A25+1
B26 : =A26
A27 : =A26+1
B27 : =A27
A28 : =A27+1
B28 : =A28
A29 : =WENN(A28="";"";WENN(MONAT(A28+1)=MONAT(A$28); A28+1;""))
B29 : =A29
A30 : =WENN(A29="";"";WENN(MONAT(A29+1)=MONAT(A$28); A29+1;""))
B30 : =A30
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =WOCHENTAG($A1;2)>=6Abc
A12. / Formel ist =SVERWEIS($A1;ft;4;0)="X"Abc
B11. / Formel ist =WOCHENTAG($A1;2)>=6Abc
B12. / Formel ist =SVERWEIS($A1;ft;4;0)="X"Abc
A21. / Formel ist =WOCHENTAG($A2;2)>=6Abc
A22. / Formel ist =SVERWEIS($A2;ft;4;0)="X"Abc
B21. / Formel ist =WOCHENTAG($A2;2)>=6Abc
B22. / Formel ist =SVERWEIS($A2;ft;4;0)="X"Abc
A31. / Formel ist =WOCHENTAG($A3;2)>=6Abc
A32. / Formel ist =SVERWEIS($A3;ft;4;0)="X"Abc
B31. / Formel ist =WOCHENTAG($A3;2)>=6Abc
B32. / Formel ist =SVERWEIS($A3;ft;4;0)="X"Abc
A41. / Formel ist =WOCHENTAG($A4;2)>=6Abc
A42. / Formel ist =SVERWEIS($A4;ft;4;0)="X"Abc
B41. / Formel ist =WOCHENTAG($A4;2)>=6Abc
B42. / Formel ist =SVERWEIS($A4;ft;4;0)="X"Abc
A51. / Formel ist =WOCHENTAG($A5;2)>=6Abc
A52. / Formel ist =SVERWEIS($A5;ft;4;0)="X"Abc
B51. / Formel ist =WOCHENTAG($A5;2)>=6Abc
B52. / Formel ist =SVERWEIS($A5;ft;4;0)="X"Abc
A61. / Formel ist =WOCHENTAG($A6;2)>=6Abc
A62. / Formel ist =SVERWEIS($A6;ft;4;0)="X"Abc
B61. / Formel ist =WOCHENTAG($A6;2)>=6Abc
B62. / Formel ist =SVERWEIS($A6;ft;4;0)="X"Abc
A71. / Formel ist =WOCHENTAG($A7;2)>=6Abc
A72. / Formel ist =SVERWEIS($A7;ft;4;0)="X"Abc
B71. / Formel ist =WOCHENTAG($A7;2)>=6Abc
B72. / Formel ist =SVERWEIS($A7;ft;4;0)="X"Abc
A81. / Formel ist =WOCHENTAG($A8;2)>=6Abc
A82. / Formel ist =SVERWEIS($A8;ft;4;0)="X"Abc
B81. / Formel ist =WOCHENTAG($A8;2)>=6Abc
B82. / Formel ist =SVERWEIS($A8;ft;4;0)="X"Abc
A91. / Formel ist =WOCHENTAG($A9;2)>=6Abc
A92. / Formel ist =SVERWEIS($A9;ft;4;0)="X"Abc
B91. / Formel ist =WOCHENTAG($A9;2)>=6Abc
B92. / Formel ist =SVERWEIS($A9;ft;4;0)="X"Abc
A101. / Formel ist =WOCHENTAG($A10;2)>=6Abc
A102. / Formel ist =SVERWEIS($A10;ft;4;0)="X"Abc
B101. / Formel ist =WOCHENTAG($A10;2)>=6Abc
B102. / Formel ist =SVERWEIS($A10;ft;4;0)="X"Abc
A111. / Formel ist =WOCHENTAG($A11;2)>=6Abc
A112. / Formel ist =SVERWEIS($A11;ft;4;0)="X"Abc
B111. / Formel ist =WOCHENTAG($A11;2)>=6Abc
B112. / Formel ist =SVERWEIS($A11;ft;4;0)="X"Abc
A121. / Formel ist =WOCHENTAG($A12;2)>=6Abc
A122. / Formel ist =SVERWEIS($A12;ft;4;0)="X"Abc
B121. / Formel ist =WOCHENTAG($A12;2)>=6Abc
B122. / Formel ist =SVERWEIS($A12;ft;4;0)="X"Abc
A131. / Formel ist =WOCHENTAG($A13;2)>=6Abc
A132. / Formel ist =SVERWEIS($A13;ft;4;0)="X"Abc
B131. / Formel ist =WOCHENTAG($A13;2)>=6Abc
B132. / Formel ist =SVERWEIS($A13;ft;4;0)="X"Abc
A141. / Formel ist =WOCHENTAG($A14;2)>=6Abc
A142. / Formel ist =SVERWEIS($A14;ft;4;0)="X"Abc
B141. / Formel ist =WOCHENTAG($A14;2)>=6Abc
B142. / Formel ist =SVERWEIS($A14;ft;4;0)="X"Abc
A151. / Formel ist =WOCHENTAG($A15;2)>=6Abc
A152. / Formel ist =SVERWEIS($A15;ft;4;0)="X"Abc
B151. / Formel ist =WOCHENTAG($A15;2)>=6Abc
B152. / Formel ist =SVERWEIS($A15;ft;4;0)="X"Abc
A161. / Formel ist =WOCHENTAG($A16;2)>=6Abc
A162. / Formel ist =SVERWEIS($A16;ft;4;0)="X"Abc
B161. / Formel ist =WOCHENTAG($A16;2)>=6Abc
B162. / Formel ist =SVERWEIS($A16;ft;4;0)="X"Abc
A171. / Formel ist =WOCHENTAG($A17;2)>=6Abc
A172. / Formel ist =SVERWEIS($A17;ft;4;0)="X"Abc
B171. / Formel ist =WOCHENTAG($A17;2)>=6Abc
B172. / Formel ist =SVERWEIS($A17;ft;4;0)="X"Abc
A181. / Formel ist =WOCHENTAG($A18;2)>=6Abc
A182. / Formel ist =SVERWEIS($A18;ft;4;0)="X"Abc
B181. / Formel ist =WOCHENTAG($A18;2)>=6Abc
B182. / Formel ist =SVERWEIS($A18;ft;4;0)="X"Abc
A191. / Formel ist =WOCHENTAG($A19;2)>=6Abc
A192. / Formel ist =SVERWEIS($A19;ft;4;0)="X"Abc
B191. / Formel ist =WOCHENTAG($A19;2)>=6Abc
B192. / Formel ist =SVERWEIS($A19;ft;4;0)="X"Abc
A201. / Formel ist =WOCHENTAG($A20;2)>=6Abc
A202. / Formel ist =SVERWEIS($A20;ft;4;0)="X"Abc
B201. / Formel ist =WOCHENTAG($A20;2)>=6Abc
B202. / Formel ist =SVERWEIS($A20;ft;4;0)="X"Abc
A211. / Formel ist =WOCHENTAG($A21;2)>=6Abc
A212. / Formel ist =SVERWEIS($A21;ft;4;0)="X"Abc
B211. / Formel ist =WOCHENTAG($A21;2)>=6Abc
B212. / Formel ist =SVERWEIS($A21;ft;4;0)="X"Abc
A221. / Formel ist =WOCHENTAG($A22;2)>=6Abc
A222. / Formel ist =SVERWEIS($A22;ft;4;0)="X"Abc
B221. / Formel ist =WOCHENTAG($A22;2)>=6Abc
B222. / Formel ist =SVERWEIS($A22;ft;4;0)="X"Abc
A231. / Formel ist =WOCHENTAG($A23;2)>=6Abc
A232. / Formel ist =SVERWEIS($A23;ft;4;0)="X"Abc
B231. / Formel ist =WOCHENTAG($A23;2)>=6Abc
B232. / Formel ist =SVERWEIS($A23;ft;4;0)="X"Abc
A241. / Formel ist =WOCHENTAG($A24;2)>=6Abc
A242. / Formel ist =SVERWEIS($A24;ft;4;0)="X"Abc
B241. / Formel ist =WOCHENTAG($A24;2)>=6Abc
B242. / Formel ist =SVERWEIS($A24;ft;4;0)="X"Abc
A251. / Formel ist =WOCHENTAG($A25;2)>=6Abc
A252. / Formel ist =SVERWEIS($A25;ft;4;0)="X"Abc
B251. / Formel ist =WOCHENTAG($A25;2)>=6Abc
B252. / Formel ist =SVERWEIS($A25;ft;4;0)="X"Abc
A261. / Formel ist =WOCHENTAG($A26;2)>=6Abc
A262. / Formel ist =SVERWEIS($A26;ft;4;0)="X"Abc
B261. / Formel ist =WOCHENTAG($A26;2)>=6Abc
B262. / Formel ist =SVERWEIS($A26;ft;4;0)="X"Abc
A271. / Formel ist =WOCHENTAG($A27;2)>=6Abc
A272. / Formel ist =SVERWEIS($A27;ft;4;0)="X"Abc
B271. / Formel ist =WOCHENTAG($A27;2)>=6Abc
B272. / Formel ist =SVERWEIS($A27;ft;4;0)="X"Abc
A281. / Formel ist =WOCHENTAG($A28;2)>=6Abc
A282. / Formel ist =SVERWEIS($A28;ft;4;0)="X"Abc
B281. / Formel ist =WOCHENTAG($A28;2)>=6Abc
B282. / Formel ist =SVERWEIS($A28;ft;4;0)="X"Abc
A291. / Formel ist =WOCHENTAG($A29;2)>=6Abc
A292. / Formel ist =SVERWEIS($A29;ft;4;0)="X"Abc
B291. / Formel ist =WOCHENTAG($A29;2)>=6Abc
B292. / Formel ist =SVERWEIS($A29;ft;4;0)="X"Abc
A301. / Formel ist =WOCHENTAG($A30;2)>=6Abc
A302. / Formel ist =SVERWEIS($A30;ft;4;0)="X"Abc
B301. / Formel ist =WOCHENTAG($A30;2)>=6Abc
B302. / Formel ist =SVERWEIS($A30;ft;4;0)="X"Abc
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
cu jörg
ein feedback wär ganz reizend

Anzeige
AW: zähle die Tage Montag bis Donnerstag im Monat
10.09.2007 23:27:00
FP
Hallo Edwin,
soferne in A1 das Datum des Monatsersten steht:
=SUMME(4+(28-REST(A1-{2.3.4.5};-7)<TAG(A1+32-TAG(A1+32))))
steht in A1 das Jahr und in B1 das Monat:
=SUMME(4+(28-REST((B1&"-"&A1)-{2.3.4.5};-7)<TAG(DATUM(A1;B1+1;))))
für alle die es interessiert:
es wird die Summe der Tage Mo - Fr benötigt ( in A1 steht jeweils der Monatserste )
=SUMME(4+(28-REST(A1-{2.3.4.5.6};-7)<TAG(A1+32-TAG(A1+32))))
es wird die Summe der Tage Mo - Sa benötigt
=SUMME(4+(28-REST(A1-{0.2.3.4.5.6};-7)<TAG(A1+32-TAG(A1+32))))
steht nicht der Monatserste in A1 sondern ein beliebiges Datum: Variante für Mo-Fr
=SUMME(4+(28-REST(A1-TAG(A1)+1-{2.3.4.5.6};-7)<TAG(DATUM(JAHR(A1);MONAT(A1)+1;))))
oder etwas kürzer
=SUMME(4+(28-REST(A1-TAG(A1)-{1.2.3.4.5};-7)<TAG(DATUM(JAHR(A1);MONAT(A1)+1;))))
Servus aus dem Salzkammergut
Franz

Anzeige
Korrektur
11.09.2007 09:45:06
FP
Hallo,
statt TAG(A1+32-TAG(A1+32)) muss/kann man zur Ermittlung des Tages des Ultimo
32-TAG(A1+32-TAG(A1))
einsetzen
Die komplette Formel für ein beliebiges Datum in A1 sieht dann so aus:
=SUMME(4+(28-REST(A1-TAG(A1)+1-{2.3.4.5};-7)<32-TAG(A1+32-TAG(A1))))
Servus aus dem Salzkammergut
Franz

Vielen Dank
11.09.2007 10:55:00
Edwin
Hallo,
vielen Dank Euch allen.
Ich bin immer wieder aufs Neue über die vielen hochqualifizierten Beiträge in diesem Forum begeistert.
Gruß
Edwin

323 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige