Microsoft Excel

Herbers Excel/VBA-Archiv

komplizierte Fragestellung :-(

Betrifft: komplizierte Fragestellung :-( von: Willi Weissnix
Geschrieben am: 19.09.2020 11:13:48

Hallihallo!


Ich bin Biostudent und meine Excelzeit liegt nun schon paar Jahre zurück. Im Rahmen von der Diplomarbeit soll ich in der hoffentlich angehängten Exceldatei die 4 Spalten (A-D) vergleichen und da komm ich überhaupt nicht weiter.

wenn alle 4 werte pro zeile übereinstimmen soll in z.B. Spalte E der Wert 1 erscheinen, wenn einer oder mehrere der Werte um 1 größer oder kleiner ist soll eine 2 auftauchen und wenn einer oder mehrere Werte sich um 2 oder mehr unterscheiden, soll die 3 erscheinen.


Ich habe Excel für Microsoft 365 MSO 16.0.13.029.20232 32-Bit


Kann Excel überhaupt sowas ?

Ich bin dankbar für jede Hilfe und wünsche noch einen schönes Wochenende


https://www.herber.de/bbs/user/140325.xlsx

Betrifft: AW: komplizierte Fragestellung :-(
von: onur
Geschrieben am: 19.09.2020 11:24:05

in E1:
=MAX(A2:D2)-MIN(A2:D2)+1

und runterkopieren.

Betrifft: AW: komplizierte Fragestellung :-(
von: Daniel
Geschrieben am: 19.09.2020 11:26:16

Hi

=MIN(2;MAX(A2:D2)-MIN(A2:D2))+1

Gruß Daniel

Betrifft: AW: komplizierte Fragestellung :-(
von: Zwenn
Geschrieben am: 19.09.2020 11:28:08

Hallo,

das sind doch nur ein paar Vergleiche zwischen Minimum und Maximum:
=WENN(MAX(A2:D2)-MIN(A2:D2)=0;1;WENN(MAX(A2:D2)-MIN(A2:D2)=1;2;WENN(MAX(A2:D2)-MIN(A2:D2)>1;3))) 
Viele Grüße,

Zwenn

Betrifft: AW: komplizierte Fragestellung :-(
von: Hajo_Zi
Geschrieben am: 19.09.2020 11:32:26


Tabelle1
 ABCDE
244441
344332
444342
576753

verwendete Formeln
Zelle Formel Bereich N/A
E2:E5=N(UND(A2=B2; B2=C2;C2=D2))+WENN(N(MAX(A2: D2)-MIN(A2: D2)=1);2;WENN(N(MAX(A2: D2)-MIN(A2: D2)>1);3;0))  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit



GrußformelHomepage

Betrifft: und????
von: Oberschlumpf
Geschrieben am: 19.09.2020 14:33:39

passt auch eine der Antworten???

Betrifft: AW: mE ist noch nicht eindeutig geklärt ...
von: neopa C
Geschrieben am: 20.09.2020 13:22:33

Hallo Willi,

... welches Ergebnis Ergebnis z.B. in Zeile 30 und 32 ermittelt werden soll. Da Du aber geschrieben hast: "wenn alle 4 werte pro zeile übereinstimmen" müssten dort die Leerzellen als 0 gewertet werden. Oder?

Ich würde deshalb in E2 folgende Formel vorschlagen:

=MIN(2;MAX(INDEX(A2:D2+0;))-MIN(INDEX(A2:D2+0;)))+1

und Formel nach unten kopieren.

Wobei in Deiner Excelversion (die ich nicht im Einsatz habe) wahrscheinlich schon folgende Formel:
=MIN(2;MAX(A2:D2+0)-MIN(A2:D2+0))+1 ausreichend sein (in älteren Excelversionen muss diese mit der spez. Tastenkombination [Strg] +[Shift]+[Enter] abgeschlossen werden).

Gruß Werner
.. , - ...

Betrifft: AW: Nur rechnen, wenn alle 4 Felder gefüllt
von: Sulprobil
Geschrieben am: 20.09.2020 17:15:28

=WENN(ANZAHL(A2:D2)=4;MIN(2;MAX(A2:D2)-MIN(A2:D2))+1;"")