Microsoft Excel

Herbers Excel/VBA-Archiv

ganzzahlige Werte einer Differenz | Herbers Excel-Forum


Betrifft: ganzzahlige Werte einer Differenz von: Buh
Geschrieben am: 07.01.2010 17:51:48

Hallo alle zusammen,

ich bin auf der Suche nach einer Lösung für folgendes Problem:

Es gibt 2 Werte z.B. 3 und 8

Ich benötige eine Formel die mir alle ganzzahligen Werte anzeigt die auf und zwischen 3 und 8 liegen, also 3,4,5,6,7,8.

Fällt hier jemandem etwas ein?

Tausend Dank im Vorraus!!!

  

Betrifft: AW: ganzzahlige Werte einer Differenz von: ransi
Geschrieben am: 07.01.2010 17:57:54

HAllo

Reicht das ?
Tabelle1

 ABCDE
138 3 
2   4 
3   5 
4   6 
5   7 
6   8 
7   #ZAHL! 
8   #ZAHL! 
9   #ZAHL! 
10   #ZAHL! 
11   #ZAHL! 
12   #ZAHL! 
13     

Formeln der Tabelle
ZelleFormel
D1{=KKLEINSTE(ZEILE(INDIREKT("A" & $A$1 &":A" &$B$1)); ZEILE(A1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


ransi


  

Betrifft: AW: ganzzahlige Werte einer Differenz von: Josef Ehrensberger
Geschrieben am: 07.01.2010 18:00:07

Hallo ???,

so?

Tabelle5

 AB
11Min3
12Max8
13  
14  
153 
164 
175 
186 
197 
208 
21  
22  
23  

Formeln der Tabelle
ZelleFormel
A15=B11
A16=WENN($B$11+ZEILE(A1)<=$B$12;$B$11+ZEILE(A1); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: ganzzahlige Werte einer Differenz von: Daniel
Geschrieben am: 07.01.2010 18:01:50

Hi
wie sollen den die Werte angezeigt werden, alle in einer Zelle oder in Zellen untereinander?
als formel für den 2. Fall vielleicht so:

Formel in A1: =wenn((3 + Zeile()-1)>8;"";3+Zeile()-1)

diese Formel musst du genügend weit nach unten kopieren, so das alle möglichen Fälle abgedeckt sind.

sollte die Formel nicht in Zeile 1 sondern in einer anderen Zeile beginnen, muss du das entsprechend anpassen, also nicht "Zeile()-1", sondern eben z.B. "Zeile()-2", je nach Zeile, in der die Formel das erste mal steht.

Gruß, Daniel


  

Betrifft: und hier noch in VBA von: Matthias L
Geschrieben am: 07.01.2010 18:06:51

Hallo



Gruß Matthias


  

Betrifft: AW: ganzzahlige Werte einer Differenz von: Buh
Geschrieben am: 08.01.2010 15:41:10

Hallo alle zusammen,

vielen Dank für eure schnellen Antworten.

Ich habe nun alle Möglichkeiten ausgetestet und bin davon beeindruckt das sie auch alle funktionieren. Nun werde ich mich für eine der Lösungen entscheiden.

Die VBA Version ist noch ein wenig zu fortschrittlich für mich, aber eines Tages werde ich es hoffentlich auch anwenden können.

mit besten Grüßen
Stu


Beiträge aus den Excel-Beispielen zum Thema "ganzzahlige Werte einer Differenz"