Datumsdifferenz in Jahren

Bild

Betrifft: Datumsdifferenz in Jahren
von: Markus Brunner
Geschrieben am: 07.04.2005 13:50:11
Hi freaks,
ich bin auf der Suche nach einer Formel die mir die Datumsdifferenz in Jahren in die Kategorien < 2 Jahre; 2 - 5 Jahre und > 5 Jahre einteilt.
z.B. sollte die Datumsdifferenz 1.1.2000 - 2.1.2005 das Ergebnis "> 5 Jahre" bringen.
Mein Ansatz hierfür wäre:
=WENN(UND(DATEDIF(B1;C1;"y")>4;DATEDIF(B1;C1;"md")>-1);"> 5 Jahre")
Alledings bekomme ich es nicht hin, die Parameter 2 - 5 Jahre und kleiner 2 Jahre in diese Formel einzubinden.
Leider hat das VBA-Programmprojekt an dem ich arbeite noch ziemlich viele offene Baustellen und ich muss bis morgen eine Version für unseren Prüfungsausschuss vorbereitet haben.
Deshalb ist das ganze leider brandeilig.
Kann mir jemand helfen?
Vielen Dank im Voraus
Marco

Bild

Betrifft: AW: Datumsdifferenz in Jahren
von: Rudi
Geschrieben am: 07.04.2005 14:54:35
Hallo Marco
Damit müsstest du es hinkriegen:
=WENN(DATEDIF(B1;C1;"M")grössergleich 24;WENN(DATEDIF(B1;C1;"M")grösser 60;"grösser 5 Jahre";"2 - 5 Jahre");"kleiner als 2 Jahre")
Gruss
Rudi
P.S. Bitte die Bezeichnungen "grösser", "kleiner" etc. durch die bekannten Symbole ersetzen. Ich musste wegen einer Fehlermeldung so verfahren.
Bild

Betrifft: AW: Datumsdifferenz in Jahren
von: Markus Brunner
Geschrieben am: 07.04.2005 15:11:15
Danke Rudi,
vielen Dank für Deine Antwort.
Leider funktioniert die Formel nur bedingt.
Probiere den Zeitraum 01.01.2000 bis 02.01.2005 aus.
Ergebnis mit Deiner Formel: 2-5 Jahre.
Aber der Ansatz mit den Monaten ist gut. Nur müssten irgendwie noch die Tage mit einer Wenn-Abfrage berücksichtigt werden. Hast Du eine Idee, wie man die wenn-und Abfrage gestalten könnte?
Mein zweiter Ansatz war:
=WENN(UND(DATEDIF(B1;C1;"y")>4;DATEDIF(B1;C1;"md")>-1);" über 5 Jahre");WENN(UND(DATEDIF(B1;C1;"y")<=1; DATEDIF(B1;C1;"md")>-1);" < 2 Jahre";"2 - 5 Jahre")
Leider bekomme ich hier einen #Wert-Fehler. Irgendwo ist in meiner Formel noch der Wurm drinn. Findest Du ihn?
Übrigens:
Die Zeichen < und > kannst Du hier posten, wenn Du vorher ~f~ eingibst und Deine Nachricht mit ~f~ beendest.
Herzliche Grüße
Marco
Bild

Betrifft: AW: Datumsdifferenz in Jahren
von: Markus Brunner
Geschrieben am: 07.04.2005 15:51:09
Sorry, habe übersehen das "Frage noch offen" Icon zu setzen.
Vielleicht hat auch jemand anderes hier noch eine Idee.
Insbesondere wegen meiner Formel. Ich glaube dass es nur an einer oder zwei Klammern liegt. Trotz größter Suchanstrengungen habe ich meinen Fehler noch nicht gefunden.
cu
Marco
Bild

Betrifft: AW: Datumsdifferenz in Jahren
von: HermannZ
Geschrieben am: 07.04.2005 16:09:14
Hallo Marco,
die Klammer hinter "über 5 Jahre" muss weg dann gehts.
=WENN(UND(DATEDIF(A216;B216;"y")>4;DATEDIF(A216;B216;"md")>-1);" über 5 Jahre";WENN(UND(DATEDIF(A216;B216;"y")<=1; DATEDIF(A216;B216;"md")>-1);" < 2 Jahre";"2 - 5 Jahre"))
Gruß hermann
Bild

Betrifft: AW: Datumsdifferenz in Jahren
von: Rudi
Geschrieben am: 07.04.2005 16:16:19
Hallo Marco
Du hast Recht: Es liegt (auch) an der Klammersetzung. Du darfst die erste Wenn-Formel immer erst ganz am Schluss schliessen.
Es hatte noch einen zweiten Fehler, weshalb immer die Fehlermeldung erschienen ist: DATEDIF von Tagen darf nicht negativ sein.
Mit folgender Formel müsste es jetzt hinhauen.
=WENN(UND(DATEDIF(B1;C1;"Y")>4;DATEDIF(B1;C1;"MD")>=1);" über 5 Jahre";WENN(UND(DATEDIF(B1;C1;"Y")]<=1; DATEDIF(B1;C1;"MD")>=1);" < 2 Jahre";"2 - 5 Jahre"))
Viel Glück!
Rudi
Bild

Betrifft: AW: Datumsdifferenz in Jahren
von: Markus Brunner
Geschrieben am: 08.04.2005 08:46:18
Hallo HerrmannZ, hallo Rudi,
vielen Dank für Eure schnelle Antwort. Leider kam ich gestern wegen akuter Arbeitsüberlastung nicht mehr dazu ins Forum zu schauen.
@HerrmannZ: Stimmt, der Wert-Fehler ist jetzt weg. Leider rechent meine Formel trotzdem nicht richtig. Als Ergebnis kommt immer < 2 Jahre. Vielleicht hat Rudi die Ursache gefunden.
@Rudi: Ich habe Deine Formel über die Zwischenablage eingefügt. Bekomme aber immer die Fehlermeldung: "Die eingegebene Formel enthält einen Fehler". Die eckige Klammer nach DATEDIF(B1;C1;"Y")] habe ich durch eine runde Klammer ersetzt. Trotzdem funktioniert's nicht.
Hat jemand eine Idee, woran es liegen kann, bzw. warum meine Formel nicht funktioniert?
Ihr könnt es einfach testen, indem Ihr die Zellen B1 und C1 als Datumsfelder formatiert und beliebige Zeiträume testet.
Bis bald.
cu
Marco
Bild

Betrifft: AW: Datumsdifferenz in Jahren
von: Markus Brunner
Geschrieben am: 08.04.2005 09:04:59
Habe den Fehler gefunden :-)
@HerrmannZ: Ich habe übersehen die Zellbereich anzupassen.
Hiermit hat es funktioniert:
=WENN(UND(DATEDIF(B1;C1;"y")>4;DATEDIF(B1;C1;"md")>-1);" über 5 Jahre";WENN(UND(DATEDIF(B1;C1;"y")<=1; DATEDIF(B1;C1;"md")>-1);" < 2 Jahre";"2 - 5 Jahre"))
Vielen Herzlichen Dank!!!
@Rudi: Bist Du Dir sicher, dass Datediff "md" nicht negativ sein darf? Im Beispiel https://www.herber.de/bbs/user/20789.xls ist Datediff "md" auch negativ.
Trotzdem vielen Dank an Euch beide :-)
cu
Marco
Bild

Betrifft: AW: Datumsdifferenz in Jahren
von: Markus Brunner
Geschrieben am: 08.04.2005 09:16:59

Ich habe soeben noch einen kleinen Fehler in meiner Formel entdeckt.
Falls jemand die Formel verwenden möchte:
=WENN(UND(DATEDIF(B1;C1;"y")>4;DATEDIF(B1;C1;"md")>0);" über 5 Jahre";WENN(UND(DATEDIF(B1;C1;"y")<=1; DATEDIF(B1;C1;"md")>-1);" < 2 Jahre";"2 - 5 Jahre"))
Jetzt wird auch taggenau der korrekte Zeitraum beim Übergang 2-5 und >5 Jahre berechnet.
cu
Marco
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datumsdifferenz in Jahren"