Microsoft Excel

Herbers Excel/VBA-Archiv

Max und min Wert Finden


Betrifft: Max und min Wert Finden von: Strijbos
Geschrieben am: 28.09.2019 17:18:23

Hallo zusammen,

Habe eine Tabelle mit Daten

In Spalte B stehen Kalender Wochen
In Spalte C Stehen Zeiten
in Spalte D der Name

Problem ist das Zeiten mehrfach vorkommen können

Ich suche nun eine Formel die mir nun die Max Werte ausgibt

Die Zeit ist so dargestellt SS:MM

Möchte nun die Beste Zeit (Niedrigste Zeit dargestellt bekommen, daneben der Name)
Ist ein 2. mit dem gleichen Wert dann in der Spalte darunter der Nächst.

Das Gleiche dann mit der höchsten Zeit

Kann mir einer Helfen, Ich weis , ich habe noch eine Anfrage gestellt, wo das ein Teil war. Sorry

Danke Gruß Björn

  

Betrifft: AW: eine flexible Formellösung ... von: neopa C
Geschrieben am: 28.09.2019 18:02:14

Hallo Börn,

... die es auch ermöglicht, die Datentabelle zu erweitern und auch nachträglich beliebig zu verschieben könnte z.B. so definiert werden, wie nachfolgende aufgeziegt. Formeln E3; F2, H3 und I2 einfach nach unten kopieren.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHI
1WocheZeitName BestZeitName Max ZeitName
2KW_2502:25Name 1 02:09Name 3 02:33Name 2
3KW_2502:33Name 2 02:09Name 5 02:33Name 6
4KW_2502:09Name 3 02:09Name 8   
5KW_2502:22Name 4      
6KW_2502:09Name 5      
7KW_2502:33Name 6      
8KW_2502:15Name 7      
9KW_2502:09Name 8      
10KW_2502:22Name 9      
11         

ZelleFormel
E2=MIN(_DatTab[Zeit])
F2=WENN(E2="";"";INDEX(_DatTab[Name];AGGREGAT(15;6;ZEILE(_DatTab)/(_DatTab[Zeit]=E2);ZÄHLENWENN(E$2:E2;E2))-ZEILE(_DatTab)+1))
H2=MAX(_DatTab[Zeit])
I2=WENN(H2="";"";INDEX(_DatTab[Name];AGGREGAT(15;6;ZEILE(_DatTab)/(_DatTab[Zeit]=H2);ZÄHLENWENN(H$2:H2;H2))-ZEILE(_DatTab)+1))
E3=WENN(KKLEINSTE(_DatTab[Zeit];ANZAHL(E$2:E2)+1)=E2;E2;"")
H3=WENN(KGRÖSSTE(_DatTab[Zeit];ANZAHL(H$2:H2)+1)=H2;H2;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Gruß Werner
.. , - ...


  

Betrifft: AW: nachgetragen: ergänzende Erläuterung ... von: neopa C
Geschrieben am: 28.09.2019 18:10:56

Hallo,

... für die "Quelldaten" (in meinem Beispiel A1:C10) hab ich mit der Funktion "Als Tabelle formatieren" angewendet. Den dadurch dieser automatisch zugewiesene Bereichsname: "Tabelle1" hab ich im Namensmanager in "_DatTab" umbenannt, um eine eindeutige Unterscheidung zum Tabellenblattnamen herzustellen.

Gruß Werner
.. , - ...


  

Betrifft: Bestenliste von: WF
Geschrieben am: 29.09.2019 19:11:25

Hi,

die Zeiten stehen ab C2 und die Namen ab D2 runter.

In E1 steht die Bestzeit:
=MIN(C1:C99)

In E2 steht die Arrayformel:
{=WENNFEHLER(INDEX(D:D;KKLEINSTE(WENN(C$1:C$99=E$1;ZEILE(X$1:X$99));ZEILE(X1)));"")}
runterkopieren

WF


Beiträge aus dem Excel-Forum zum Thema "Max und min Wert Finden"