Pivottabelle: Ergebnisse weiterberechnen

Bild

Betrifft: Pivottabelle: Ergebnisse weiterberechnen von: Naddi
Geschrieben am: 10.03.2005 16:37:28

Hallo.
Hab ein Problem mit Pivottabellen. Ich lasse ANZAHL im Datenfeld errechnen. Nun moechte ich aber in der Pivottabelle mit eben dieser Anzahl (steht in beliebig vielen Spalten) einen Durchschnittswert errechnen lassen.

Also - NICHT ueber das Einfuegen einer weiteren Spalte und Nutzen der normalen Funktionen (Mittelwert); sondern ueber die Bearbeitung eben dieser Pivottabelle.

Koennt Ihr mir helfen? Vielen lieben Dank!

Bild


Betrifft: AW: Pivottabelle: Ergebnisse weiterberechnen von: Otto
Geschrieben am: 11.03.2005 08:53:22

Hallo Naddi,

Meine Testumgebungen: Excel 9.0 SR-1, Multilingual unter Windows 2000 SP-4 und Excel 11 Deutsch unter Windows XP

Kannst Du bitte mal ein kleines Beispiel mit Testdaten posten, damit wir das Problem besser verstehen können?

Gruß Otto


Bild


Betrifft: AW: Pivottabelle: Ergebnisse weiterberechnen von: Nadja
Geschrieben am: 11.03.2005 10:30:07

Hallo Otto.
Anbei ein Beispiel.
Vielen Dank für Deine Hilfe, Naddi

https://www.herber.de/bbs/user/19498.xls


Bild


Betrifft: AW: Pivottabelle: Ergebnisse weiterberechnen von: Otto
Geschrieben am: 11.03.2005 10:50:13

Hallo Naddi,

Meine Testumgebungen: Excel 9.0 SR-1, Multilingual unter Windows 2000 SP-4 und Excel 11 Deutsch unter Windows XP

Die Spalte Durchschnitt soll also extra dazukommen und als Werte {1,5; 1,5; 1; 3} enthalten?
Dann würde ich die Funktion =MITTELWERT($B5:D5) in F5 schreiben und herunterziehen. Eventuell schreibe =MITTELWERT($B1:D1) nach F1 und kopiere es hinter die Gesamtergebnisspalte.
Oder habe ich Dich völlig falsch verstanden? Wenn ja wäre ein Beispiel eines händisch ausgerechneten Ergebnisses hilfreich.
Willst Du ohne VBA auskommen?

Gruß Otto


Bild


Betrifft: AW: Pivottabelle: Ergebnisse weiterberechnen von: Naddi
Geschrieben am: 11.03.2005 10:58:42

Hallo Otto.
Hier nochmal ein Erklärungsversuch.
https://www.herber.de/bbs/user/19503.xls

Vielen Dank für Deine Hilfe, Naddi


Bild


Betrifft: AW: Pivottabelle: Ergebnisse weiterberechnen von: Otto
Geschrieben am: 11.03.2005 11:50:58

Hallo Naddi,

Meine Testumgebungen: Excel 9.0 SR-1, Multilingual unter Windows 2000 SP-4 und Excel 11 Deutsch unter Windows XP

Am einfachsten geht das über das Einfügen einer Spalte vor der PivotTabelle
Dort schreibst Du dann nach A8:
=PIVOTDATENZUORDNEN("MA-Nr.";$B$3)/(ANZAHL(B8:IV8)-1)
und nach A5 schreibst Du
=PIVOTDATENZUORDNEN("MA-Nr.";$B$3;"Haus";$B5)/(ANZAHL(B5:IV5)-1)
Das kannst Du entsprechend herunterziehen.
Man könnte diese Spalte natürlich auch mit VBA füllen lassen, dann ginge das auch hinter der PivotTabelle.

Gruß Otto


Bild


Betrifft: AW: Pivottabelle: Ergebnisse weiterberechnen von: Naddi
Geschrieben am: 11.03.2005 12:09:21

Boah.... 1000 Dank :)


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Pivottabelle: Ergebnisse weiterberechnen"