Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Rechnen mit Datums-/Uhrzeitwerten

Rechnen mit Datums-/Uhrzeitwerten
18.03.2014 16:07:29
Wolfango
Hallo Experten,
Ich ziehe zwei Datumswerte voneinander ab und erhalte die Differenz.
Dieses Ergebnis formatiere ich als [hh]:mm um diese Differenz in Stunden anzuzeigen.
Beispiel:
18.03.2014 00:00:00 minus 15.03.2014 02:00:00 ergibt 70:00 h
Soweit so gut!
Nun möchte ich die errechneten Stunden mit WENN-ABfragen weiterverarbeiten.
Das geht natürlich nicht, da sich hinter der - Kraft Zahlenformat dargestellten - 70:00 die Zahl 2,916666... verbirgt.
Wie wandle ich diese Zahl (die Kraft Zahlenformat dargestellten 70:00 h in eine tatsächliche Zahl 70 um, so dass ich ganz einfache Logikfunktionen daran knüpfen kann?
Danke und Gruß,
Wo

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
* 24.... oder? owT
18.03.2014 16:17:43
Christian

AW: Rechnen mit Datums-/Uhrzeitwerten
18.03.2014 16:18:13
hary
Moin Wolfgango



Tabelle1
 ABC
118.03.2014 00:00  
215.03.2014 02:00  
3 69:0070

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
B3=A1-A2  =R[-2]C[-1]-R[-1]C[-1]
C3=RUNDEN(B3*24;0)  =ROUND(RC[-1]*24,0)

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary

Anzeige
AW: Rechnen mit Datums-/Uhrzeitwerten
18.03.2014 16:28:29
fcs
Hallo Wo,
du musst den Zellwert "nur" mit 24 multiplizieren, um die Stunden dezimal zu erhalten.
Für Zahlenvergleiche solltest du den Wert dann Runden, um Probleme mit der Rechengenauigkeit von Excel zu vermeiden. Bei minutengenauem Rechnen auf 3 Nachkommastellen, bei sekundenenau auf 5 Nachkommastellen.
Beispiel:
=WENN(RUNDEN(G2*24;3)>70;">70";"

Wenn in G2 der Summen-Zeitwert steht.
Gruß
Franz

AW: Rechnen mit Datums-/Uhrzeitwerten
18.03.2014 17:10:27
Wolfango
.....klar!!! (...natürlich einfach mit 24 multiplizieren...)
Ich hab' sowas von viel zu kompliziert gedacht....
Zum Glück gibt's ja euch!!
Vielen Dank an alle!!
Anzeige

311 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige