Microsoft Excel

Herbers Excel/VBA-Archiv

Spalten mit Eintrag zählen

Betrifft: Spalten mit Eintrag zählen von: Anika
Geschrieben am: 27.10.2020 14:57:14

Hallo zusammen,

ich habe eine Tabelle, in der Spalte A und B untereinander die KW auflistet, also pro Zeile Spalte A = Montag, Spalte B = Freitag. Untereinander das ganze Jahr in Wochen.
in den weiteren Spalten habe ich Einträge, wie Modul 1 oder Modul 2, aber auch Urlaub und Praktikum.
Nun möchte ich eine Summe ausgeben, die mir zählt, wie viele Spalten heute alle anderen Einträge, außer Praktikum und Urlaub haben.
Es muss also heute die richtige Zeile finden, und dann in der Zeile zählen, wie viele Einträge, außer Praktikum und Urlaub vorhanden sind.
versteht jemand, was ich meine?

Grüße
Anika

Betrifft: AW: (D)eine Beispieldatei wäre hilfreich(er) owT
von: neopa C
Geschrieben am: 27.10.2020 15:01:00

Gruß Werner
.. , - ...

Betrifft: AW: (D)eine Beispieldatei wäre hilfreich(er) owT
von: Anika
Geschrieben am: 27.10.2020 15:15:22

Hallo Werner,

ich habe die Datei hochgeladen

https://www.herber.de/bbs/user/141127.xlsx

Betrifft: AW: z.B. mit SUMMENPRODUKT() ... w
von: neopa C
Geschrieben am: 27.10.2020 15:34:53

Hallo Anika,

... wenn ich Dein Anliegen richtig interpretiere so:

=SUMMENPRODUKT((D4:P199<>"")*(D4:P199<>"Praktikum")*(D4:P199<>"Urlaub")*(A4:A199<=HEUTE()) *(B4:B199>=HEUTE()))

Teste mal.

Gruß Werner
.. , - ...

Betrifft: AW: z.B. mit SUMMENPRODUKT() ... w
von: Günther
Geschrieben am: 27.10.2020 15:50:29

Moin Anika
Werners Ergebnis stimmt, deine berechneten 8 sind falsch.
Was aber "tödlich" ist sind solche Einträge wie in P93. Da ist gewiss eine Korrektur von Hand mehr als sinnvoll.
 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: Eintrag in P93 analog wie G75 (s.u.) owT
von: neopa C
Geschrieben am: 27.10.2020 15:58:57

Gruß Werner
.. , - ...

Betrifft: AW: z.B. mit SUMMENPRODUKT() ... w
von: Anika
Geschrieben am: 28.10.2020 07:25:57

Hallo Günther,
ja, das muss noch bearbeitet werden.
danke für den Hinweis
liebe Grüße
Anika

Betrifft: AW: hierzu ergänzend nachgetragen ...
von: neopa C
Geschrieben am: 27.10.2020 15:56:14

Hallo Anika,

... hab eben noch festgestellt, das z.B. Deine Praktikumsangaben nicht eindeutig sind. Z.B. würde mit meiner Formel Deine Angabe in G75 nicht als "Praktikum" erkannt werden können.
Wenn Du jedoch z.B. "Praktikum bis 14.07" schreiben würdest dann könnte mit folgender Formel dieses wie auch "Praktikum Home" als "Praktikum" erkenn und werten.

=SUMMENPRODUKT((D4:P199<>"")*(LINKS(D4:P199;6)<>"Prakti")*(D4:P199<>"Urlaub") *(A4:A199<=HEUTE())*(B4:B199>=HEUTE()))

Besser wäre es jedoch, Du würdest in den auszuwertenden Zellen nur eineindeutige Werte (z.B. über Datengültigkeit) zulassen. Dann gibt es auch keine Auswertungsprobleme. Denn selbst nur ein Leerzeichen in einer Zelle würde mit der Formel als "Wert" berücksichtigt.

Gruß Werner
.. , - ...

Betrifft: AW: z.B. mit SUMMENPRODUKT() ... w
von: Anika
Geschrieben am: 28.10.2020 07:24:15

Hallo Werner,
ja, super
du hast mir sehr geholfen
danke :)

Betrifft: AW: gerne owT
von: neopa C
Geschrieben am: 28.10.2020 09:03:06

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Spalten mit Eintrag zählen"