Dynamische Spaltenangabe bei Mittelwert

Bild

Betrifft: Dynamische Spaltenangabe bei Mittelwert
von: Simon
Geschrieben am: 21.10.2015 11:35:06

Hi Community!
Die Seite hat mir in der vergangenheit sehr geholfen nur jetzt bin ich bei einem Punkt angekommen, wozu ich nichts gefunden habe und selbst aktiv werden muss. Ich hoffe ihr könnt mir helfen.
Folgendes Problem:
Ich habe viele "Mittelwert" Funktionen, die ich automatisch updaten will, sobald ein Monat vorbei ist.
Bsp.: Ist der September vorbei, muss der Monat Spetember mit in die Berechnung einfließen. (von Januar bis einschließlich September). (Monate sind in Spalten dargestellt)
Sprich, ich muss die 2. Zahl (also Spalte) um eins weiter nach rechts ziehen.
Gibt es eine Möglichkeit, dass ich eventuell in einer seperaten Zelle angeben kann, welche Spalte als 2. Zahl benutzt werden soll?
-----
Ebeneso wird der mittelwert der letzten 3 Monate benötigt. D.h. ist ein monat vorbei, muss der gesamte bereich um eine spalte nach rechts verschoben werden.
---
Ich hoffe es ist einigermaßen verständlich. Wenn nicht, muss ich doch eine Bsp. Excel erstellen.
Lg & Danke
Simon

Bild

Betrifft: AW: Dynamische Spaltenangabe bei Mittelwert
von: SF
Geschrieben am: 21.10.2015 11:36:41
Hola,

Wenn nicht, muss ich doch eine Bsp. Excel erstellen.
bitte.
Gruß,
steve1da

Bild

Betrifft: AW: Dynamische Spaltenangabe bei Mittelwert
von: Rudi Maintaire
Geschrieben am: 21.10.2015 11:50:21
Hallo,
A1: letzter Monat
=MITTELWERT(A2:INDEX(2:2;;A1))
=MITTELWERT(INDEX(2:2;;MAX(1;A1-2)):INDEX(2:2;;A1))
Gruß
Rudi

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Dynamische Spaltenangabe bei Mittelwert"