INDEX VERGLEICH mit Bezug auf Bereich

Bild

Betrifft: INDEX VERGLEICH mit Bezug auf Bereich
von: MB12
Geschrieben am: 20.06.2015 23:02:23

Hallo zusammen,
folgendes funktioniert problemlos:
In Tabelle1 habe ich über 500 Datensätze mit Aufgaben für verschiedene Abteilungen
In Spalte G steht jeweils das Abteilungskürzel zu der Aufgabe
Für jede Abteilung habe ich ein eigenes Aufgabenblatt,
das Abteilungskürzel steht immer in A1
=INDEX('Tabelle1'!F:F;VERGLEICH($A$1;'Tabelle1!$G:$G;0))
Jetzt kann das Suchkriterium nicht nur in Spalte G (verantwortlich),
sondern manchmal auch in Spalte H (unterstützende Abteilung) stehen.
Wenn ich aber einen Bereich eingebe, bekomme ich die Fehlermeldung #NV:
=INDEX('Tabelle1'!F:F;VERGLEICH($A$1;'Tabelle1!$G$3:$H$520;0))
Was mache ich falsch? Vermutlich irgend ein banaler Fehler…..
Vielen vielen Dank im Voraus
Margarete

Bild

Betrifft: AW: INDEX VERGLEICH mit Bezug auf Bereich
von: SF
Geschrieben am: 20.06.2015 23:09:52
Hola,
warum nicht mit Wennfehler() arbeiten?
Gruß,
steve1da

Bild

Betrifft: AW: INDEX VERGLEICH mit Bezug auf Bereich
von: MB12
Geschrieben am: 20.06.2015 23:19:39
Hi Steve1da,
ganz einfach, weil ich das nicht kenne :-(

Bild

Betrifft: AW: INDEX VERGLEICH mit Bezug auf Bereich
von: SF
Geschrieben am: 20.06.2015 23:22:39
Hola,
bin von Excel gut ausgegangen:

=WENNFEHLER(INDEX(Tabelle1!F:F;VERGLEICH($A$1;Tabelle1!$G$3:$G$520;0));INDEX(Tabelle1!F:F; VERGLEICH($A$1;Tabelle1!$H$3:$H$520;0))) 
Gruß,
steve1da

Bild

Betrifft: AW: INDEX VERGLEICH mit Bezug auf Bereich
von: MB12
Geschrieben am: 20.06.2015 23:45:45
Hi Steve1da,
musste es zwar für meine Zwecke etwas abändern, aber jetzt funktioniert es, herzlichen Dank.
Meine Lernmethode seit fast 30 Jahren: habe eine Aufgabe und löse sie. Und in dieser kurzen Zeit ist mir diese Funktion noch nie untergekommen. Werde sie aber sicher nicht vergessen, da sie auch so einfach verständlich ist.
Gut's Nächtle - jetzt kann ich beruhigt ins Bett gehen...

Bild

Betrifft: Die gibt's auch erst seit 2007! ;-) GuNa! owT
von: Luc:-?
Geschrieben am: 21.06.2015 01:48:00
:-?

Bild

Betrifft: Grundsatzfehler
von: w
Geschrieben am: 20.06.2015 23:50:13
Hi,
VERGLEICH verarbeitet nur eine Spalte. Wenn Du den verwenden willst, musst Du den für jede Spalte hintereinander schachteln - viel Vergnügen (siehe SF).
Per Arrayformel geht es in einem Rutsch.
{=INDEX(F:F;MIN(WENN(G1:H99=A1;ZEILE(1:99))))}
Kommt der Suchbegriff mehrfach vor, wird der in der kleinsten Zeilenzahl herangezogen.
Salut WF


 Bild

Beiträge aus den Excel-Beispielen zum Thema "INDEX VERGLEICH mit Bezug auf Bereich"