Microsoft Excel

Herbers Excel/VBA-Archiv

VBA Makros laufen nicht

Betrifft: VBA Makros laufen nicht von: Franziska S.
Geschrieben am: 06.08.2020 14:15:47

Hallo zusammen,

habe Makros erstellt, welche problemlos funktionieren.

Will ich sie aber über einen eigenen in der customUI14.xml erstellten Tab und dort definierte Buttons aufrufen kommt die Fehlermeldung 450: Falsche Anzahl an Argumenten oder ungültige Zuweisung einer Eigenschaft.
Daraus werde ich so garnicht schlau.
Alle anderen Tabs sind ausgeblendet (). Das ist quasi der Zweck der Sache.
Was bedeutet die Fehlermeldung und was mache ich dagegen?

Vielen Dank schon mal für eure Hilfe.
Gruß
Franzi

Betrifft: Was für eine Art von Makros hast du erstellt, ...
von: Luc:?
Geschrieben am: 06.08.2020 14:42:15

…Franzi,
Funktions- oder SubProzeduren, mit oder ohne zu übergebende Argumente bzw Parameter?
Hinweis: SubProzeduren können extern, also auch per Button, nur ohne Parameter gestartet wdn.
Gruß, Luc :-?

„Die universelle Befähigung zur Unfähigkeit macht jede menschliche Leistung zu einem unglaublichen Wunder.“ Stapps ironisches Paradoxon
Nichtsdestotrotz Durchblick verbessern mit …


Betrifft: AW: Was für eine Art von Makros hast du erstellt, ...
von: Franziska S.
Geschrieben am: 06.08.2020 14:46:04

Hi Luc,

Sub-Prozeduren!
Ich ahne noch immer nix.... :-(

Gruß
Sabine

Betrifft: AW: Hab's! Saublöder Fehler meinerseits
von: Franziska S.
Geschrieben am: 06.08.2020 15:32:13

Einfach im Code was vergessen *im Boden versink*
Nächste Frage meinerseits kommt bestimmt...... :-)

Betrifft: Na, denn iss ja jut... ;-) owT
von: Luc:?
Geschrieben am: 06.08.2020 20:18:10

:-?

Beiträge aus dem Excel-Forum zum Thema "VBA Makros laufen nicht"