Microsoft Excel

Herbers Excel/VBA-Archiv

Letzter bester Preis pro Artikel

Betrifft: Letzter bester Preis pro Artikel von: Peter
Geschrieben am: 04.09.2020 01:23:16

Hallo ihr Lieben,

leider ist diese Anforderung in Excel wohl nicht zu lösen.

Es geht um die Berechnung von Einsparungen. Also, wenn eine Bestellung mit einem bestimmten Daum mit dem letztem aktuellen Preis bestellt worden wäre und das auf Basis der Preis pro Menge.

Ich muss also großen Datenmengen im Nachgang betrachten.

Ggf hat jemand eine Lösung. Kann auch gerne ein Makro sein, welches die Werte ermittelt.

Viel Spaß beim Tüfteln.

https://www.herber.de/bbs/user/140033.xlsx

Betrifft: AW: Letzter bester Preis pro Artikel
von: Peter
Geschrieben am: 04.09.2020 01:33:41

Noch zur Erklärung, die Mengen aus den Bestellungen sind frei und der beste Preis kann natürlich dann nach der schlechtere sein.

Betrifft: AW: wenn in (D)einer Beispieldatei ...
von: neopa C
Geschrieben am: 04.09.2020 09:01:17

Hallo Peter,

... die dafür von Dir angestrebten (händisch ermittelten) Zielergebnisse stünden, könnte es aufklärend wirken.

Gruß Werner
.. , - ...

Betrifft: AW: wenn in (D)einer Beispieldatei ...
von: Peter
Geschrieben am: 04.09.2020 10:31:30

Hallo,

natürlich hast du recht. Ich haben mal Livedaten genommen. Es kommt wohl auch vor, dass die Bestellpreise im Nachgang von Hand engepasst werden können, daher sind in den Bestellungen Preise, die lt. Liste so nicht automatisch ermittelt wurden.

LG

Peter

https://www.herber.de/bbs/user/140040.xlsx

Betrifft: AW: Zielwerte nur teilweise nachvollziehbar ...
von: neopa C
Geschrieben am: 04.09.2020 12:04:14

Hallo Peter,

... in Deiner Tabelle1 ermittele ich in G4 keinen Preis aus der Preistabelle (wegen Nichteinhaltung der Mindestmenge) und würde dann somit gemäß Deiner verbaler Vorgabe dafür den Bestellpreis übernehmen.

Meine Formel in Tabelle1!G3 dafür wäre:

=WENNFEHLER(INDEX(N:N;AGGREGAT(14;6;ZEILE(I$3:I$9)/(I$3:I$9=D3)/(J$3:J$9=C3)/(E3>=M$3:M$9) /(L$3:L$9+(L$3:L$9=0)*HEUTE()<=B3);1));F3)


Die Formel entsprechend angepasst für die Tabelle2!H2 ermittelt analog bis einschließlich Zeile 36 durchgängig schlechte Preise.

=WENNFEHLER(INDEX(N:N;AGGREGAT(14;6;ZEILE(J$2:J$9)/(J$2:J$9=D2)/(K$2:K$9=E2)/(F2>=M$2:M$9) /(P$2:P$9+(P$2:P$9=0)*HEUTE()-7<=A2);1));"")

Prüfe es selbst noch einmal.

Gruß Werner
.. , - ...

Betrifft: AW: Zielwerte nur teilweise nachvollziehbar ...
von: Peter
Geschrieben am: 04.09.2020 14:33:12

Hallo,

erst mal lieben Dank. Ich muss hier intern auch erst mal so einigen Dingen auf den Grund gehen. Wie das dann immer so kommt. Kleie Anfrage wird groß.

Dir ein schönes Wochenende

LG aus Lippe

Peter

Betrifft: AW: danke, wünsch ich Dir auch owT
von: neopa C
Geschrieben am: 04.09.2020 14:52:04

Gruß Werner
.. , - ...

Betrifft: AW: Letzter bester Preis pro Artikel
von: SF
Geschrieben am: 04.09.2020 08:34:04

Hola,

und was wäre jetzt in deiner Beispieldatei dein konkretes Wunschergebnis?

Gruß,
steve1da

Betrifft: AW: Letzter bester Preis pro Artikel
von: Peter
Geschrieben am: 04.09.2020 08:46:17

Guten Morgen,

ich habe die Tabelle jetzt noch ergänzt. In dem Beispiel wurde die Ware zu 2,4 gekauft. Der letzte Preis für diesen Mengenbereich wäre zuvor 1,87 gewesen. Also Vorzeitraum vor dem Bestelldatum.


https://www.herber.de/bbs/user/140035.xlsx

Betrifft: AW: Letzter bester Preis pro Artikel
von: SF
Geschrieben am: 04.09.2020 09:14:14

Hola,

so?
=INDEX($N$3:$N$7;AGGREGAT(15;6;ZEILE($N$3:$N$7)-2/(($I$3:$I$7=D3)*($M$3:$M$7=B3));1))

Gruß,
steve1da

Betrifft: AW: Letzter bester Preis pro Artikel
von: Peter
Geschrieben am: 04.09.2020 09:22:43

Hallo,

bekomme die Meldung #ZAHL!. Die Bestellmenge würde da auch noch eine Rolle spielen müssen?

Betrifft: AW: Letzter bester Preis pro Artikel
von: SF
Geschrieben am: 04.09.2020 09:34:25

Hola,

sorry, hatte die Formel anhand deiner ersten Datei gebaut. Die zweite hat einen Spalteversatz nach rechts...
=INDEX($N$3:$N$7;AGGREGAT(15;6;ZEILE($M$3:$M$7)-2/(($I$3:$I$7=D3)*(B3>=$K$3:$K$7)*(B3<=$L$3:$L$ _
7)*(E3>=$M$3:$M$7));1))

Gruß,
steve1da

Beiträge aus dem Excel-Forum zum Thema "Letzter bester Preis pro Artikel"