Microsoft Excel

Herbers Excel/VBA-Archiv

Gelbe Zellen zählen

Betrifft: Gelbe Zellen zählen von: Roland
Geschrieben am: 05.09.2020 10:15:17

Hallo zusammen,


wie macht mann es, in einer Zahlenreihe gelbe Zellen zu zählen?

In einer Zahlenreihe sind z.B. vorher über bedingte Formatierung 3 Felder gelb hinterlegt worden.

Ich möchte nun, dass in einer Ergebniszelle die Anzahl der gelben Felder ausgeben wird.


https://www.herber.de/bbs/user/140057.xlsx



Vielen Dank für eure Hilfe.

Gruß Roland

Betrifft: AW: Gelbe Zellen zählen
von: Hajo_Zi
Geschrieben am: 05.09.2020 10:27:59

Hallo Roland,

es ist die falsche Datei, da wurde nichts über bedingte Formatierung gefärbt.

GrußformelHomepage

Betrifft: AW: Gelbe Zellen zählen
von: Roland
Geschrieben am: 05.09.2020 10:41:50

Hallo Hajo,
stimmt, im Muster-XLS hab ich einfach mal 3 Zellen zur Veranschaulichung manuell gelb gefärbt.
Gibts zum Farbzellen zählen pauschal einen Lösungsansatz, oder brauch man dazu den Bezug zur Bedingten Formatierung?
Gruß Roland

Betrifft: AW: Gelbe Zellen zählen
von: Hajo_Zi
Geschrieben am: 05.09.2020 10:43:51

Hallo Roland,

ja Du brauhst einen Bezug zur Bedingten Formatierung. Den hattest Du nicht in Deiner Datei nicht, da Du es selber machen wolltest. Also mache es.
Ich bin dann raus.

Gruß Hajo

Betrifft: für die Datei
von: Hajo_Zi
Geschrieben am: 05.09.2020 10:41:23

Hallo Roland,

ohne Bedingte Formatierung.


Tabelle1
 BCDEFGH
21234567
30606600
43      

verwendete Formeln
Zelle Formel Bereich N/A
B3:H3=Hintergrund  
B4=ZÄHLENWENN(B3:H3;6)  

definierte Namen  
Name Bezieht sich auf Tabelle Z1S1-Formel
Hintergrund=ZELLE.ZUORDNEN(63;INDIREKT("Z(-1)S";FALSCH)) =GET.CELL(63,INDIRECT("Z(-1)S",FALSE))
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit



Gruß Hajo

Betrifft: AW: Gelbe Zellen zählen
von: Danielnnd erklärungen
Geschrieben am: 05.09.2020 10:57:32

Hi

Zum Zählen von gefärbten Zellen gibt es genügend Material in den Archiven der diversen Excelforen.

Wenn du mit bedingter Formatierung färbst, ist es am einfachsten sich die Bedingung anzuschauen und über diese zu zählen.
Dh wenn du alle Werte größer 100 färbst, dann nimm ZählenWenn(A:A;">100")


Wenn du unbedingt Farben zählen willst, nutze eine Suchmaschine deiner Wahl, es gibt genügend Beiträge die das Thema behandeln.

Gruß Daniel

Betrifft: Art der Erzeugung gelber Zellen ist egal ...
von: Luc:?
Geschrieben am: 08.09.2020 23:30:36

…mit dieser singularen MatrixFml, die 2 UDFs enthält, Roland;
allerdings ist sie bei deinem (Basis-)Kenntnisstand, der u.a. nicht zu beinhalten scheint, dass es ein wesentlicher Unterschied ist, ob eine Zelle direkt oder indirekt per Regel eines BedingtFormats gefärbt wurde, wohl eher nicht zu empfehlen. Sie kann und soll dir aber zeigen, dass das nicht ohne VBA-Einsatz und nach µS' Willen auch nicht so einfach mit einer ZellFml möglich ist. Man muss die entsprd Einschränkungen umgehen, was keinesfalls zum Xl-BasisWissen gehört.
{=SUMME(--(TxEval("CellColor("&ADRESSE(ZEILE(1:7) ;SPALTE(B:H);4)&")")=65535)) }
Gruß, Luc :-?
„Die universelle Befähigung zur Unfähigkeit macht jede menschliche Leistung zu einem unglaublichen Wunder.“ Stapps ironisches Paradoxon
Nichtsdestotrotz Durchblick verbessern mit …


Beiträge aus dem Excel-Forum zum Thema "Gelbe Zellen zählen"