Microsoft Excel

Herbers Excel/VBA-Archiv

Datengültigkeit

Betrifft: Datengültigkeit von: Fritz_W
Geschrieben am: 11.09.2020 12:43:01

Hallo Excelgemeinde,

mit welcher Formel kann ich mit Hilfe der Datenüberprüfung sicherstellen, dass im Zellbereich A1:A20 nur ganze Zahlen zwischen 1 und 20 eingegeben werden kann, keine Zahl aber mehrfach.

Für eure Hilfen danke ich im Voraus

mfg
Fritz

Betrifft: AW: Zulassen "Ganze Zahl" zwischen 1 und 20 owT
von: neopa C
Geschrieben am: 11.09.2020 12:50:39

Gruß Werner
.. , - ...

Betrifft: keine Zahl aber mehrfach! owT
von: Matthias L
Geschrieben am: 11.09.2020 12:56:11



Betrifft: AW: sorry, Du wolltest ja noch ...
von: neopa C
Geschrieben am: 11.09.2020 12:58:24

Hallo Fritz,

... die Bedingung "eine Zahl aber mehrfach."

Dann benutzerdefinierte Formel:

=(KÜRZEN(A1;)=A1)*(ZÄHLENWENN(A$1:A$20;A1)=1)

und Häkchen au "Leer Zellen ignorieren" entfernen

Gruß Werner
.. , - ...

Betrifft: AW: immer noch nicht richtig ...
von: neopa C
Geschrieben am: 11.09.2020 13:01:29

Hallo,

... dann wohl so; =(KÜRZEN(A1;)=A1)*(ZÄHLENWENN(A$1:A$20;A1)=1)*(A1>0)*(A1<21)

Gruß Werner
.. , - ...

Betrifft: AW: Datengültigkeit
von: Rudi Maintaire
Geschrieben am: 11.09.2020 12:52:52

=(A1=GANZZAHL(A1))*(A1>=1)*(A1<=20)

Gruß
Rudi

Betrifft: keine Zahl aber mehrfach owT
von: Matthias L
Geschrieben am: 11.09.2020 12:56:25



Betrifft: AW: Datengültigkeit
von: Fritz_W
Geschrieben am: 11.09.2020 13:11:55

Sorry Rudi,

auch Dir natürlich ganz herzlichen Dank, wie immer perfekt.

Gruß
Fritz

Betrifft: AW: Datengültigkeit
von: Matthias L
Geschrieben am: 11.09.2020 13:02:51

=(A1=GANZZAHL(A1))*(A1>=1)*(A1<=20)*(ZÄHLENWENN($A$1:$A$20;A1)=1)


Betrifft: AW: Datengültigkeit
von: Fritz_W
Geschrieben am: 11.09.2020 13:03:01

Hallo Werner und Matthias,

funktioniert, herzlichen Denk

Gruß Fritz

Betrifft: AW: wow ...
von: neopa C
Geschrieben am: 11.09.2020 13:17:26

Hallo Fritz,

... gerade mal nur ein und eine halbe Minute hast Du gebraucht, um meinen 3. Vorschlag zu testen und als korrekt einzustufen und dann sogar lediglich 10 sec, um zu erkennen, dass dann auch Matthias eine korrekten Vorschlag eingestellt hat und dies dann auch noch als Beitrag hier festzuhalten.
Dein letzter Beitrag, den zu Rudis Vorschlag, lässt Deine Beiträge in anderem Licht erscheinen.

Gruß Werner
.. , - ...

Betrifft: AW: wow ...
von: Fritz_W
Geschrieben am: 11.09.2020 14:04:09

Hallo Werner,

die Lösungsvorschläge funktionieren doch, oder?

Aber ich will nicht verfehlen, dass Deine Vermutung nicht unbegründet ist: ich habe, weil ich kurzfristig verhindert war (und diese Dauer nicht abschätzen konnte), entgegen der sonstigen Gepflogenheit gleich Rückmeldung geben und mich bedanken wollte. Da ich zudem glaubte, die Kompetenz der Antwortenden einschätzen zu können, habe ich das gemacht, eine (baldige) Rückmeldung und Dankeschön für diejenigen, die mir immer so kompetente Hilfe zukommen lassen, ist mir sehr wichtig. Ich hoffe, Du verstehst mich und siehst mir das nach, es wäre ganz schlimm, wenn gerade Du mir in Zukunft nicht mehr helfen würdest.

Sie mir das nach.

Gruß
Fritz

Betrifft: AW: Dein Vorsatz ist löblich, doch
von: neopa C
Geschrieben am: 11.09.2020 15:45:50

Hallo Fritz,

... es gibt ein altes Sprichwort, das Dir sicherlich auch bekannt sein dürfte:
"vertrauen ist gut doch Kontrolle ist besser"
So entsprachen z.B. meine ersten beiden Vorschläge eben leider nicht Deiner Zielstellung sondern erst mein 3. Vorschlag und kurze Zeit danach auch der von Matthias.

Gruß Werner
.. , - ...

Betrifft: AW: Dein Vorsatz ist löblich, doch
von: Fritz_W
Geschrieben am: 11.09.2020 15:59:19

Ja Werner das Sprichwort kenn ich.
In solchen Fällen könnte man sich bedanken, aber mitteilen, dass man noch testet und sich ggf. später noch einmal meldet.

Gruß Fritz

Betrifft: =SUMMENPRODUKT(VERGLEICH(ZEILE(1:20);A1:A20;0))
von: WF
Geschrieben am: 11.09.2020 14:14:47

.

Betrifft: AW: =SUMMENPRODUKT(VERGLEICH(ZEILE(1:20);A1:A20;0))
von: Fritz_W
Geschrieben am: 11.09.2020 14:36:43

Hallo WF,

auch Dir vielen Dank.

wenn ich die Formel für die Zelle A1eingebe erfolgt folgende Meldung:
"Die Funktion untersucht gerade einen Fehler. Möchten Sie den Vorgang fortsetzen?"

Gruß
Fritz

Betrifft: AW: hier hast Du alles richtig gemacht ....
von: neopa C
Geschrieben am: 11.09.2020 15:50:30

Hallo Fritz,

... indem Du kontrollieren wolltest. Aber bereits Excel erkennt berechtigt einen fehlerhaften Ansatz.
Du hast aber für Deine Zielstellung schon zwei funktionierende Lösungsvorschläge, eine davon kannst Du nutzen.

Gruß Werner
.. , - ...

Betrifft: andere Interpretation
von: WF
Geschrieben am: 12.09.2020 07:06:14

Hi,

ich ging davon aus, dass in A1 bis A20 ALLE Zahlen von 1 bis 20 (unsortiert) vorkommen MÜSSEN.
Also keine Leerzellen.

WF

Betrifft: AW: andere Interpretation
von: Fritz_W
Geschrieben am: 12.09.2020 12:43:56

Hallo WF,

vielen Dank für die Rückmeldung.

Gruß
Fritz