Microsoft Excel

Herbers Excel/VBA-Archiv

Gewichtung einzelner Datenzeilen

Betrifft: Gewichtung einzelner Datenzeilen von: Janno
Geschrieben am: 29.09.2020 10:56:13

Hallo zusammen,


anbei eine Beispieldatei: https://www.herber.de/bbs/user/140509.xlsx


wie finde ich über eine Formel heraus wie viele Äpfel Max und wie viele Äpfel Mustermann verkauft? Die Mengen und Anzahl der verkauften Zeilen variieren dabei (s. Beispieldatei).


Danke für Eure Mithilfe.


Grüße

Janno

Betrifft: AW: dazu nutze ZÄHLENWENNS(), wobei ...
von: neopa C
Geschrieben am: 29.09.2020 10:58:58

Hallo Janno,

... eine umfassendere trotzdem einfache wie flexible Auswertung aller Daten mit einer Pivotauswertung möglich ist.

Gruß Werner
.. , - ...

Betrifft: AW: sorry, natürlich meinte ich SUMMEWENNS() ...
von: neopa C
Geschrieben am: 29.09.2020 11:07:35

Hallo Janno,

... als Formellösung. Also für Max:

=SUMMEWENNS(B:B;A:A;"Apfel";C:C;"Max")

Trotzdem: Schau Dir mal eine Pivotauswertung an.

Gruß Werner
.. , - ...

Betrifft: mit SUMMENPRODUKT (alle Excel-Versionen)
von: WF
Geschrieben am: 29.09.2020 11:09:04

=SUMMENPRODUKT((A2:A20="Apfel")*(C2:C20="Max")*B2:B20)

WF

Betrifft: AW: die Pivotauswertung (auch alle Excelversionen)
von: neopa C
Geschrieben am: 29.09.2020 11:34:42

Hallo Janno nochmal,

... und dies nachfolgend auch gleich mit Diagramm (PivotCart) ist mit wenigen Mausklicks erstellt. Sieh mal: https://www.herber.de/bbs/user/140511.xlsx

In dieser kannst Du nun sowohl in der Ergebnistabelle als auch im Chart noch zusätzlich beliebig filtern und die Ergebnisanzeige schnell ändern.

Gruß Werner
.. , - ...