Microsoft Excel

Herbers Excel/VBA-Archiv

Anwesende Person Ermitteln

Betrifft: Anwesende Person Ermitteln von: Sebastian
Geschrieben am: 30.09.2020 09:55:55

Hallo liebe Gemeinde,


ich habe schonmal gefragt und auch eine Lösung gefunden. Jetzt ist es so, das ich noch eine weitere Lösung suche.


Ich ermittel in einer Tabelle für einen bestimmten Zeitraum die Anzahl der anwesenden Personen. Jetzt möchte ich aber gern, wenn nur eine Person im Verein da ist, den Namen des Anwesenden dahinter schreiben. die Tabelle habe ich mal hochgeladen.


https://www.herber.de/bbs/user/140535.xlsx


Hat jemand eine Idee wie ich das lösen kann?


Viele Grüße

Sebastian

Betrifft: nur ne Solo-Person auswerfen
von: WF
Geschrieben am: 30.09.2020 10:25:57

Hi,

in E6 folgende Arrayformel:
{=WENN(D6=1;INDEX(D:D;MAX(($B$18:$B$22<=B6)*($C$18:$C$22>=C6)*ZEILE(X$18:X$22)));"")}

WF

Betrifft: AW: nur ne Solo-Person auswerfen
von: Sebastian
Geschrieben am: 30.09.2020 10:41:11

Das Funktioniert - nur mal eine Frage zum Verständnis

Was hat das X zu bedeuten bei ZEILE(X$18:X$22)

Viele Grüße und Danke
Sebastian

Betrifft: Du kannst auch Zeile($18:$22) nehmen
von: WF
Geschrieben am: 30.09.2020 10:58:01

Das gibt bei umfangreicheren Tabellen aber Performanceprobleme, da ganze Zeilen abgefragt werden.
ZEILE(X$18:X$22) bezieht sich nur auf eine.
Ich nehme X (Du kannst auch jeden anderen Spaltenbuchstaben nehmen), da diese Spalte nicht vorkommt.

Nimmst Du z.B. Spalte B kommen von Anfängern dauernd Nachfragen, da die nachschauen, was in der Zelle steht. Dass das nur eine Zahlenkrücke sein Kann, kapieren sie bei X, da da nichts steht.

WF

Betrifft: AW: Du kannst auch Zeile($18:$22) nehmen
von: Sebastian
Geschrieben am: 30.09.2020 11:26:01

Ok Vielen Dank ich habe es verstanden :-)

Betrifft: AW: Du kannst auch Zeile($18:$22) nehmen
von: Luschi
Geschrieben am: 30.09.2020 21:17:35

Hallo Sebastian,

wenn Du Excel 365 im Einsatz hast, dann ist diese Formel genau das Richtige für die Lösung:

=WENN(D6=1;FILTER($D$18:$D$22;($B$18:$B$22<=B6)*($C$18:$C$22>=C6));"")

Gruß von Luschi
aus klein-Paris

Betrifft: AW: alternativ ...
von: neopa C
Geschrieben am: 30.09.2020 11:30:24

Hallo Sebastian,

... in E6 so: =WENN(D6=1;INDEX(D:D;AGGREGAT(15;6;ZEILE(D$18:D$99)/(B$18:B$99<C6)/(C$18:C$99>B6);1));"")

Gruß Werner
.. , - ...

Betrifft: Da isser ja.
von: WF
Geschrieben am: 30.09.2020 11:52:48

.