Microsoft Excel

Herbers Excel/VBA-Archiv

Verweis / indirekt / Vergleich?

Betrifft: Verweis / indirekt / Vergleich? von: Bernd
Geschrieben am: 17.10.2020 13:15:46

Moin zusammen,

bin mal wieder hilflos und es wäre schön, wenn mir da jemand helfen könnte:

Habe eine Datei mit dem Blatt Vorgabe in dem verschiedene Beträge für die unterschiedlichen Monate aufgeführt sind.
Im Blatt Januar sollen nun nur die Beträge gemäß des Blattes Vorgabe in der Spalte C übernommen werden die größer Null sind. Als weitere Identifikation dient die Spalte A in der die betreffenden Konten aufgeführt sind.

Das selbe soll mit den Blättern Februar bis incl. Dezember geschehen.

Lieben Dank schon einmal für eure Hilfe.

Bernd

https://www.herber.de/bbs/user/140932.xlsx

Betrifft: AW: Verweis / indirekt / Vergleich?
von: Herbert_Grom
Geschrieben am: 17.10.2020 13:32:06

Hallo Bernd,

in Januar C2:
=WENNFEHLER(INDEX(Vorgabe!$C$3:$C$14;AGGREGAT(15;6;ZEILE($A$1:$A$12)/(Vorgabe!$C$3:$C$14>0) /(Vorgabe!$B$3:$B$14=B2);1));"") 
Servus

Betrifft: AW: Verweis / indirekt / Vergleich?
von: Bernd
Geschrieben am: 17.10.2020 21:10:19

Moin zusammen, erst einmal lieben Dank für eure Hilfe und soweit passt es so wie ich das vorhatte. Nun kommt aber die Raupe Nimmersatt ins Spiel. Die hätte da noch zwei Wünsche:

1. Wäre es möglich, Zeilen auszublenden, in denen in der Spalte C kein Wert aufgeführt ist?

2. Wäre es möglich, Zeilen auszublenden, in denen in der Spalte C der selbe Wert wie in der Spalte D eingetragen ist (wobei die Werte in der Spalte D, nach und nach eingetrudelt kommen)?

LG Bernd

Betrifft: AW: möglich ist vieles, doch ...
von: neopa C
Geschrieben am: 17.10.2020 21:44:37

Hallo Bernd,

... definiere doch mal, was Du genau unter "ausblenden" verstehst.
Zu 1.) Willst Du die in Spalte A der Monatsblätter nur die Konten durch Formel gelistet haben, die im Vorgabe-Tabellenblatt auch einen Wert gelistet haben? Oder?

Und was Du mit 2. meinst, entzieht sich momentan meiner Fantasie.

Erkläre Deine Zielstellung am besten konkret an Deinen Beispieldatenvorgaben?

Gruß Werner
.. , - ...

Betrifft: AW: möglich ist vieles, doch ...
von: Bernd
Geschrieben am: 17.10.2020 22:04:49

Dann versuche ich mal meine Ideen klarer zu definieren. :-)

Zu 1: Das hast du schon richtig erfasst Werner: Im Januar sollen die Zeilen 5,6,7, 11,12,13 ausgeblendet werden.
Zu 2: Der Wert der in Spalte C steht ist ein Soll-Wert. Durch verschiedene Eingaben in einem anderen Bereich des Blattes summiert sich der Wert in der Spalte D. Sind die Werte in der Spalte C mit denen der Spalte D identisch, soll sich die entsprechende Zeile ausblenden.
Beispiel Januar Konto 1102 mit dem Sollwert von 120 in der Zelle C4. Im Bereich der Spalten G&H wird die Eingabe 1102 (z.B. G12) 120 (z.b. H12) getätigt. Dieser Wert wird in die Zelle D4 übertragen. Somit ist der Wert der Zelle C4 identisch mit dem der Zelle D4. Da dies so ist, soll die Zeile 4 ausgeblendet werden.

Ich hoffe, dass ich mich diesmal klarer ausgedrückt habe. Ist halt nicht immer meine Stärke :-(.

VG Bernd

Betrifft: AW: auch wieder nur eine Formel ...
von: neopa C
Geschrieben am: 18.10.2020 09:43:05

Hallo Bernd,

... und zwar für alle Monate gleichzeitig zu 1.
Dazu gruppiere zunächst wieder die Tabellenblätter.
Dann in Januar!A2 folgende Formel:

=WENNFEHLER(INDEX(Vorgabe!A:A;AGGREGAT(15;6;ZEILE(A$1:A$99)/ISTZAHL(INDEX(Vorgabe!$A:$N;;VERGLEICH(TEIL(ZELLE("Dateiname";$A$1);FINDEN("]";ZELLE("Dateiname";$A$1))+1;31);Vorgabe!$1:$1;0)));ZEILE(A1)));"")

und diese weit genug nach unten und in Spalte B kopieren.

Dann Gruppierung wieder aufheben.

zu 2. Meinst Du mit Deinen Angaben Daten werte im Tabellenblatt Vorgabe? Oder? Meinst Du mit ausblenden dann dass in so einem Fall die Kontonummer in Spalte A dann gar nicht erst erscheint?

Gruß Werner
.. , - ...

Betrifft: AW: mit VERWEIS() u.INDEX() in nur 1ner Formel ...
von: neopa C
Geschrieben am: 17.10.2020 13:57:23

Hallo Bernd,

... gruppiere Deine 12 Monatsblätter dann folgende Formel in C2:

=WENN(A2="";"";VERWEIS(9;1/(Vorgabe!$A$1:$A99&Vorgabe!$B$1:$B$99=A2&B2);INDEX(Vorgabe!A:N;;VERGLEICH(TEIL(ZELLE("Dateiname";$A$1);FINDEN("]";ZELLE("Dateiname";$A$1))+1;31);Vorgabe!$1:$1;0))))

und nach unten ziehend kopieren.

Blattgruppierung wieder aufheben nicht vergessen.

Gruß Werner
.. , - ...