Microsoft Excel

Herbers Excel/VBA-Archiv

Index Vergleich

Betrifft: Index Vergleich von: Navid
Geschrieben am: 22.10.2020 17:36:04

Hallo,

kann man bei Index&Vergleich eine entweder oder Suchkriterium einfügen? Also wenn Excel das eine Suchkriterium nicht findet soll er nach dem anderen Suchkriterium suchen.

Hier meine Formel:

=WENNFEHLER(WENN(ODER(M5="Equity Call";M5="Equity Put";M5="Index Future";M5="Index Call"); INDEX(UNIVERSAL_DATA!AW:AW;VERGLEICH(N5&K5;UNIVERSAL_DATA!$AZ:$AZ&UNIVERSAL_DATA!$AW:$AW;0)); WENN(UND(M5="Equity CFD";J5="GBP");INDEX(MS_DATA!Y:Y*100;VERGLEICH(SVERWEIS(D5;HELP_DATA!B:C;2; FALSCH);MS_DATA!Q:Q;0);1);WENN(M5="Equity CFD";INDEX(MS_DATA!Y:Y;VERGLEICH(SVERWEIS(D5;HELP_DATA!B:C; 2;FALSCH);MS_DATA!Q:Q;0);1);INDEX(UNIVERSAL_DATA!AW:AW;VERGLEICH(PMA!E5;UNIVERSAL_DATA!$C:$C;0);1)))) ;"")

Betrifft: AW: Index Vergleich
von: Navid
Geschrieben am: 22.10.2020 17:40:26

*ein

Betrifft: ODER funktioniert da nicht - nimm + (plus)
von: WF
Geschrieben am: 22.10.2020 18:27:58

.

Betrifft: AW: Index Vergleich
von: Daniel
Geschrieben am: 22.10.2020 18:37:45

Hi

Das geht mit WennFehler:

WennFehler(Vergleich(suchwert1;Spalte;0);Vergleich(suchwert2;Spalte;0))

Wenn der erste Vergleich einen Fehler ergibt, wird der zweite angewendet.

Gruß Daniel

Beiträge aus dem Excel-Forum zum Thema "Index Vergleich"