Microsoft Excel

Herbers Excel/VBA-Archiv

Automatisierter Durchschnittswert

Betrifft: Automatisierter Durchschnittswert von: Clara
Geschrieben am: 22.10.2020 17:21:50

Guten Abend zusammen,

ich seh' den Wald vor lauter Bäumen nicht mehr, nachdem ich nun bestimmt 2 Stunden alles ausprobiert habe was mir eingefallen ist.

https://www.herber.de/bbs/user/141026.xlsm

Ziel:

  • In der hochgeladenen Excel möchte ich im Sheet "Vorlage" in Spalte I immer den Durchschnittswert (d.h. den durchschnittlichen Kaufpreis) bilden.

  • Dieser Durchschnittspreis ist relevant für einen möglichen späteren Verkauf.

  • Da die Auflistung in der Tabelle chronologisch geschehen soll (sieht man in Spalte B), darf der Durchschnittswert immer nur den Stückpreis aus Käufen berücksichtigen, die VOR einem Verkauf liegen.

  • Das ganze soll dann mitwachsen indem man einfach ein neues Ereignis (Kauf oder Verkauf) durch einfügen einer neuen Tabellenzeile (Tab-Taste in der letzten Zelle von Spalte I, hier bspw. I6) anlegt, sodass die Formel nicht mehr "angefasst" werden muss und jeder Anwender einfach nur stupide die Platzhalter "Menge" etc. befüllen muss.


  • Bisheriger Fehler:
    Der Durchschnittswert bezieht für ein Ereignis JEDES Kauf-Ereignis mit ein, auch wenn es in der Zukunft liegt. Das macht dann natürlich keinen Sinn.

    Besten Dank für eure Bemühungen meine Kopfschmerzen zu lindern.

    VG
    Clara

    PS: Würde das eigentlich ganz gern ohne VBA lösen...

    Betrifft: AW: Automatisierter Durchschnittswert
    von: Peter Müller
    Geschrieben am: 22.10.2020 18:06:59

    Hallo Clara,

    hilft dir vielleicht diese Formel (in "Vorlage", Zelle I3):
    =SUMMEWENNS($G$3:G3;$C$3:C3;"Kauf";$B$3:B3;"<="&B3)/SUMMEWENN($C$3:C3;"Kauf";$D$3:D3)
    Gruß
    Peter

    Betrifft: AW: Automatisierter Durchschnittswert
    von: Clara
    Geschrieben am: 23.10.2020 08:30:27

    Danke Peter,

    also das funktioniert schonmal besser. Mit dem Datum und SUMMEWENNS hatte ich es auch versucht, aber wohl nicht richtig. Das einzige was dabei nicht funktioniert ist meine Ausführung im letzten Bulletpoint:

    Füge ich eine neue Zeile in der Tabelle ein (Tab-Taste im letzten Feld, I6), umfasst die die Zeile mit I6 dann auch den Bereich der neuen Zeile I7, sodass die Formeln I6 = I7.

    Hier noch eine Idee? Ansonsten muss ich da vermutlich versuchen, ob ich deine Formel mit einem Makro immer sauber weiterkopiere sobald eine neue Zeile hinzukommt. Ich dachte nur, dass das einfacher gehen muss.

    LG
    Clara

    Betrifft: AW: Automatisierter Durchschnittswert
    von: Peter Müller
    Geschrieben am: 23.10.2020 09:14:59

    Hallo Clara,

    schau mal, ob das so funktioniert:

    https://www.herber.de/bbs/user/141034.xlsm


    Gruß
    Peter

    Betrifft: Vielen lieben Dank! owT
    von: Clara
    Geschrieben am: 23.10.2020 09:34:59