Microsoft Excel

Herbers Excel/VBA-Archiv

Vereinfachung einer Suche von Texten

Betrifft: Vereinfachung einer Suche von Texten von: Benny
Geschrieben am: 05.11.2020 12:57:32

Hallo an Alle Experten



Also ich schildere mal mein Vorhaben.

Ich möchte gerne das in Meile Zelle G1 ein Ja oder Nein herauskommt.

Hierzu soll er bei der Zelle A1 bis F1 ermittelt ob der Text1 oder Text2 vorhanden ist.

Falls einer dieser Texte vorhanden ist soll er nein sagen sonst ja.


Ich habe

Hier meine Formel:


=WENN(SUMME(WENN(ODER(A1=TEXT1;A1=TEXT2);1;0);<br>
WENN(ODER(B1=TEXT1;B1=TEXT2);1;0);WENN(ODER(C1=TEXT1;C1=TEXT2);1;0);<br>
WENN(ODER(D1=TEXT1;D1=TEXT2);1;0);WENN(ODER(E1=TEXT1;E1=TEXT2);1;0);<br>
WENN(ODER(F1=TEXT1;F1=TEXT2);1;0))größer 0;Nein;JA)




Nun meine Frage,

Kann ich diese Formel mir vereinfachen oder sogar in VGA umschreiben?

Betrifft: AW: Vereinfachung einer Suche von Texten
von: Oberschlumpf
Geschrieben am: 05.11.2020 13:00:29

Hi Benny,

sorry, aber dein Deutsch (Grammatik, Tippfehler, usw) ist nicht das Beste.
Dadurch ist das Verstehen deiner Frage nicht ganz so einfach.
Kannst du bitte eine Bsp-Datei per Upload zeigen?

Ciao
Thorsten

Betrifft: AW: mit SUMMENPRODUKT() von ZÄHLENWENN() ...
von: neopa C
Geschrieben am: 05.11.2020 13:08:59

Hallo Benny,

... so: =WENN(SUMMENPRODUKT(ZÄHLENWENN(A1:F1;{"Text1";"Text2"}))>0;"Ja";"nein")

ob das allerdings für Deine eine Vereinfachung ist, kannst nur Du entscheiden.

Gruß Werner
.. , - ...

Betrifft: AW: Vereinfachung einer Suche von Texten
von: Charly CNX
Geschrieben am: 05.11.2020 13:24:01

Hi Benny
In G1
=WENN(ODER(A1:F1="Text1";A1:F1="Text2");"Nein";"Ja")
Gruss Charly

Betrifft: AW: nicht: ..."Nein";"Ja") ...
von: neopa C
Geschrieben am: 05.11.2020 13:34:31

Hallo Charly,

... sondern ..."Ja";"Nein") in Deiner Formel und diese Formel muss in Excel vor Office 365 als Matrixformel eingegeben werden.

Gruß Werner
.. , - ...

Betrifft: @Werner
von: Charly CNX
Geschrieben am: 05.11.2020 13:44:38

Hallo Werner
Ich hab MS 365,deshalb hab ichs nicht bemerkt.
Danke fuer den Hinweis.
Aber ...
Falls einer dieser Texte vorhanden ist soll er nein sagen sonst ja.
Gruss Charly

Betrifft: AW: damit hast Du Recht, habe ich ...
von: neopa C
Geschrieben am: 05.11.2020 13:50:01

Hallo Charly,

... nicht richtig gelesen und dadurch dann auch in meinem Vorschlag falsch herum angegeben.
Danke Dir.

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Vereinfachung einer Suche von Texten"