Gradtagzahlen berechnen

nach unten

Betrifft: Gradtagzahlen berechnen
von: mike49
Geschrieben am: 13.10.2021 22:02:21

Hallo Leute,
ich möchte für die Heizkostenabrechnung die Gradtagszahlen bei Mieterwechsel berechnen.
Diese sind in der Gradtagszahlentabelle nach VDI 2067 für jeden Monat festgelegt und ergeben in der Summe von Januar bis Dezember den Wert 1000.
Ich möchte jetzt den Beginn des Nutzungszeitraums in eine Zelle eintragen und das Nutzungsende in die danebenliegende. Das Ergebnis sollte dann in einer weiteren Zelle angezeigt werden.
Gibt man z.B. in A1 das Datum 01.04.2020 und in B1 das Datum 31.12.2020 ein, müsste in C1 der Wert 550 Gradtage angezeigt werden.
Schwieriger wird es, wenn übers Jahr ermittelt werden soll:
Gibt man z.B. in A1 das Datum 01.08.2014 und in B1 das Datum 30.06.2015 ein, müsste in C1 der Wert 987 Gradtage angezeigt werden.
Lässt sich das verwirklichen? Hat jemand eine Lösung?
Gruß
mike49

nach oben  nach unten

Betrifft: AW: Gradtagzahlen berechnen
von: Yal
Geschrieben am: 13.10.2021 22:35:20

Hallo Mike,
Du hast dann wohl eine Liste mit
_ Spalte 1 ("A") für alle Tage zwischen einem ersten Tag und heute (erster Tag ab Zeile 2)
_ Spalte 2 ("B") für den Gradtagzahl zu dem gegebenen Tag
Dann brauchst Du eine kumulierende Spalte "C", also fortlaufend dem Kuml vom Vortag + Tag der Zeile:
_ in C1 steht 0
_ in C2 steht = C1+ B2
_ in C3 steht = C2+ B3
usw.
So kannst Du
per Sverweis den kumulierte Gradtagzahl zum Austrittstag
minus den
per Sverweis kumulierte Gradtagzahl zum Tag vor der Eintritt.
Viel Erfolg
Yal

nach oben  nach unten

Betrifft: AW: Gradtagzahlen berechnen
von: onur
Geschrieben am: 13.10.2021 22:58:04

Was ist mit 2021? Da gibt es keine Werte, wenn das Jahr nicht um ist.
Wie sieht DEINE Tabelle aus? Täglich? Monatlich? Jahr für Jahr oder fortlaufend?
Ist der Start immer am Ersten des Monats?
Du solltest mal eine Datei posten.

nach oben  nach unten

Betrifft: AW: Gradtagzahlen berechnen
von: mike49
Geschrieben am: 13.10.2021 23:16:45

Hallo ,
danke für die Antwort.
Ich lade die Tabelle mal hoch https://www.herber.de/bbs/user/148609.xlsx
Die Werte in F20 und F20 habe ich manuell eingetragen. Die sollen aber automatisch nach Eingabe des Nutzungszeitraums berechnet werden.
LG
mike49

nach oben  nach unten

Betrifft: AW: Gradtagzahlen berechnen
von: RPP63
Geschrieben am: 14.10.2021 07:45:08

Moin!
Schwieriger wird es, wenn übers Jahr ermittelt werden soll
Erstellst Du die Hzk-Abrechnung selbst?
Grundsätzlich macht es Sinn, als Abrechnungszeitraum der kompletten Nebenkostenabrechnung das Kalenderjahr zu nehmen.
Dann ist die Berechnung der Gradtagszahlen einfach:
 BCDEF
20Nutzungszeitraum01.04.202031.12.2020550,00
21  01.08.201430.11.2014243,48
22  01.02.201931.08.2019440,00

ZelleFormel
F20=SUMME(INDEX(F$4:F$16;MONAT(D20)+(MONAT(D20)>2)):INDEX(F$4:F$16;MONAT(E20)+(MONAT(E20)>2)))

Willst Du tatsächlich an einer überjährigen Lösung festhalten, musst Du wie folgt aufdröseln:
=WENN(JAHR(Ende)>JAHR(Anfang);komplizierteFormel;obigeFormel)
Gruß Ralf

nach oben  nach unten

Betrifft: AW: Gradtagzahlen berechnen
von: mike49
Geschrieben am: 14.10.2021 08:57:11

Moin Ralf,
danke für die schnelle Hilfe. Das funktioniert auch super, wenn der Nutzungszeitraum nicht jahrübergreifend ist.
Ja, ich erstelle die Heizkostenabrechnung selbst..
Wie müsste denn die "aufgedröselte" Lösungsformel in meinem Beispiel (01.08.2014 bis 30.06.2015) aussehen? Ich verstehe das nicht ganz! Sorry!
Gruß
mike49

nach oben  nach unten

Betrifft: Gradtagzahlen für ganze Monate
von: WF
Geschrieben am: 14.10.2021 08:39:15

Hi,
die Zeile 5 (Februar 28) hab ich gelöscht.
2 mal Februar in einer Monatstabelle ist bescheuert. Außerdem sind die Gradtage jeweils 150.
Folgende Arrayformel:
{=SUMME(ISTZAHL(VERGLEICH(ZEILE(X$1:X$12);MONAT(D19+ZEILE(INDIREKT("X1:X"&E19-D19)));0))*F$4:F$15)}
runterkopteren
WF
von - bis darf nicht länger als 1 Jahr sein.

nach oben  nach unten

Betrifft: AW: Gradtagzahlen für ganze Monate
von: mike49
Geschrieben am: 14.10.2021 09:12:30

Hallo WF,
auch dir danke für deinen Lösungsvorschlag.
Die Tabelle wird auch für die Ermittlung der Nutzungstage benötigt. In einem Schaltjahr wie 2020 hat der Februar 29 Tage.
Diese Tatsache tragen die Formeln in E5 und E6 Rechnung.
Mit verlaub: die Zeile 5 kann also nicht gelöscht werden!
Vielleicht kannst du deine Formel diesbezüglich anpassen? Was ist mit Zelle X gemeint?
LG
mike49

nach oben  nach unten

Betrifft: Februar bleibt solo
von: WF
Geschrieben am: 14.10.2021 09:17:49

Hi,
28 oder 29 Tage klärt man mit einer WENN-Abfrage.
Zeile(x1:x12) sind die Zahlen 1 bis 12 entsprechend den Monatszahlen
WF

nach oben  nach unten

Betrifft: AW: Februar bleibt solo
von: mike49
Geschrieben am: 14.10.2021 09:41:51

Ok. Danke. Wieder was dazugelernt
Das hilft mir aber jetzt nicht wirklich weiter, was die jahresübergreifende Ermittlung der Gradtagzahlen betrifft.
Gruß
mike49

nach oben  nach unten

Betrifft: Jahreswechsel sind abgedeckt
von: WF
Geschrieben am: 14.10.2021 10:13:30

Hi,
die Monatsfolge muss nicht chronologisch sein.
Die Zahl 1 (Januar) wird gesucht und auch gefunden egal, ob sie am Anfang oder irgendwo in der Mitte steht.
WF

nach oben  nach unten

Betrifft: AW: Jahreswechsel sind abgedeckt
von: mike49
Geschrieben am: 14.10.2021 11:07:42

Uups!
Das verstehe ich nicht ganz!
Kann ich jetzt in D20 eintragen: 01.08.2014 und in E20 30.06.2015 und in F20 wird der Wert 987 angezeigt?
mike49

nach oben  nach unten

Betrifft: AW: Jahreswechsel sind abgedeckt
von: mike49
Geschrieben am: 14.10.2021 11:10:32

anstatt 987 wird bei mir 40 angezeigt!
Mache ich was falsch? Muss die Formel abgeändert werden?

nach oben  nach unten

Betrifft: ja, irgendwas machst Du falsch ?
von: WF
Geschrieben am: 14.10.2021 12:29:01

987 erhältst Du mit:
{=SUMME(ISTZAHL(VERGLEICH(ZEILE(X$1:X$12);MONAT(D20+ZEILE(INDIREKT("X1:X"&E20-D20)));0))*F$4:F$15)}

nach oben  nach unten

Betrifft: AW: ja, irgendwas machst Du falsch ?
von: mike49
Geschrieben am: 14.10.2021 13:29:11

Hallo WF,
ich habe doch die Mustermappe hochgeladen.
Gib mal in F21 deine Array-Formel ein. Demnach müsste als Ergebnis 987 angezeigt werden. Klappt das bei dir?
Gruß
mike49

nach oben  nach unten

Betrifft: wir drehn uns im Kreis
von: WF
Geschrieben am: 14.10.2021 13:39:33

Ich hab eine von 2 Februarzeilen gelöscht.
2 mal Februar ist Unsinn.

nach oben  nach unten

Betrifft: AW: wir drehn uns im Kreis
von: mike49
Geschrieben am: 14.10.2021 13:57:01

Schade. Irgendwie krieg ich das nicht hin.
Klappt's bei dir mit meiner Mustermappe?
LG
mike49

nach oben  nach unten

Betrifft: ja, nach Löschung einer Februarzeile
von: WF
Geschrieben am: 14.10.2021 14:06:29

.

nach oben  nach unten

Betrifft: AW: ja, nach Löschung einer Februarzeile
von: mike49
Geschrieben am: 14.10.2021 14:46:17

Ja! Das klappt jetzt!
Wie lautet jetzt noch die Wennabfrage in E5, dass bei einem Schaltjahr für Februar dort 29 angezeigt wird?
LG
mike49

nach oben  nach unten

Betrifft: =WENN(REST(F1;4)=0;29;28)
von: WF
Geschrieben am: 14.10.2021 15:13:14

eingedampft:
=28+(REST(F1;4)=0)
ist von 1901 bis 2099 richtig - sollte Dir langen.
WF

nach oben  nach unten

Betrifft: AW: =WENN(REST(F1;4)=0;29;28)
von: mike49
Geschrieben am: 14.10.2021 18:16:21

Hallo WF,
das klappt jetzt so wie ich es gewollt habe! 😊
Danke für deine Hilfe und Geduld! 👏
Liebe Grüße
mike49

Excel-Beispiele zum Thema "Gradtagzahlen berechnen"