Bereich_Verschieben und S-/W-Verweis

nach unten

Betrifft: Bereich_Verschieben und S-/W-Verweis
von: Uwe
Geschrieben am: 14.10.2021 01:57:20

Grüß Gott, liebe Spezialistengemeinde!
Ich habe ein Problem bei der Berechnung einer Zeitdifferenz (wie lange war die Haltedauer eines Wertpapieres). Das eine Datum kann ich recht einfach aus einer Tabelle entnehmen. Das andere Datum allerdings befindet sich zwar immer in der gleichen Spalte aber immer unterschiedlicher Zeile. Es gäbe aber einen festen Bezugspunkt. Und an der Stelle versage ich. Nun könnte ich die passende Formel für die Zeitdifferenz mit der Hand eintragen, aber die Tabelle hat im Original rund 72.000 Zeilen.

Meine Idee wäre nund ungeähr folgende: Excel müßte also für die Berechnung jeweils von der letzten Zeile pro ISIN, die immer auf 0 Bestand steht (hier also Zeile 6 und Zeile12) ausgegangen werden. Der erste Datumwert wäre dann in der gleichen Zeile in Spalte A. Schwieriger wird es mit dem zweiten Datumswert. Hier müßte Excel dann hochlaufen bis zur nächsten Null, in Spalte A springen und das Datum aus der darunter liegenden Zeile nehmen. Also von D12 ausgehend über D10 und A10 um dann den Wert aus A11 zu nehmen.
Hat jemand eine Idee, wie ich da rangehe...? Hier der Link: https://www.herber.de/bbs/user/148610.xlsx
Mit bestem Dank und frdl. Gruß
Harvey

nach oben  nach unten

Betrifft: AW: als Formel nur mit VERWEIS() und WENN() ...
von: neopa C
Geschrieben am: 14.10.2021 14:01:30

Hallo Harvey ,
... ich geh davon aus, dass es eher nur eine einmalige Berechnung ist (weil bei einer derartigen Menge an auszuwertenden Datensätzen eine Formellösung schon etwas länger rechnen wird) und die Daten in Spalte A:B sortiert sind und zwar zuerst nach Spalte B und danach für Spalte A aufwärts.
Dann folgende Formel: in E2: =WENN(D2*A2;"";A2-VERWEIS(9;1/(D$1:D1=0);A$2:A$4)) und diese nach unten kopieren.
Gruß Werner
.. , - ...

nach oben  nach unten

Betrifft: AW: hatte noch vergessen mitzuteilen ...
von: neopa C
Geschrieben am: 14.10.2021 14:27:12

Hallo,
... dass ich in D1 eine 0 mit benutzerdefinierten Zahlenformat: ;;"Bestand" eingeschrieben habe.
Gruß Werner
.. , - ...