Microsoft Excel

Herbers Excel/VBA-Archiv

zählen und kopieren

Betrifft: zählen und kopieren
von: Alex
Geschrieben am: 16.04.2003 - 11:09:53

hallo,

ich möchte gerne eine exceltabelle automatisieren.
in tabelle1 werden immer eine unterschiedliche anzahl von daten eingefügt. jetzt möchte ich gerne die anzahl der zeilen in tabelle1 ermitteln und dann in tabelle2 die zelle A1 entsprechend der anzahl aus tabelle1 bis A? kopieren.

danke für jeden tip....

greetz

  

Re: zählen und kopieren
von: Frederik Fuhrmann
Geschrieben am: 16.04.2003 - 12:46:23

Hallo!

Range("a1:a" & Range("a65536").End(xlUp).Row).Copy Sheets("Tabelle2").Range("a1")

Gruß
F.

  

Re: zählen und kopieren
von: Fritz
Geschrieben am: 16.04.2003 - 12:50:23

Ich kann Dir nur über eine Umweg helfen.

Ermittle rechts außerhalb des Druckbereichs ZB in Spalte Z für jede Zeile, in die Daten geschrieben werden können:

=wenn(a1="";0;1)


Kopier die Formel also in alle Zeilen z.B. 500, die theoretisch links beschrieben werden können.

Auf Tabelle2 kommt dann in A1 die Formel:

=SUMME(Tabelle1!Z1:Z500)

Das könnte gehen.

  

Danke
von: Stefan
Geschrieben am: 16.04.2003 - 13:00:55

...funktioniert wunderbar

 

Beiträge aus den Excel-Beispielen zum Thema "zählen und kopieren"