Microsoft Excel

Herbers Excel/VBA-Archiv

Summe wenn

    Betrifft: Summe wenn von: Thomas
    Geschrieben am: 01.09.2003 14:21:46

    Hallo zusammen,

    eine Frage an die Experten:

    in der Spalte A habe ich in den Zeilen 1 bis 4 Werte zu stehen. In der Spalte B stehen in den selben Zeilen ja oder nein dahinter.

    A B
    1 200 ja
    2 300 nein
    3 100 ja
    4 200 ja


    Nun sollen in A5 alle Zellen der Splate A summiert werden, welche in der Spalte B ein ja zu stehen haben.

    Könnt ihr helfen ??

    Danke vorab

    Thomas

      


    Betrifft: AW: Summe wenn von: Mac4
    Geschrieben am: 01.09.2003 14:37:21

    Hallo Thomas,

    so sollte es gehen:

    =SUMMENPRODUKT((A1:A4)*(B1:B4="ja"))


      


    Betrifft: AW: Summe wenn von: Thomas
    Geschrieben am: 01.09.2003 14:51:07

    Vielen Dank!

    läuft prima!!


      


    Betrifft: AW: Summe wenn = SUMMEWENN von: Boris
    Geschrieben am: 01.09.2003 14:43:32

    Hi Thomas,

    ...benutze einfach die gleichlautende Funktion:
    =SUMMEWENN(B:B;"ja";A:A)

    Grüße Boris

    P.S.: Wobei die SUMMENPRODUKT-Lösung natürlich auch funktioniert.