Microsoft Excel

Herbers Excel/VBA-Archiv

MITTELWERT ausrechnen

    Betrifft: MITTELWERT ausrechnen von: TOM
    Geschrieben am: 03.09.2003 07:46:44

    Morgen zusammen

    Ich habe einen Bereich A1:E121 in denen Werte stehen. Aus diesem Bereich möchte ich den Mittelwert berechnen mit einer Funktion. Mein Problem ist aber das einige Werte in meinem Bereich auch Nullen sind und die möchte ich als fehlende Werte behandeln.

    Wie bringe ich meine Funktion dazu nur die Zahlenwerte zu zählen??
    Besten Dank für Eure Hilfe

    Gruss TOM

      


    Betrifft: AW: MITTELWERT ausrechnen von: galenzo
    Geschrieben am: 03.09.2003 08:01:20

    Benütze eine Array-Formal derart:
    {=MITTELWERT(WENN(A1:E121<>0;A1:E121))}

    (wie immer der Hinweis: Die geschweiften Klammern nicht direkt eingeben, sondern die Formel durch SHIFT+STRG+ENTER abschließen)


     

    Beiträge aus den Excel-Beispielen zum Thema " MITTELWERT ausrechnen"