Das Archiv des Excel-Forums

Sollstunden als Formel???

Bild

Betrifft: Sollstunden als Formel???
von: Selma

Geschrieben am: 19.09.2003 13:31:33

Hi Leute,

ich brauche kurze Hilfe:

in Q10 habe ich stehen das Monat als Zahl z.B. 9
in U10 das Jahr als Zahl z.B. 2003
in B12 diese Formel (Benutzerdefiniertes Format: T): =WENN(Q10*U10;DATUM(U10;Q10;1);"")
in C12 diese Formel (Benutzerdefiniertes Format: T): =WENN(B$12="";"";WENN(MONAT(B$12+1)<>$Q$10;"";B$12+1))
in D12 diese Formel (Benutzerdefiniertes Format: T): =WENN(C$12="";"";WENN(MONAT(C$12+1)<>$Q$10;"";C$12+1))
...
...
bis AF12 diese Formel (Benutzerdefiniertes Format: T): =WENN(AE$12="";"";WENN(MONAT(AE$12+1)<>$Q$10;"";AE$12+1))

in B13 diese Formel (Benutzerdefiniertes Format: TTT): =WENN($Q$10="";"";B$12)
in C13 diese Formel (Benutzerdefiniertes Format: TTT): =WENN($Q$10="";"";C$12)
...
...
bis AF13 diese Formel (Benutzerdefiniertes Format: TTT): =WENN($Q$10="";"";AF$12)

In Zelle AH44 möchte ich als Ergebniss Sollstunden für das Monat haben.

Die Tage: Mo, Di, Mi, Do im Bereich B13:AF13 sollen mit 7,5 und Fr mit 7,0 berechnet werden.

Das heisst jetzt für das Monat September 2003 sollte in AH44 "163" stehen.


Vielen Dank vorab...

Gruß
Selma
Bild


Betrifft: AW: Sollstunden als Formel???
von: Panicman
Geschrieben am: 19.09.2003 22:53:14

Hallo Selma,

versuchs mal hiermit
=SUMMENPRODUKT(((WOCHENTAG(INDIREKT("B12:"&ADRESSE(12;VERGLEICH(;A12:AF12;-1)));2)<5)*7,5)+((WOCHENTAG(INDIREKT("B12:"&ADRESSE(12;VERGLEICH(;A12:AF12;-1)));2)=5)*7))


Gruß
Holger


Bild


Betrifft: AW: Sollstunden als Formel???
von: Selma
Geschrieben am: 22.09.2003 10:50:31

Danke Holger, es funzt....

Gruß
Selma


Bild


Betrifft: Bitteschön, hab gern geholfen ! o.T.
von: Panicman
Geschrieben am: 22.09.2003 13:45:38




 Bild

Excel-Beispiele zum Thema " Sollstunden als Formel???"

Anzeigen von Werten und Formeln download Zeile einfügen und Formeln und Werte übernehmen download
Formeln mit Zelladressen speichern download Zeilenumbruch in Formel erzwingen download
Aktueller Arbeitsblattname in Formel download Variable in Formel einbauen download
Ein Zeichen in einer Formel suchen download Variable in Excel-Formel einbauen. download
Summenformel unter Zahlenreihe eintragen download Arbeitszeittabelle und SVERWEIS-Formel download
Zeilen mit leeren Formeln beim Druck unterdrücken download Ausgabe einer benutzerdefinierten Funktion in Matrixformel download
Listung der mit der Formel KOMBINATIONEN() ermittelten Elemente download Alle Formeln und Links in Werte wandeln download
Formel bis zur letzten Zeile der Nebenspalte kopieren download Summenformel per VBA eintragen download
Namen löschen ohne Formeln zu zerstören download Anzeige der Formel mit Quellblattangabe download
Alle Formeln und Zahlen löschen download Textstring in berechenbare Formel umwandeln download
Spielpaarungen von Vorrunde bis Finale durch Formeln ermitteln download Zahlenstring mit Formel auslesen und Fehlermeldung verhindern download
Wahrheitsprüfung einer mit Zellwerten zusammengestzten Formel download SVERWEIS-Formel über mehrere Fundstellen download
Mittelwert einer Zahlenreihe bis zur Zeile mit der Formel download SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele download
Beispiel für die Anwendung der SUMMEWENN-FORMEL download Datei auswählen, öffnen und Formelsuchdialog anzeigen download
Formelbereich in Einzelelemente aufschlüsseln download Signal, wenn sich Formelwert über eine Grenze bewegt download
Formeleingabe über ShortCut download UserForm-Aufruf, wenn Formel-Wert Grenze überschreitet download
In Abhängigkeit von einem Formelwert Makro starten download In Abhängigkeit von einem Formelwert Mail mit Outlook versenden download
Anzahl nach 2 Kriterien ermitteln mit DB-Funktion und MatrixFormel download Sortierung mit Formel-Leerstrings am Ende download
Nach Formelkalkulation Zellwert erhöhen download Markierung von Formeln über bedingte Formatierung download
Zellschutz nur für Formeln download Text in Formel und Formel in Text download
Blatt ohne Code, Steuerelement und Formeln speichern download Zählen von in einer Formel vorkommenden Zahlen download
Temporärer VBA-Einsatz einer Matrixformel download Eintragen von Matrixformeln in eine Jahres-/Monatsmatrix download
Dynamischer Blattname in SVERWEIS-Formel download Bei Eintrag Übernahme der Formel aus Nebenzelle download
TextBox-Eingabe mit Formel weiterberechnen und zurückgeben download Formeltexte anzeigen download
Formel zur Ermittlung von Ostersonntag download Ermittlung von Datenbank- und Array-Formelergebnissen per VBA download