Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
312to316
312to316
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Sollstunden als Formel???

Sollstunden als Formel???
19.09.2003 13:31:33
Selma
Hi Leute,

ich brauche kurze Hilfe:

in Q10 habe ich stehen das Monat als Zahl z.B. 9
in U10 das Jahr als Zahl z.B. 2003
in B12 diese Formel (Benutzerdefiniertes Format: T): =WENN(Q10*U10;DATUM(U10;Q10;1);"")
in C12 diese Formel (Benutzerdefiniertes Format: T): =WENN(B$12="";"";WENN(MONAT(B$12+1)<>$Q$10;"";B$12+1))
in D12 diese Formel (Benutzerdefiniertes Format: T): =WENN(C$12="";"";WENN(MONAT(C$12+1)<>$Q$10;"";C$12+1))
...
...
bis AF12 diese Formel (Benutzerdefiniertes Format: T): =WENN(AE$12="";"";WENN(MONAT(AE$12+1)<>$Q$10;"";AE$12+1))

in B13 diese Formel (Benutzerdefiniertes Format: TTT): =WENN($Q$10="";"";B$12)
in C13 diese Formel (Benutzerdefiniertes Format: TTT): =WENN($Q$10="";"";C$12)
...
...
bis AF13 diese Formel (Benutzerdefiniertes Format: TTT): =WENN($Q$10="";"";AF$12)

In Zelle AH44 möchte ich als Ergebniss Sollstunden für das Monat haben.

Die Tage: Mo, Di, Mi, Do im Bereich B13:AF13 sollen mit 7,5 und Fr mit 7,0 berechnet werden.

Das heisst jetzt für das Monat September 2003 sollte in AH44 "163" stehen.


Vielen Dank vorab...

Gruß
Selma

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Sollstunden als Formel???
19.09.2003 22:53:14
Panicman
Hallo Selma,

versuchs mal hiermit
=SUMMENPRODUKT(((WOCHENTAG(INDIREKT("B12:"&ADRESSE(12;VERGLEICH(;A12:AF12;-1)));2)<5)*7,5)+((WOCHENTAG(INDIREKT("B12:"&ADRESSE(12;VERGLEICH(;A12:AF12;-1)));2)=5)*7))


Gruß
Holger
AW: Sollstunden als Formel???
22.09.2003 10:50:31
Selma
Danke Holger, es funzt....

Gruß
Selma
Bitteschön, hab gern geholfen ! o.T.
22.09.2003 13:45:38
Panicman

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige