Das Archiv des Excel-Forums

Rangliste mit Excel

Bild

Betrifft: Rangliste mit Excel
von: Toto

Geschrieben am: 19.09.2003 14:35:03

Hallo,

ich muss eine Rangliste mit Excel erstellen.
Habe in einer Tabelle die Prozente ausgerechnet,
in einer anderen Tabelle, habe ich mir mit
"KGRÖSSTE" die Prozente in Reihenfolge aufgelistet.
Nun muss ich die Namen und div. andere Daten
neben die Prozente setzen, was ich eigentlich
mit SVERWEIS machen wollte.
NUr habe ich ein PRoblem bei Personen die die
gleichen Prozente haben.

Kann mir jemand helfen?

DAnke schon mal im VOraus.

Gruß
TOTO
Bild


Betrifft: AW: Rangliste mit Excel
von: Detlef
Geschrieben am: 19.09.2003 14:59:19

Hallo TOTO,
gibt es noch ander kriterien wonach man die rangliste erstellt?
sowas wie höchste summe oder kleinster unterschied bei den einzelnen auszuwertenden feldern.
wenn ja schick doch die datei.
Gruß Detlef


Bild


Betrifft: AW: Rangliste mit Excel
von: TOTO
Geschrieben am: 19.09.2003 15:16:09

Hallo Detlef,

danke für Deine Antwort. Leider kann ich Dir
Datei nicht schicken. Sind Daten mit drin
die nicht unbedingt öffentlich sind.

Man nehme an:
1. Tabelle
unsortiert
1 Spalte 2 Spalte 3 Spalte 4 Spalte
Prozente Prämie Rest aus letztem Jahr Name

2. Tabelle (wäre dann die Rangliste)
sortiert nach Prozenten und nach Nachname

1 spalte 2 spalte 3spalt 4 Spalte 5 Spalte
Prozente Name Prämie Rest gesamt Prämie

Habe jetzt mal mit Rang probiert, funktionier auch nicht.
Muss ja bei gleichen Prozenten verschiede Name haben, und
er gibt mir bei z.B. 50% immer den ersten Namen den er
findet.


Bild


Betrifft: mit Hilfsspalte
von: Günther Oppold
Geschrieben am: 19.09.2003 15:35:51

Hi Toto,

ich würde, der Einfachheit halber mit einer Hilfsspalte arbeiten:
Tabelle1: AA2: =A2-Zeile()/100000

in Tabelle2:
AA2: =kgrösste(Tabelle1!AA$2:AA$999;Zeile()-1) - runterziehen
A2: =index(Tabelle1!A$2:A$999;vergleich($AA$2;Tabelle1!$AA$2:$AA$999;0) Formel nach rechts und nach unten ziehen.

das Ergebnis ist nach Prozenten absteigend.

Wenn Du Tabelle1 nach Namen sortieren kannst - ist auch Tabelle 2 nach Namen sortiert.

Sonst musst Du VBA bemühen - aber(leider) nicht mit mir ;-(

Gruß
Günther


Bild


Betrifft: AW: mit Hilfsspalte
von: Norbert
Geschrieben am: 20.09.2003 09:17:44

lasse dir doch den Rang berechnen.
Mit
{=SUMME(WENN(B1<$B$1:$B$10;1;0))+1}
müßte es klappen.
Im obigen Beispiel ist in Zelle B1 der Einzelwert und die Gesamtliste geht von B1 bis B10.
Excel zählt dann immer 1 dazu, wenn es in dem Bereich einen niederigen Wert findet.
die +1 sind deswegen, damit Excel nicht bei null beginnt.
Vergiss nicht bei der Eingabe mit >ALT> und abzuschließen, damit es zum Array wird (geschwungene Klammern).

Gruß
Norbert


Bild


Betrifft: AW: Rangliste mit Excel
von: ChrisL
Geschrieben am: 19.09.2003 15:08:21

Hi Toto

oder hast du es auch schonmal mit der Funktion RANG versucht?

Gruss
Chris


 Bild

Excel-Beispiele zum Thema " Rangliste mit Excel"

Skatrangliste erstellen download